source: projects/specs/trunk/p/python-simplejson/python-simplejson-vl.spec @ 8158

Revision 8158, 5.8 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3%global _use_internal_dependency_generator 0
4%global __find_provides /bin/sh -c "%{_rpmconfigdir}/find-provides | grep -v -E '(_speedups.so)' || /bin/true"
5%global __find_requires /bin/sh -c "%{_rpmconfigdir}/find-requires | grep -v -E '(_speedups.so)' || /bin/true"
6
7Name:           python-simplejson
8
9Version:        2.1.2
10Release:        3%{?_dist_release}
11Summary:        Simple, fast, extensible JSON encoder/decoder for Python
12
13Group:          System Environment/Libraries
14# The main code is licensed MIT.
15# The docs include jquery which is licensed MIT or GPLv2
16License: MIT and (MIT or GPLv2)
17URL:            http://undefined.org/python/#simplejson
18Source0:        http://pypi.python.org/packages/source/s/simplejson/simplejson-%{version}.tar.gz
19BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
20
21BuildRequires:  python-devel
22BuildRequires:  python-setuptools
23BuildRequires:  python-nose
24
25Vendor: Project Vine
26Distribution: Vine Linux
27
28%description
29simplejson is a simple, fast, complete, correct and extensible JSON
30<http://json.org> encoder and decoder for Python 2.5+. It is pure Python code
31with no dependencies, but includes an optional C extension for a serious speed
32boost.
33
34simplejson is the externally maintained development version of the json library
35included with Python 2.6 and Python 3.0, but maintains backwards compatibility
36with Python 2.5.
37
38The encoder may be subclassed to provide serialization in any kind of
39situation, without any special support by the objects to be serialized
40(somewhat like pickle).
41
42The decoder can handle incoming JSON strings of any specified encoding (UTF-8
43by default).
44
45
46%prep
47%setup -q -n simplejson-%{version}
48
49
50%build
51%{__python} setup.py build
52
53
54%install
55%__rm -rf $RPM_BUILD_ROOT
56%{__python} setup.py install --skip-build --root=$RPM_BUILD_ROOT
57
58%check
59nosetests -q
60
61%clean
62%__rm -rf $RPM_BUILD_ROOT
63
64
65%files
66%defattr(-,root,root,-)
67%doc docs LICENSE.txt
68%dir %{python_sitearch}/simplejson
69%{python_sitearch}/simplejson-*.egg-info
70%{python_sitearch}/simplejson/*.py*
71%{python_sitearch}/simplejson/tests/*.py*
72%{python_sitearch}/simplejson/_speedups.so
73
74
75%changelog
76* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.1.2-3
77- rebuild with VineSeed environment
78
79* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.1.2-2
80- rebuild with python-2.7.2
81
82* Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> - 2.1.2-1
83- updated simplejson to 2.1.2
84
85* Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 2.1.1-1
86- initial build based on Fedora development
87
88* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 2.1.1-3
89- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
90
91* Wed Jun 30 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 2.1.1-2
92- Filter unnecessary provides
93- License tag update
94- Minor spec file cleanups
95
96* Mon Jun 21 2010 Kyle VanderBeek <kylev@kylev.com> - 2.1.1-1
97- Update to 2.1.1
98
99* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.9-3
100- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
101
102* Fri Jun  5 2009 Kyle VanderBeek <kylev@kylev.com> - 2.0.9-2
103- Remove ill-advised gcc BuildRequires
104
105* Thu Jun  4 2009 Kyle VanderBeek <kylev@kylev.com> - 2.0.9-1
106- Update to 2.0.9
107- Make sure to require gcc to the speedups get compiled
108- Fix description since we're not "pure" python
109- Change to pypi instead of cheesehop
110
111* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.7-2
112- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
113
114* Tue Jan 06 2009 Luke Macken <lmacken@redhat.com> 2.0.7-1
115- Update to 2.0.7
116
117* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.0.3-3
118- Rebuild for Python 2.6
119
120* Thu Oct 23 2008 Luke Macken <lmacken@redhat.com> 2.0.3-2
121- Use nose to run the simplejson test suite
122
123* Mon Oct 20 2008 Tom "spot" Callaway <tcallawa@redhat.com> 2.0.3-1
124- update to 2.0.3
125
126* Wed Oct 01 2008 Luke Macken <lmacken@redhat.com> - 2.0.1-1
127- Update to 2.0.1, which contains many optimizations and bugfixes
128
129* Wed Sep 24 2008 Luke Macken <lmacken@redhat.com> - 1.9.3-1
130- Update to 1.9.3, which includes a significant decoding speed boost, and
131  various bug fixes.
132
133* Tue May 06 2008 Luke Macken <lmacken@redhat.com> - 1.9.1-1
134- Update to 1.9.1
135
136* Wed Apr 02 2008 Luke Macken <lmacken@redhat.com> - 1.8.1-1
137- Update to 1.8.1
138
139* Thu Feb 28 2008 Luke Macken <lmacken@redhat.com> - 1.7.4-1
140- Update to 1.7.4
141
142* Fri Feb  8 2008 Luke Macken <lmacken@redhat.com> - 1.7.3-3
143- Rebuild for gcc 4.3
144
145* Wed Oct 24 2007 Luke Macken <lmacken@redhat.com> - 1.7.3-2
146- Include the LICENSE.txt
147
148* Wed Oct  3 2007 Luke Macken <lmacken@redhat.com> - 1.7.3-1
149- 1.7.3
150
151* Sun Sep  2 2007 Luke Macken <lmacken@redhat.com> - 1.7.1-3
152- Update for python-setuptools changes in rawhide
153
154* Tue Aug 21 2007 Luke Macken <lmacken@redhat.com> - 1.7.1-2
155- Rebuild
156
157* Sun Jul  8 2007 Luke Macken <lmacken@redhat.com> - 1.7.1-1
158- 1.7.1
159
160* Wed Mar 21 2007 Luke Macken <lmacken@redhat.com> - 1.7-2
161- Use python_sitearch instead of sitelib
162
163* Tue Mar 20 2007 Luke Macken <lmacken@redhat.com> - 1.7-1
164- 1.7 (Bug #233212)
165
166* Sat Mar  3 2007 Luke Macken <lmacken@redhat.com> - 1.5
167- 1.5
168
169* Sat Dec  9 2006 Luke Macken <lmacken@redhat.com> - 1.4-4
170- Add python-devel to BuildRequires
171
172* Sat Dec  9 2006 Luke Macken <lmacken@redhat.com> - 1.4-2
173- Rebuild for new python
174
175* Fri Nov 24 2006 Luke Macken <lmacken@redhat.com> - 1.4-1
176- 1.4
177
178* Sun Sep  3 2006 Luke Macken <lmacken@redhat.com> - 1.3-4
179- Rebuild for FC6
180
181* Mon Aug 14 2006 Luke Macken <lmacken@redhat.com> - 1.3-3
182- Include .pyo's instead of just ghosting them
183
184* Wed Jul 12 2006 Luke Macken <lmacken@redhat.com> - 1.3-2
185- Add --single-version-externally-managed flag to install
186
187* Mon Jul 10 2006 Luke Macken <lmacken@redhat.com> - 1.3-1
188- Initial package
Note: See TracBrowser for help on using the repository browser.