source: projects/specs/trunk/p/python-simplejson/python-simplejson-vl.spec @ 8420

Revision 8420, 5.9 KB checked in by kudoh, 10 years ago (diff)
RevLine 
[1741]1%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
[521]2
[1741]3%global _use_internal_dependency_generator 0
4%global __find_provides /bin/sh -c "%{_rpmconfigdir}/find-provides | grep -v -E '(_speedups.so)' || /bin/true"
5%global __find_requires /bin/sh -c "%{_rpmconfigdir}/find-requires | grep -v -E '(_speedups.so)' || /bin/true"
[521]6
[1741]7Name:           python-simplejson
[521]8
[8420]9Version:        3.4.1
10Release:        1%{?_dist_release}
[1741]11Summary:        Simple, fast, extensible JSON encoder/decoder for Python
[521]12
[1741]13Group:          System Environment/Libraries
14# The main code is licensed MIT.
15# The docs include jquery which is licensed MIT or GPLv2
16License: MIT and (MIT or GPLv2)
17URL:            http://undefined.org/python/#simplejson
18Source0:        http://pypi.python.org/packages/source/s/simplejson/simplejson-%{version}.tar.gz
19BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
[521]20
[1741]21BuildRequires:  python-devel
22BuildRequires:  python-setuptools
23BuildRequires:  python-nose
[521]24
[8158]25Vendor: Project Vine
26Distribution: Vine Linux
[1741]27
[521]28%description
[1741]29simplejson is a simple, fast, complete, correct and extensible JSON
30<http://json.org> encoder and decoder for Python 2.5+. It is pure Python code
31with no dependencies, but includes an optional C extension for a serious speed
32boost.
[521]33
[1741]34simplejson is the externally maintained development version of the json library
35included with Python 2.6 and Python 3.0, but maintains backwards compatibility
36with Python 2.5.
[521]37
38The encoder may be subclassed to provide serialization in any kind of
39situation, without any special support by the objects to be serialized
40(somewhat like pickle).
41
[1741]42The decoder can handle incoming JSON strings of any specified encoding (UTF-8
43by default).
[521]44
45
46%prep
47%setup -q -n simplejson-%{version}
48
49
50%build
51%{__python} setup.py build
52
53
54%install
[1741]55%__rm -rf $RPM_BUILD_ROOT
56%{__python} setup.py install --skip-build --root=$RPM_BUILD_ROOT
[521]57
58%check
59nosetests -q
60
61%clean
[1741]62%__rm -rf $RPM_BUILD_ROOT
[521]63
64
65%files
66%defattr(-,root,root,-)
[8420]67%doc CHANGES.txt LICENSE.txt
[521]68%dir %{python_sitearch}/simplejson
[1741]69%{python_sitearch}/simplejson-*.egg-info
[521]70%{python_sitearch}/simplejson/*.py*
71%{python_sitearch}/simplejson/tests/*.py*
72%{python_sitearch}/simplejson/_speedups.so
73
74
75%changelog
[8420]76* Sat May 03 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.1-1
77- new upstream release
78
[8158]79* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.1.2-3
80- rebuild with VineSeed environment
81
[5701]82* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.1.2-2
83- rebuild with python-2.7.2
84
[2258]85* Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> - 2.1.2-1
86- updated simplejson to 2.1.2
87
[1741]88* Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 2.1.1-1
89- initial build based on Fedora development
[521]90
[1741]91* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 2.1.1-3
92- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
[521]93
[1741]94* Wed Jun 30 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 2.1.1-2
95- Filter unnecessary provides
96- License tag update
97- Minor spec file cleanups
98
99* Mon Jun 21 2010 Kyle VanderBeek <kylev@kylev.com> - 2.1.1-1
100- Update to 2.1.1
101
102* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.9-3
103- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
104
105* Fri Jun  5 2009 Kyle VanderBeek <kylev@kylev.com> - 2.0.9-2
106- Remove ill-advised gcc BuildRequires
107
108* Thu Jun  4 2009 Kyle VanderBeek <kylev@kylev.com> - 2.0.9-1
109- Update to 2.0.9
110- Make sure to require gcc to the speedups get compiled
111- Fix description since we're not "pure" python
112- Change to pypi instead of cheesehop
113
114* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.7-2
115- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
116
117* Tue Jan 06 2009 Luke Macken <lmacken@redhat.com> 2.0.7-1
118- Update to 2.0.7
119
[521]120* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.0.3-3
121- Rebuild for Python 2.6
122
123* Thu Oct 23 2008 Luke Macken <lmacken@redhat.com> 2.0.3-2
124- Use nose to run the simplejson test suite
125
126* Mon Oct 20 2008 Tom "spot" Callaway <tcallawa@redhat.com> 2.0.3-1
127- update to 2.0.3
128
129* Wed Oct 01 2008 Luke Macken <lmacken@redhat.com> - 2.0.1-1
130- Update to 2.0.1, which contains many optimizations and bugfixes
131
132* Wed Sep 24 2008 Luke Macken <lmacken@redhat.com> - 1.9.3-1
133- Update to 1.9.3, which includes a significant decoding speed boost, and
134  various bug fixes.
135
136* Tue May 06 2008 Luke Macken <lmacken@redhat.com> - 1.9.1-1
137- Update to 1.9.1
138
139* Wed Apr 02 2008 Luke Macken <lmacken@redhat.com> - 1.8.1-1
140- Update to 1.8.1
141
142* Thu Feb 28 2008 Luke Macken <lmacken@redhat.com> - 1.7.4-1
143- Update to 1.7.4
144
145* Fri Feb  8 2008 Luke Macken <lmacken@redhat.com> - 1.7.3-3
146- Rebuild for gcc 4.3
147
148* Wed Oct 24 2007 Luke Macken <lmacken@redhat.com> - 1.7.3-2
149- Include the LICENSE.txt
150
151* Wed Oct  3 2007 Luke Macken <lmacken@redhat.com> - 1.7.3-1
152- 1.7.3
153
154* Sun Sep  2 2007 Luke Macken <lmacken@redhat.com> - 1.7.1-3
155- Update for python-setuptools changes in rawhide
156
157* Tue Aug 21 2007 Luke Macken <lmacken@redhat.com> - 1.7.1-2
158- Rebuild
159
160* Sun Jul  8 2007 Luke Macken <lmacken@redhat.com> - 1.7.1-1
161- 1.7.1
162
163* Wed Mar 21 2007 Luke Macken <lmacken@redhat.com> - 1.7-2
164- Use python_sitearch instead of sitelib
165
166* Tue Mar 20 2007 Luke Macken <lmacken@redhat.com> - 1.7-1
167- 1.7 (Bug #233212)
168
169* Sat Mar  3 2007 Luke Macken <lmacken@redhat.com> - 1.5
170- 1.5
171
172* Sat Dec  9 2006 Luke Macken <lmacken@redhat.com> - 1.4-4
173- Add python-devel to BuildRequires
174
175* Sat Dec  9 2006 Luke Macken <lmacken@redhat.com> - 1.4-2
176- Rebuild for new python
177
178* Fri Nov 24 2006 Luke Macken <lmacken@redhat.com> - 1.4-1
179- 1.4
180
181* Sun Sep  3 2006 Luke Macken <lmacken@redhat.com> - 1.3-4
182- Rebuild for FC6
183
184* Mon Aug 14 2006 Luke Macken <lmacken@redhat.com> - 1.3-3
185- Include .pyo's instead of just ghosting them
186
187* Wed Jul 12 2006 Luke Macken <lmacken@redhat.com> - 1.3-2
188- Add --single-version-externally-managed flag to install
189
190* Mon Jul 10 2006 Luke Macken <lmacken@redhat.com> - 1.3-1
191- Initial package
Note: See TracBrowser for help on using the repository browser.