source: projects/specs/trunk/p/python-rpm-macros/python-rpm-macros-vl.spec @ 12367

Revision 12367, 5.7 KB checked in by tomop, 4 years ago (diff)

updated 5 packages

krb5-1.18-1

python-pip-20.0.2-1

python-requests-2.23.0-1

python-rpm-macros-3.8-1

python-setuptools-44.1.0-1

Line 
1%{!?rpmmacrodir:%global rpmmacrodir %{_sysconfdir}/rpm}
2
3Name:           python-rpm-macros
4Version:        3.8
5Release:        1%{?_dist_release}
6Summary:        The unversioned Python RPM macros
7Vendor:         Project Vine
8Distribution:   Vine Linux
9Packager:       tomop
10
11License:        MIT
12Source0:        macros.python
13Source1:        macros.python-srpm
14Source2:        macros.python2
15Source3:        macros.python3
16Source4:        macros.platform-python
17
18BuildArch:      noarch
19# For %%python3_pkgversion used in %%python_provide
20Requires:       python-srpm-macros
21Obsoletes:      python-macros < 3
22Provides:       python-macros = %{version}-%{release}
23
24%description
25This package contains the unversioned Python RPM macros, that most
26implementations should rely on.
27
28You should not need to install this package manually as the various
29python?-devel packages require it. So install a python-devel package instead.
30
31%package -n python-srpm-macros
32Summary:        RPM macros for building Python source packages
33
34%description -n python-srpm-macros
35RPM macros for building Python source packages.
36
37%package -n python2-rpm-macros
38Summary:        RPM macros for building Python 2 packages
39# Would need to be different for each release - worth it?
40#Conflicts:      python2-devel < 2.7.11-3
41Requires:       python-rpm-macros
42Requires:       python-srpm-macros
43
44%description -n python2-rpm-macros
45RPM macros for building Python 2 packages.
46
47%package -n python3-rpm-macros
48Summary:        RPM macros for building Python 3 packages
49# Would need to be different for each release - worth it?
50#Conflicts:      python3-devel < 3.5.1-3
51Requires:       python-rpm-macros
52Requires:       python-srpm-macros
53
54%description -n python3-rpm-macros
55RPM macros for building Python 3 packages.
56
57#%package -n platform-python-rpm-macros
58#Summary:        RPM macros for building Platform-Python packages
59
60#%description -n platform-python-rpm-macros
61#RPM macros for building Platform-Python packages.
62
63
64%prep
65
66%build
67
68%install
69mkdir -p %{buildroot}/%{rpmmacrodir}
70install -m 644 %{SOURCE0} %{SOURCE1} %{SOURCE2} %{SOURCE3} %{SOURCE4} \
71  %{buildroot}/%{rpmmacrodir}/
72
73
74%files
75%{rpmmacrodir}/macros.python
76
77%files -n python-srpm-macros
78%{rpmmacrodir}/macros.python-srpm
79
80%files -n python2-rpm-macros
81%{rpmmacrodir}/macros.python2
82
83%files -n python3-rpm-macros
84%{rpmmacrodir}/macros.python3
85
86#%files -n platform-python-rpm-macros
87#%{rpmmacrodir}/macros.platform-python
88%exclude %{rpmmacrodir}/macros.platform-python
89
90
91%changelog
92* Wed Apr 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.8-1
93- updated to 3.8.
94
95* Wed Oct 23 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3-26
96- updated macros.
97
98* Mon Dec 18 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3-25
99- fixed a typo.
100
101* Wed Sep 20 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3-24
102- fixed a path to install.
103
104* Tue Sep 19 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3-23
105- initial build for Vine Linux.
106
107* Wed Aug 02 2017 Tomas Orsava <torsava@redhat.com> - 3-22
108- Add platform-python macros (https://fedoraproject.org/wiki/Changes/Platform_Python_Stack)
109
110* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3-21
111- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
112
113* Fri Mar 03 2017 Michal Cyprian <mcyprian@redhat.com> - 3-20
114- Revert "Switch %%__python3 to /usr/libexec/system-python"
115  after the Fedora Change https://fedoraproject.org/wiki/Changes/Making_sudo_pip_safe
116  was postponed
117
118* Fri Feb 17 2017 Michal Cyprian <mcyprian@redhat.com> - 3-19
119- Switch %%__python3 to /usr/libexec/system-python
120
121* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3-18
122- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
123
124* Mon Jan 23 2017 Michal Cyprian <mcyprian@redhat.com> - 3-17
125- Add --no-deps option to py_install_wheel macros
126
127* Tue Jan 17 2017 Tomas Orsava <torsava@redhat.com> - 3-16
128- Added macros for Build/Requires tags using Python dist tags:
129  https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
130
131* Thu Nov 24 2016 Orion Poplawski <orion@cora.nwra.com> 3-15
132- Make expanded macros start on the same line as the macro
133
134* Wed Nov 16 2016 Orion Poplawski <orion@cora.nwra.com> 3-14
135- Fix %%py3_install_wheel (bug #1395953)
136
137* Wed Nov 16 2016 Orion Poplawski <orion@cora.nwra.com> 3-13
138- Add missing sleeps to other build macros
139- Fix build_egg macros
140- Add %%py_build_wheel and %%py_install_wheel macros
141
142* Tue Nov 15 2016 Orion Poplawski <orion@cora.nwra.com> 3-12
143- Add %%py_build_egg and %%py_install_egg macros
144- Allow multiple args to %%py_build/install macros
145- Tidy up macro formatting
146
147* Wed Aug 24 2016 Orion Poplawski <orion@cora.nwra.com> 3-11
148- Use %%rpmmacrodir
149
150* Tue Jul 12 2016 Orion Poplawski <orion@cora.nwra.com> 3-10
151- Do not generate useless Obsoletes with %%{?_isa}
152
153* Fri May 13 2016 Orion Poplawski <orion@cora.nwra.com> 3-9
154- Make python-rpm-macros require python-srpm-macros (bug #1335860)
155
156* Thu May 12 2016 Jason L Tibbitts III <tibbs@math.uh.edu> - 3-8
157- Add single-second sleeps to work around setuptools bug.
158
159* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 3-7
160- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
161
162* Thu Jan 14 2016 Orion Poplawski <orion@cora.nwra.com> 3-6
163- Fix typo in %%python_provide
164
165* Thu Jan 14 2016 Orion Poplawski <orion@cora.nwra.com> 3-5
166- Handle noarch python sub-packages (bug #1290900)
167
168* Wed Jan 13 2016 Orion Poplawski <orion@cora.nwra.com> 3-4
169- Fix python2/3-rpm-macros package names
170
171* Thu Jan 7 2016 Orion Poplawski <orion@cora.nwra.com> 3-3
172- Add empty %%prep and %%build
173
174* Mon Jan 4 2016 Orion Poplawski <orion@cora.nwra.com> 3-2
175- Combined package
176
177* Wed Dec 30 2015 Orion Poplawski <orion@cora.nwra.com> 3-1
178- Initial package
Note: See TracBrowser for help on using the repository browser.