source: projects/specs/trunk/p/python-rpm-macros/python-rpm-macros-vl.spec @ 12545

Revision 12545, 6.4 KB checked in by tomop, 3 years ago (diff)

rpm-4.16.1.2-1 and requirements

Line 
1Name:           python-rpm-macros
2Summary:        The unversioned Python RPM macros
3Version:        3.8
4Release:        2%{?_dist_release}
5Group:          programming
6Vendor:         Project Vine
7Distribution:   Vine Linux
8Packager:       tomop
9
10License:        MIT
11Source0:        macros.python
12Source1:        macros.python-srpm
13Source2:        macros.python2
14Source3:        macros.python3
15Source4:        macros.platform-python
16
17Source100:      python.attr
18Source101:      pythondist.attr
19Source102:      pythondistdeps.py
20# for apt (rich operators of dependencies are not supported)
21Patch1000:      pythondistdeps.py-downgrade.patch
22
23BuildArch:      noarch
24# For %%python3_pkgversion used in %%python_provide
25Requires:       python-srpm-macros
26Requires:       python3-packaging
27Obsoletes:      python-macros < 3
28Provides:       python-macros = %{version}-%{release}
29
30%description
31This package contains the unversioned Python RPM macros, that most
32implementations should rely on.
33
34You should not need to install this package manually as the various
35python?-devel packages require it. So install a python-devel package instead.
36
37
38%package -n python-srpm-macros
39Summary:        RPM macros for building Python source packages
40
41%description -n python-srpm-macros
42RPM macros for building Python source packages.
43
44
45%package -n python2-rpm-macros
46Summary:        RPM macros for building Python 2 packages
47# Would need to be different for each release - worth it?
48#Conflicts:      python2-devel < 2.7.11-3
49Requires:       python-rpm-macros
50Requires:       python-srpm-macros
51
52%description -n python2-rpm-macros
53RPM macros for building Python 2 packages.
54
55
56%package -n python3-rpm-macros
57Summary:        RPM macros for building Python 3 packages
58# Would need to be different for each release - worth it?
59#Conflicts:      python3-devel < 3.5.1-3
60Requires:       python-rpm-macros
61Requires:       python-srpm-macros
62
63%description -n python3-rpm-macros
64RPM macros for building Python 3 packages.
65
66
67#%package -n platform-python-rpm-macros
68#Summary:        RPM macros for building Platform-Python packages
69
70#%description -n platform-python-rpm-macros
71#RPM macros for building Platform-Python packages.
72
73
74%prep
75%setup -T -c
76cp -f %{SOURCE102} ./
77%patch1000 -p0
78
79
80%build
81
82
83%install
84mkdir -p %{buildroot}%{_rpmmacrodir}
85install -m 644 %{SOURCE0} %{SOURCE1} %{SOURCE2} %{SOURCE3} %{SOURCE4} \
86  %{buildroot}%{_rpmmacrodir}/
87
88mkdir -p %{buildroot}%{_fileattrsdir}
89install -m 644 %{SOURCE100} %{SOURCE101} \
90  %{buildroot}%{_fileattrsdir}/
91
92mkdir -p %{buildroot}%{_rpmconfigdir}
93install -m 755 pythondistdeps.py \
94  %{buildroot}%{_rpmconfigdir}/
95
96sed -i -e 's|#!/usr/bin/python|#!/usr/bin/python3|' \
97  %{buildroot}%{_rpmconfigdir}/pythondistdeps.py
98
99
100%files
101%{_rpmmacrodir}/macros.python
102%{_rpmconfigdir}/pythondistdeps.py
103%{_fileattrsdir}/*
104
105%files -n python-srpm-macros
106%{_rpmmacrodir}/macros.python-srpm
107
108%files -n python2-rpm-macros
109%{_rpmmacrodir}/macros.python2
110
111%files -n python3-rpm-macros
112%{_rpmmacrodir}/macros.python3
113
114#%files -n platform-python-rpm-macros
115#%{rpmmacrodir}/macros.platform-python
116%exclude %{_rpmmacrodir}/macros.platform-python
117
118
119%changelog
120* Mon Feb 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.8-2
121- added scripts.
122
123* Wed Apr 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.8-1
124- updated to 3.8.
125
126* Wed Oct 23 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3-26
127- updated macros.
128
129* Mon Dec 18 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3-25
130- fixed a typo.
131
132* Wed Sep 20 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3-24
133- fixed a path to install.
134
135* Tue Sep 19 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3-23
136- initial build for Vine Linux.
137
138* Wed Aug 02 2017 Tomas Orsava <torsava@redhat.com> - 3-22
139- Add platform-python macros (https://fedoraproject.org/wiki/Changes/Platform_Python_Stack)
140
141* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3-21
142- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
143
144* Fri Mar 03 2017 Michal Cyprian <mcyprian@redhat.com> - 3-20
145- Revert "Switch %%__python3 to /usr/libexec/system-python"
146  after the Fedora Change https://fedoraproject.org/wiki/Changes/Making_sudo_pip_safe
147  was postponed
148
149* Fri Feb 17 2017 Michal Cyprian <mcyprian@redhat.com> - 3-19
150- Switch %%__python3 to /usr/libexec/system-python
151
152* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3-18
153- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
154
155* Mon Jan 23 2017 Michal Cyprian <mcyprian@redhat.com> - 3-17
156- Add --no-deps option to py_install_wheel macros
157
158* Tue Jan 17 2017 Tomas Orsava <torsava@redhat.com> - 3-16
159- Added macros for Build/Requires tags using Python dist tags:
160  https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
161
162* Thu Nov 24 2016 Orion Poplawski <orion@cora.nwra.com> 3-15
163- Make expanded macros start on the same line as the macro
164
165* Wed Nov 16 2016 Orion Poplawski <orion@cora.nwra.com> 3-14
166- Fix %%py3_install_wheel (bug #1395953)
167
168* Wed Nov 16 2016 Orion Poplawski <orion@cora.nwra.com> 3-13
169- Add missing sleeps to other build macros
170- Fix build_egg macros
171- Add %%py_build_wheel and %%py_install_wheel macros
172
173* Tue Nov 15 2016 Orion Poplawski <orion@cora.nwra.com> 3-12
174- Add %%py_build_egg and %%py_install_egg macros
175- Allow multiple args to %%py_build/install macros
176- Tidy up macro formatting
177
178* Wed Aug 24 2016 Orion Poplawski <orion@cora.nwra.com> 3-11
179- Use %%rpmmacrodir
180
181* Tue Jul 12 2016 Orion Poplawski <orion@cora.nwra.com> 3-10
182- Do not generate useless Obsoletes with %%{?_isa}
183
184* Fri May 13 2016 Orion Poplawski <orion@cora.nwra.com> 3-9
185- Make python-rpm-macros require python-srpm-macros (bug #1335860)
186
187* Thu May 12 2016 Jason L Tibbitts III <tibbs@math.uh.edu> - 3-8
188- Add single-second sleeps to work around setuptools bug.
189
190* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 3-7
191- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
192
193* Thu Jan 14 2016 Orion Poplawski <orion@cora.nwra.com> 3-6
194- Fix typo in %%python_provide
195
196* Thu Jan 14 2016 Orion Poplawski <orion@cora.nwra.com> 3-5
197- Handle noarch python sub-packages (bug #1290900)
198
199* Wed Jan 13 2016 Orion Poplawski <orion@cora.nwra.com> 3-4
200- Fix python2/3-rpm-macros package names
201
202* Thu Jan 7 2016 Orion Poplawski <orion@cora.nwra.com> 3-3
203- Add empty %%prep and %%build
204
205* Mon Jan 4 2016 Orion Poplawski <orion@cora.nwra.com> 3-2
206- Combined package
207
208* Wed Dec 30 2015 Orion Poplawski <orion@cora.nwra.com> 3-1
209- Initial package
Note: See TracBrowser for help on using the repository browser.