source: projects/specs/trunk/p/python-rpm-macros/python-rpm-macros-vl.spec @ 11269

Revision 11269, 5.3 KB checked in by tomop, 6 years ago (diff)

python-rpm-macros-3-25

Line 
1%{!?rpmmacrodir:%global rpmmacrodir %{_sysconfdir}/rpm}
2
3Name:           python-rpm-macros
4Version:        3
5Release:        25%{?_dist_release}
6Summary:        The unversioned Python RPM macros
7Vendor:         Project Vine
8Distribution:   Vine Linux
9Packager:       tomop
10
11License:        MIT
12Source0:        macros.python
13Source1:        macros.python-srpm
14Source2:        macros.python2
15Source3:        macros.python3
16Source4:        macros.platform-python
17
18BuildArch:      noarch
19# For %%python3_pkgversion used in %%python_provide
20Requires:       python-srpm-macros
21Obsoletes:      python-macros < 3
22Provides:       python-macros = %{version}-%{release}
23
24%description
25This package contains the unversioned Python RPM macros, that most
26implementations should rely on.
27
28You should not need to install this package manually as the various
29python?-devel packages require it. So install a python-devel package instead.
30
31%package -n python-srpm-macros
32Summary:        RPM macros for building Python source packages
33
34%description -n python-srpm-macros
35RPM macros for building Python source packages.
36
37%package -n python2-rpm-macros
38Summary:        RPM macros for building Python 2 packages
39# Would need to be different for each release - worth it?
40#Conflicts:      python2-devel < 2.7.11-3
41
42%description -n python2-rpm-macros
43RPM macros for building Python 2 packages.
44
45%package -n python3-rpm-macros
46Summary:        RPM macros for building Python 3 packages
47# Would need to be different for each release - worth it?
48#Conflicts:      python3-devel < 3.5.1-3
49
50%description -n python3-rpm-macros
51RPM macros for building Python 3 packages.
52
53#%package -n platform-python-rpm-macros
54#Summary:        RPM macros for building Platform-Python packages
55
56#%description -n platform-python-rpm-macros
57#RPM macros for building Platform-Python packages.
58
59
60%prep
61
62%build
63
64%install
65mkdir -p %{buildroot}/%{rpmmacrodir}
66install -m 644 %{SOURCE0} %{SOURCE1} %{SOURCE2} %{SOURCE3} %{SOURCE4} \
67  %{buildroot}/%{rpmmacrodir}/
68
69
70%files
71%{rpmmacrodir}/macros.python
72
73%files -n python-srpm-macros
74%{rpmmacrodir}/macros.python-srpm
75
76%files -n python2-rpm-macros
77%{rpmmacrodir}/macros.python2
78
79%files -n python3-rpm-macros
80%{rpmmacrodir}/macros.python3
81
82#%files -n platform-python-rpm-macros
83#%{rpmmacrodir}/macros.platform-python
84
85
86%changelog
87* Mon Dec 18 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.25
88- fixed a typo.
89
90* Wed Sep 20 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3-24
91- fixed a path to install.
92
93* Tue Sep 19 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3-23
94- initial build for Vine Linux.
95
96* Wed Aug 02 2017 Tomas Orsava <torsava@redhat.com> - 3-22
97- Add platform-python macros (https://fedoraproject.org/wiki/Changes/Platform_Python_Stack)
98
99* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3-21
100- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
101
102* Fri Mar 03 2017 Michal Cyprian <mcyprian@redhat.com> - 3-20
103- Revert "Switch %%__python3 to /usr/libexec/system-python"
104  after the Fedora Change https://fedoraproject.org/wiki/Changes/Making_sudo_pip_safe
105  was postponed
106
107* Fri Feb 17 2017 Michal Cyprian <mcyprian@redhat.com> - 3-19
108- Switch %%__python3 to /usr/libexec/system-python
109
110* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3-18
111- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
112
113* Mon Jan 23 2017 Michal Cyprian <mcyprian@redhat.com> - 3-17
114- Add --no-deps option to py_install_wheel macros
115
116* Tue Jan 17 2017 Tomas Orsava <torsava@redhat.com> - 3-16
117- Added macros for Build/Requires tags using Python dist tags:
118  https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
119
120* Thu Nov 24 2016 Orion Poplawski <orion@cora.nwra.com> 3-15
121- Make expanded macros start on the same line as the macro
122
123* Wed Nov 16 2016 Orion Poplawski <orion@cora.nwra.com> 3-14
124- Fix %%py3_install_wheel (bug #1395953)
125
126* Wed Nov 16 2016 Orion Poplawski <orion@cora.nwra.com> 3-13
127- Add missing sleeps to other build macros
128- Fix build_egg macros
129- Add %%py_build_wheel and %%py_install_wheel macros
130
131* Tue Nov 15 2016 Orion Poplawski <orion@cora.nwra.com> 3-12
132- Add %%py_build_egg and %%py_install_egg macros
133- Allow multiple args to %%py_build/install macros
134- Tidy up macro formatting
135
136* Wed Aug 24 2016 Orion Poplawski <orion@cora.nwra.com> 3-11
137- Use %%rpmmacrodir
138
139* Tue Jul 12 2016 Orion Poplawski <orion@cora.nwra.com> 3-10
140- Do not generate useless Obsoletes with %%{?_isa}
141
142* Fri May 13 2016 Orion Poplawski <orion@cora.nwra.com> 3-9
143- Make python-rpm-macros require python-srpm-macros (bug #1335860)
144
145* Thu May 12 2016 Jason L Tibbitts III <tibbs@math.uh.edu> - 3-8
146- Add single-second sleeps to work around setuptools bug.
147
148* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 3-7
149- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
150
151* Thu Jan 14 2016 Orion Poplawski <orion@cora.nwra.com> 3-6
152- Fix typo in %%python_provide
153
154* Thu Jan 14 2016 Orion Poplawski <orion@cora.nwra.com> 3-5
155- Handle noarch python sub-packages (bug #1290900)
156
157* Wed Jan 13 2016 Orion Poplawski <orion@cora.nwra.com> 3-4
158- Fix python2/3-rpm-macros package names
159
160* Thu Jan 7 2016 Orion Poplawski <orion@cora.nwra.com> 3-3
161- Add empty %%prep and %%build
162
163* Mon Jan 4 2016 Orion Poplawski <orion@cora.nwra.com> 3-2
164- Combined package
165
166* Wed Dec 30 2015 Orion Poplawski <orion@cora.nwra.com> 3-1
167- Initial package
Note: See TracBrowser for help on using the repository browser.