source: projects/specs/trunk/p/python-requests/python-requests-vl.spec @ 11940

Revision 11940, 2.9 KB checked in by tomop, 5 years ago (diff)

python-sphinx-1.7.9-1 and requirements

Line 
1%define ver 2.20.1
2%define rel 2
3
4Summary: Python HTTP for Humans
5Name: python-requests
6Version: %{ver}
7Release: %{rel}%{?_dist_release}
8License: ASLv2
9Group: Development/Languages
10URL: https://pypi.python.org/pypi/requests
11
12Source0: https://pypi.python.org/packages/source/r/requests/requests-%{version}.tar.gz
13
14# Explicitly use the system certificates in ca-certificates.
15# https://bugzilla.redhat.com/show_bug.cgi?id=904614
16Patch0: patch-requests-certs.py-to-use-the-system-CA-bundle.patch
17
18# https://bugzilla.redhat.com/show_bug.cgi?id=1450608
19Patch2: Remove-tests-that-use-the-tarpit.patch
20
21# Use 127.0.0.1 not localhost for socket.bind() in the Server test
22# class, to fix tests in Koji's no-network environment
23# This probably isn't really upstreamable, because I guess localhost
24# could technically be IPv6 or something, and our no-network env is
25# a pretty odd one so this is a niche requirement.
26Patch3: requests-2.12.4-tests_nonet.patch
27
28# https://bugzilla.redhat.com/show_bug.cgi?id=1567862
29Patch4: Don-t-inject-pyopenssl-into-urllib3.patch
30
31BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
32Requires: python
33Requires: python-urllib3
34Requires: python-chardet
35Requires: python-idna
36BuildRequires: python-devel
37BuildRequires: python-rpm-macros
38BuildRequires: python-setuptools
39BuildRequires: python3-devel
40BuildRequires: python3-rpm-macros
41BuildRequires: python3-setuptools
42BuildArch: noarch
43
44Vendor: Project Vine
45Distribution: Vine Linux
46Packager: iwaim
47
48%description
49Requests is an Apache2 Licensed HTTP library, written in Python, for human beings.
50
51%package -n python3-requests
52Summary: Python HTTP for Humans
53Group: Development/Languages
54Requires: python3
55Requires: python3-urllib3
56Requires: python3-chardet
57Requires: python3-idna
58
59%description -n python3-requests
60Requests is an Apache2 Licensed HTTP library, written in Python, for human beings.
61
62%prep
63%autosetup -p1 -n requests-%{version}
64
65# Unbundle the certificate bundle from mozilla.
66rm -rf requests/cacert.pem
67
68# env shebang in nonexecutable file
69sed -i '/#!\/usr\/.*python/d' requests/certs.py
70
71%build
72%py_build
73%py3_build
74
75%install
76rm -rf $RPM_BUILD_ROOT
77%py_install
78%py3_install
79
80%clean
81rm -rf $RPM_BUILD_ROOT
82
83
84%files
85%defattr(-,root,root,-)
86%license LICENSE
87%doc README* HISTORY*
88%{python_sitelib}/requests
89%{python_sitelib}/requests-%{version}-py*.egg-info
90
91%files -n python3-requests
92%defattr(-,root,root,-)
93%license LICENSE
94%doc README* HISTORY*
95%{python3_sitelib}/requests
96%{python3_sitelib}/requests-%{version}-py*.egg-info
97
98%changelog
99* Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.20.1-2
100- fixed R:.
101- imported Patch0-4 from rawhide.
102
103* Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.20.1-1
104- new upstream release.
105- add python2 support.
106
107* Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.5.1-2
108- rebuild with python3-3.5.2
109
110* Sun Mar 22 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 2.5.1-1
111- Initial build.
Note: See TracBrowser for help on using the repository browser.