source: projects/specs/trunk/p/python-requests/python-requests-vl.spec @ 11932

Revision 11932, 1.9 KB checked in by tomop, 5 years ago (diff)

python-requests-2.20.1-1

Line 
1%define ver 2.20.1
2%define rel 1
3
4Summary: Python HTTP for Humans
5Name: python-requests
6Version: %{ver}
7Release: %{rel}%{?_dist_release}
8License: ASLv2
9Group: Development/Languages
10URL: https://pypi.python.org/pypi/requests
11Source0: https://pypi.python.org/packages/source/r/requests/requests-%{version}.tar.gz
12BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
13Requires: python
14BuildRequires: python-devel
15BuildRequires: python-rpm-macros
16BuildRequires: python-setuptools
17BuildRequires: python3-devel
18BuildRequires: python3-rpm-macros
19BuildRequires: python3-setuptools
20BuildArch: noarch
21
22Vendor: Project Vine
23Distribution: Vine Linux
24Packager: iwaim
25
26%description
27Requests is an Apache2 Licensed HTTP library, written in Python, for human beings.
28
29%package -n python3-requests
30Summary: Python HTTP for Humans
31Group: Development/Languages
32Requires: python3
33
34%description -n python3-requests
35Requests is an Apache2 Licensed HTTP library, written in Python, for human beings.
36
37%prep
38%setup -qc -n requests-%{ver}
39mv requests-%{ver} python2
40cp -a python2 python3
41
42%build
43pushd python2
44%py_build
45popd
46pushd python3
47%py3_build
48popd
49
50%install
51rm -rf $RPM_BUILD_ROOT
52pushd python2
53%py_install
54cp -f LICENSE README* HISTORY* ../
55popd
56pushd python3
57%py3_install
58popd
59
60%clean
61rm -rf $RPM_BUILD_ROOT
62
63
64%files
65%defattr(-,root,root,-)
66%license LICENSE
67%doc README* HISTORY*
68%{python_sitelib}/requests
69%{python_sitelib}/requests-%{version}-py*.egg-info
70
71%files -n python3-requests
72%defattr(-,root,root,-)
73%license LICENSE
74%doc README* HISTORY*
75%{python3_sitelib}/requests
76%{python3_sitelib}/requests-%{version}-py*.egg-info
77
78%changelog
79* Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.20.1-1
80- new upstream release.
81- add python2 support.
82
83* Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.5.1-2
84- rebuild with python3-3.5.2
85
86* Sun Mar 22 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 2.5.1-1
87- Initial build.
Note: See TracBrowser for help on using the repository browser.