source: projects/specs/trunk/p/python-rdflib/python-rdflib-vl.spec @ 5191

Revision 5191, 3.8 KB checked in by inagaki, 13 years ago (diff)

new: libzeitgeist, zeitgeist, zeitgeist-datahub, python-rdflib

Line 
1# The upstream test suite does not pass on recent versions of Fedora
2# See package review (bug 378841)
3# For now, we disable running the test suite:
4%define run_tests 0
5
6Name:           python-rdflib
7Summary:        Python library for working with RDF
8Version:        3.1.0
9Release:        2%{?_dist_release}
10
11Group:          Development/Languages
12License:        BSD
13URL:            http://rdflib.net
14
15Source0:        http://rdflib.googlecode.com/files/rdflib-%{version}.tar.gz
16
17BuildArch:      noarch
18
19BuildRoot:      %{_tmppath}/%{name}-%{version}-root
20BuildRequires:  python-devel
21BuildRequires:  python-setuptools
22
23%if %{run_tests}
24BuildRequires:  python-nose >= 0.9.2
25%endif
26
27%description
28RDFLib is a Python library for working with RDF, a simple yet powerful
29language for representing information.
30
31The library contains parsers and serializers for RDF/XML, N3, NTriples,
32Turtle, TriX and RDFa. The library presents a Graph interface which can
33be backed by any one of a number of store implementations, including
34memory, MySQL, Redland, SQLite, Sleepycat, ZODB and SQLObject.
35
36%prep
37%setup -q -n rdflib-%{version}
38
39%build
40%{__python} setup.py build
41
42%install
43rm -rf $RPM_BUILD_ROOT
44%{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
45cp LICENSE $RPM_BUILD_ROOT/%{python_sitelib}/rdflib/LICENSE
46
47# Various .py files within site-packages have a shebang line but aren't
48# flagged as executable.
49# I've gone through them and either removed the shebang or made them
50# executable as appropriate:
51
52# __main__ parses URI as N-Triples:
53chmod +x $RPM_BUILD_ROOT/%{python_sitelib}/rdflib/plugins/parsers/ntriples.py
54
55# __main__ parses the file given on the command line:
56chmod +x $RPM_BUILD_ROOT/%{python_sitelib}/rdflib/plugins/parsers/notation3.py
57
58
59%check
60%if %{run_tests}
61%{__python} run_tests.py
62%endif
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67%files
68%defattr(-,root,root,-)
69%doc LICENSE
70%{python_sitelib}/*
71
72%changelog
73* Sun Nov 20 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.1.0-2
74- Initial build for Vine Linux
75
76* Wed Sep 28 2011 David Malcolm <dmalcolm@redhat.com> - 3.1.0-1
77- 3.1.0; converting from arch-specific to noarch (sitearch -> sitelib);
78removing rdfpipe and various other extensions
79
80* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.2-3
81- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
82
83* Thu Jul 22 2010 Thomas Spura <tomspur@fedoraproject.org> - 2.4.2-2
84- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
85
86* Wed Jan  6 2010 David Malcolm <dmalcolm@redhat.com> - 2.4.2-1
87- bump to 2.4.2 (#552909)
88- fix source URL to use version macro
89
90* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-10
91- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
92
93* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-9
94- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
95
96* Wed Dec 10 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.4.0-8
97- Rebuild for Python 2.6
98
99* Wed Oct  1 2008 David Malcolm <dmalcolm@redhat.com> - 2.4.0-7
100- fix tab/space issue in specfile
101
102* Tue Sep 30 2008 David Malcolm <dmalcolm@redhat.com> - 2.4.0-6
103- override autogeneration of provides info to eliminate unwanted provision
104of SPARQLParserc.so
105
106* Mon Sep 29 2008 David Malcolm <dmalcolm@redhat.com> - 2.4.0-5
107- make various scripts executable, or remove shebang, as appropriate
108
109* Tue Feb 19 2008 David Malcolm <dmalcolm@redhat.com> - 2.4.0-4
110- delete test subdir
111
112* Thu Jan 24 2008 David Malcolm <dmalcolm@redhat.com> - 2.4.0-3
113- introduce macro to disable running the test suite, in the hope of eventually
114patching it so it passes
115
116* Mon Nov 19 2007 David Malcolm <dmalcolm@redhat.com> - 2.4.0-2
117- add python-setuptools(-devel) build requirement; move testing to correct stanza
118
119* Wed Aug  1 2007 David Malcolm <dmalcolm@redhat.com> - 2.4.0-1
120- initial version
121
Note: See TracBrowser for help on using the repository browser.