source: projects/specs/trunk/p/python-rdflib/python-rdflib-vl.spec @ 5701

Revision 5701, 3.9 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1# The upstream test suite does not pass on recent versions of Fedora
2# See package review (bug 378841)
3# For now, we disable running the test suite:
4%define run_tests 0
5
6Name:           python-rdflib
7Summary:        Python library for working with RDF
8Version:        3.1.0
9Release:        3%{?_dist_release}
10
11Group:          Development/Languages
12License:        BSD
13URL:            http://rdflib.net
14
15Source0:        http://rdflib.googlecode.com/files/rdflib-%{version}.tar.gz
16
17BuildArch:      noarch
18
19BuildRoot:      %{_tmppath}/%{name}-%{version}-root
20BuildRequires:  python-devel
21BuildRequires:  python-setuptools
22
23%if %{run_tests}
24BuildRequires:  python-nose >= 0.9.2
25%endif
26
27%description
28RDFLib is a Python library for working with RDF, a simple yet powerful
29language for representing information.
30
31The library contains parsers and serializers for RDF/XML, N3, NTriples,
32Turtle, TriX and RDFa. The library presents a Graph interface which can
33be backed by any one of a number of store implementations, including
34memory, MySQL, Redland, SQLite, Sleepycat, ZODB and SQLObject.
35
36%prep
37%setup -q -n rdflib-%{version}
38
39%build
40%{__python} setup.py build
41
42%install
43rm -rf $RPM_BUILD_ROOT
44%{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
45cp LICENSE $RPM_BUILD_ROOT/%{python_sitelib}/rdflib/LICENSE
46
47# Various .py files within site-packages have a shebang line but aren't
48# flagged as executable.
49# I've gone through them and either removed the shebang or made them
50# executable as appropriate:
51
52# __main__ parses URI as N-Triples:
53chmod +x $RPM_BUILD_ROOT/%{python_sitelib}/rdflib/plugins/parsers/ntriples.py
54
55# __main__ parses the file given on the command line:
56chmod +x $RPM_BUILD_ROOT/%{python_sitelib}/rdflib/plugins/parsers/notation3.py
57
58
59%check
60%if %{run_tests}
61%{__python} run_tests.py
62%endif
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67%files
68%defattr(-,root,root,-)
69%doc LICENSE
70%{python_sitelib}/*
71
72%changelog
73* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 3.1.0-3
74- rebuild with python-2.7.2
75
76* Sun Nov 20 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.1.0-2
77- Initial build for Vine Linux
78
79* Wed Sep 28 2011 David Malcolm <dmalcolm@redhat.com> - 3.1.0-1
80- 3.1.0; converting from arch-specific to noarch (sitearch -> sitelib);
81removing rdfpipe and various other extensions
82
83* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.2-3
84- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
85
86* Thu Jul 22 2010 Thomas Spura <tomspur@fedoraproject.org> - 2.4.2-2
87- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
88
89* Wed Jan  6 2010 David Malcolm <dmalcolm@redhat.com> - 2.4.2-1
90- bump to 2.4.2 (#552909)
91- fix source URL to use version macro
92
93* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-10
94- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
95
96* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-9
97- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
98
99* Wed Dec 10 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.4.0-8
100- Rebuild for Python 2.6
101
102* Wed Oct  1 2008 David Malcolm <dmalcolm@redhat.com> - 2.4.0-7
103- fix tab/space issue in specfile
104
105* Tue Sep 30 2008 David Malcolm <dmalcolm@redhat.com> - 2.4.0-6
106- override autogeneration of provides info to eliminate unwanted provision
107of SPARQLParserc.so
108
109* Mon Sep 29 2008 David Malcolm <dmalcolm@redhat.com> - 2.4.0-5
110- make various scripts executable, or remove shebang, as appropriate
111
112* Tue Feb 19 2008 David Malcolm <dmalcolm@redhat.com> - 2.4.0-4
113- delete test subdir
114
115* Thu Jan 24 2008 David Malcolm <dmalcolm@redhat.com> - 2.4.0-3
116- introduce macro to disable running the test suite, in the hope of eventually
117patching it so it passes
118
119* Mon Nov 19 2007 David Malcolm <dmalcolm@redhat.com> - 2.4.0-2
120- add python-setuptools(-devel) build requirement; move testing to correct stanza
121
122* Wed Aug  1 2007 David Malcolm <dmalcolm@redhat.com> - 2.4.0-1
123- initial version
124
Note: See TracBrowser for help on using the repository browser.