source: projects/specs/trunk/p/python-rdflib/python-rdflib-vl.spec @ 8158

Revision 8158, 4.1 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1# The upstream test suite does not pass on recent versions of Fedora
2# See package review (bug 378841)
3# For now, we disable running the test suite:
4%define run_tests 0
5
6Name:           python-rdflib
7Summary:        Python library for working with RDF
8Version:        3.1.0
9Release:        4%{?_dist_release}
10
11Group:          Development/Languages
12License:        BSD
13URL:            http://rdflib.net
14
15Source0:        http://rdflib.googlecode.com/files/rdflib-%{version}.tar.gz
16
17BuildArch:      noarch
18
19BuildRoot:      %{_tmppath}/%{name}-%{version}-root
20BuildRequires:  python-devel
21BuildRequires:  python-setuptools
22
23%if %{run_tests}
24BuildRequires:  python-nose >= 0.9.2
25%endif
26
27Vendor: Project Vine
28Distribution: Vine Linux
29
30%description
31RDFLib is a Python library for working with RDF, a simple yet powerful
32language for representing information.
33
34The library contains parsers and serializers for RDF/XML, N3, NTriples,
35Turtle, TriX and RDFa. The library presents a Graph interface which can
36be backed by any one of a number of store implementations, including
37memory, MySQL, Redland, SQLite, Sleepycat, ZODB and SQLObject.
38
39%prep
40%setup -q -n rdflib-%{version}
41
42%build
43%{__python} setup.py build
44
45%install
46rm -rf $RPM_BUILD_ROOT
47%{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
48cp LICENSE $RPM_BUILD_ROOT/%{python_sitelib}/rdflib/LICENSE
49
50# Various .py files within site-packages have a shebang line but aren't
51# flagged as executable.
52# I've gone through them and either removed the shebang or made them
53# executable as appropriate:
54
55# __main__ parses URI as N-Triples:
56chmod +x $RPM_BUILD_ROOT/%{python_sitelib}/rdflib/plugins/parsers/ntriples.py
57
58# __main__ parses the file given on the command line:
59chmod +x $RPM_BUILD_ROOT/%{python_sitelib}/rdflib/plugins/parsers/notation3.py
60
61
62%check
63%if %{run_tests}
64%{__python} run_tests.py
65%endif
66
67%clean
68rm -rf $RPM_BUILD_ROOT
69
70%files
71%defattr(-,root,root,-)
72%doc LICENSE
73%{python_sitelib}/*
74
75%changelog
76* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 3.1.0-4
77- rebuild with VineSeed environment
78
79* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 3.1.0-3
80- rebuild with python-2.7.2
81
82* Sun Nov 20 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.1.0-2
83- Initial build for Vine Linux
84
85* Wed Sep 28 2011 David Malcolm <dmalcolm@redhat.com> - 3.1.0-1
86- 3.1.0; converting from arch-specific to noarch (sitearch -> sitelib);
87removing rdfpipe and various other extensions
88
89* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.2-3
90- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
91
92* Thu Jul 22 2010 Thomas Spura <tomspur@fedoraproject.org> - 2.4.2-2
93- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
94
95* Wed Jan  6 2010 David Malcolm <dmalcolm@redhat.com> - 2.4.2-1
96- bump to 2.4.2 (#552909)
97- fix source URL to use version macro
98
99* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-10
100- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
101
102* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-9
103- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
104
105* Wed Dec 10 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.4.0-8
106- Rebuild for Python 2.6
107
108* Wed Oct  1 2008 David Malcolm <dmalcolm@redhat.com> - 2.4.0-7
109- fix tab/space issue in specfile
110
111* Tue Sep 30 2008 David Malcolm <dmalcolm@redhat.com> - 2.4.0-6
112- override autogeneration of provides info to eliminate unwanted provision
113of SPARQLParserc.so
114
115* Mon Sep 29 2008 David Malcolm <dmalcolm@redhat.com> - 2.4.0-5
116- make various scripts executable, or remove shebang, as appropriate
117
118* Tue Feb 19 2008 David Malcolm <dmalcolm@redhat.com> - 2.4.0-4
119- delete test subdir
120
121* Thu Jan 24 2008 David Malcolm <dmalcolm@redhat.com> - 2.4.0-3
122- introduce macro to disable running the test suite, in the hope of eventually
123patching it so it passes
124
125* Mon Nov 19 2007 David Malcolm <dmalcolm@redhat.com> - 2.4.0-2
126- add python-setuptools(-devel) build requirement; move testing to correct stanza
127
128* Wed Aug  1 2007 David Malcolm <dmalcolm@redhat.com> - 2.4.0-1
129- initial version
130
Note: See TracBrowser for help on using the repository browser.