source: projects/specs/trunk/p/python-pyudev/python-pyudev-vl.spec @ 12472

Revision 12472, 9.6 KB checked in by tomop, 4 years ago (diff)

updated 4 packages

blivet-gui-2.1.15-1

python-blivet-3.2.2-1

python-pid-3.0.4-1

python-pyudev-0.22.0-1

Line 
1%bcond_with systemd
2
3%global srcname pyudev
4Summary:          A libudev binding
5Name:             python-%{srcname}
6Version:          0.22.0
7Release:          1%{?_dist_release}
8Group:            programming
9Vendor:           Project Vine
10Distribution:     Vine Linux
11
12License:          LGPLv2+
13URL:              https://pypi.org/project/pyudev/
14Source0:          https://pypi.io/packages/source/p/%{srcname}/%{srcname}-%{version}.tar.gz
15
16BuildArch:        noarch
17
18%description
19pyudev is a LGPL licensed, pure Python binding for libudev, the device
20and hardware management and information library for Linux.  It supports
21almost all libudev functionality, you can enumerate devices, query device
22properties and attributes or monitor devices, including asynchronous
23monitoring with threads, or within the event loops of Qt, Glib or wxPython.
24
25The binding supports CPython 2 (2.6 or newer) and 3 (3.1 or newer), and
26PyPy 1.5 or newer.  It is tested against udev 151 or newer, earlier
27versions of udev as found on dated Linux systems may work, but are not
28officially supported.
29
30
31%package -n python3-%{srcname}
32Summary:          A libudev binding
33Group:            programming
34%{?python_provide:%python_provide python3-%{srcname}}
35
36BuildRequires:    python3-devel
37BuildRequires:    python3-setuptools
38BuildRequires:    python3-rpm-macros
39
40# Needed for libudev, loaded through ctypes
41%if %{with systemd}
42Requires:         systemd-libs
43%endif
44
45# Used for python2/3 compatibility
46Requires:         python3-six
47
48%description -n python3-%{srcname}
49pyudev is a LGPL licensed, pure Python binding for libudev, the device
50and hardware management and information library for Linux.  It supports
51almost all libudev functionality, you can enumerate devices, query device
52properties and attributes or monitor devices, including asynchronous
53monitoring with threads, or within the event loops of Qt, Glib or wxPython.
54
55The binding supports CPython 2 (2.6 or newer) and 3 (3.1 or newer), and
56PyPy 1.5 or newer.  It is tested against udev 151 or newer, earlier
57versions of udev as found on dated Linux systems may work, but are not
58officially supported.
59
60
61%prep
62%autosetup -n %{srcname}-%{version}
63rm -rf pyudev.egg-info
64
65
66%build
67%py3_build
68
69
70%install
71%py3_install
72
73
74%files -n python3-%{srcname}
75%license COPYING
76%doc README.rst CHANGES.rst
77%{python3_sitelib}/pyudev
78%{python3_sitelib}/pyudev-%{version}-*.egg-info
79%exclude %{python3_sitelib}/pyudev/glib.py
80%exclude %{python3_sitelib}/pyudev/__pycache__/glib.*
81%exclude %{python3_sitelib}/pyudev/pyside.py
82%exclude %{python3_sitelib}/pyudev/__pycache__/pyside.*
83%exclude %{python3_sitelib}/pyudev/wx.py
84%exclude %{python3_sitelib}/pyudev/__pycache__/wx.*
85
86
87%changelog
88* Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.22.0-1
89- new upstream release.
90
91* Mon Sep 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.21.0-13
92- initial build for Vine Linux.
93- dropped qt4/qt5 stuff.
94
95* Fri Aug 16 2019 Miro Hrončok <mhroncok@redhat.com> - 0.21.0-12
96- Rebuilt for Python 3.8
97
98* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.21.0-11
99- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
100
101* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.21.0-10
102- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
103
104* Thu Oct 11 2018 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 0.21.0-9
105- Python2 binary package has been removed
106  See https://fedoraproject.org/wiki/Changes/Mass_Python_2_Package_Removal
107
108* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.21.0-8
109- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
110
111* Fri Jun 15 2018 Miro Hrončok <mhroncok@redhat.com> - 0.21.0-7
112- Rebuilt for Python 3.7
113
114* Fri Mar 23 2018 Iryna Shcherbina <ishcherb@redhat.com> - 0.21.0-6
115- Update Python 2 dependency declarations to new packaging standards
116  (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
117
118* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.21.0-5
119- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
120
121* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.21.0-4
122- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
123
124* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.21.0-3
125- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
126
127* Wed Dec 21 2016 Kevin Fenzi <kevin@scrye.com> - 0.21.0-2
128- Rebuild for Python 3.6
129
130* Fri Jul 29 2016 mulhern <amulhern@redhat.com> - 0.21.1
131- Deprecate use of Device object as mapping from udev property names to values
132- Add a Properties class and a Device.properties() method for udev properties
133- Fix places where Device object was incorrectly used in a boolean context
134- Return an empty string, not None, if the property value is an empty string
135- Exceptions re-raised from libudev calls now have a message string
136- Insert a warning about using a Device in a boolean context in docs
137- Infrastructure for vagrant tests is removed
138- Various internal refactorings
139- Extensive test improvements
140- Numerous documentation fixes
141
142* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.20.0-3
143- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
144
145* Mon May 2 2016 mulhern <amulhern@redhat.com> - 0.20.0
146- Remove parsing code added in previous release
147- No longer do CI for Python 2.6
148- Eliminate all wildcard imports and __all__ statements
149- No longer use deprecated Device.from_sys_path() method
150- Minor pylint induced changes
151- Documentation fixes
152
153* Mon Feb 08 2016 mulhern <amulhern@redhat.com> - 0.19.0
154- Never raise a DeviceNotFoundError when iterating over a device enumeration
155- Device.subsystem() now returns None if device has no subsystem
156- Add DeprecationWarnings to deprecated Device methods
157- Replace "/" with "!" in Device.from_name() sys_name parameter
158- Add some unstable classes for parsing some kinds of values
159- Make version info more like Python's including micro numbers and levels
160- Refactor some internal modules into subdirectories
161- Work on tests and reproducers
162
163* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.18.1-5
164- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
165
166* Mon Dec 21 2015 mulhern <amulhern@redhat.com> - 0.18.1
167- Restore raising KeyError in astring, asint, asbool methods in Attributes
168- Add dependency on six package
169- pyudev sources now in src directory
170- Added support for pyqt5 monitor observer
171- Added discover module, which looks up a device on limited information
172- DeviceNotFoundError is no longer a subtype of LookupError
173- Attributes class no longer extends Mapping class
174- Attributes class no longer inherits [] operator and other Mapping methods
175- Attributes class object are no longer iterable or indexable and have no length
176- Attributes.available_attributes property added
177- Attributes.get() method, with usual semantics explicitly defined
178- Device.from_* methods are deprecated, use Devices.from_* methods instead
179- Device.from_device_number() now raises DeviceNotFoundByNumberError
180- Devices.from_interface_index() method added
181- Devices.from_kernel_device() method added
182
183* Thu Dec  3 2015 David Shea <dshea@redhat.com> - 0.17-4
184- Add requires for things that are required
185- Split the main-loop integration modules into separate packages
186
187* Wed Nov 04 2015 Robert Kuska <rkuska@redhat.com> - 0.17-3
188- Rebuilt for Python3.5 rebuild
189
190* Tue Sep 15 2015 David Shea <dshea@redhat.com> - 0.17.1-2
191- Fix a typo in the python3-pyudev Provides
192
193* Mon Sep 14 2015 David Shea <dshea@redhat.com> - 0.17.1-1
194- Really start the monitor on pyudev.Monitor.poll()
195- Force non-blocking IO in pyudev.Monitor to avoid blocking on receiving the device
196- Set proper flags on pipe fs
197- Handle irregular polling events properly
198- Rename MonitorObserver GUI classes and deprecate the old ones
199- Remove patches for #1170337 and #1230773 that are now part of upstream
200- Switch to new packaging guidelines which renames python-pyudev to python2-pyudev
201
202* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.16.1-4
203- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
204
205* Fri Jun 12 2015 David Shea <dshea@redhat.com> - 0.16.1-3
206- Retry interrupted system calls (#1230773)
207- Rearrange the build process to match current packaging recommendations
208
209* Wed Jan 28 2015 David Shea <dshea@redhat.com> - 0.16.1-2
210- Use %%license for the license file
211
212* Wed Dec 10 2014 David Shea <dshea@redhat.com> - 0.16.1-1
213- Update to pyudev-0.16.1 (#880644)
214- Apply a patch from upstream to remove a global reference to libudev (#1170337)
215
216* Wed Dec 10 2014 David Shea <dshea@redhat.com> - 0.15-7
217- Fix license tag (LGPL -> LGPLv2+) (#990579)
218- Remove rst tags from description
219- Remove unnecessary requires and buildrequires (#1095459)
220- Avoid packaging upstream egg-info files
221- Add a python3 package
222- Drop the Group tag which wasn't even the right group
223
224* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.15-6
225- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
226
227* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.15-5
228- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
229
230* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.15-4
231- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
232
233* Mon Jul 23 2012 Chris Lockfort <clockfort@redhat.com> 0.15-3
234- Reflect rawhide merging udev into systemd
235* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.15-2
236- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
237* Mon Jun 18 2012 Chris Lockfort <clockfort@redhat.com> 0.15-1
238- initial package
Note: See TracBrowser for help on using the repository browser.