source: projects/specs/trunk/p/python-pysocks/python-pysocks-vl.spec @ 12469

Revision 12469, 4.4 KB checked in by tomop, 4 years ago (diff)

python-3.8.5 and related packages.

Line 
1%global pypi_name   PySocks
2%global modname     pysocks
3%global sum         A Python SOCKS client module
4
5Summary:            %{sum}
6Name:               python-%{modname}
7Version:            1.7.1
8Release:            1%{?_dist_release}
9Group:              programming
10Vendor:             Project Vine
11Distribution:       Vine Linux
12
13License:            BSD
14URL:                https://github.com/Anorov/%{pypi_name}
15Source0:            https://files.pythonhosted.org/packages/source/P/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
16
17BuildArch:          noarch
18BuildRequires:      python-devel
19BuildRequires:      python-setuptools
20BuildRequires:      python-rpm-macros
21BuildRequires:      python2-rpm-macros
22%{?python_provide:%python_provide python2-%{modname}}
23
24%global _description \
25A fork of SocksiPy with bug fixes and extra features.\
26\
27Acts as a drop-in replacement to the socket module. Featuring:\
28\
29- SOCKS proxy client for Python 2.6 - 3.x\
30- TCP and UDP both supported\
31- HTTP proxy client included but not supported or recommended (you should use\
32  urllib2's or requests' own HTTP proxy interface)\
33- urllib2 handler included.
34
35%description
36%_description
37
38%package -n python3-%{modname}
39Summary:            %{sum}
40Group:              programming
41BuildRequires:      python3-devel
42BuildRequires:      python3-setuptools
43BuildRequires:      python3-rpm-macros
44%{?python_provide:%python_provide python3-%{modname}}
45
46%description -n python3-%{modname}
47%_description
48This package is for Python3 version %{python3_version} only.
49
50
51%prep
52%autosetup -n %{pypi_name}-%{version}
53# drop useless 3rdparty code
54rm -rfv test/bin
55
56%build
57%py2_build
58%py3_build
59
60%install
61%py2_install
62%py3_install
63
64%check
65
66
67%files
68%doc README.md
69%license LICENSE
70%{python_sitelib}/socks.py*
71%{python_sitelib}/sockshandler.py*
72%{python_sitelib}/%{pypi_name}-%{version}*
73
74%files -n python3-%{modname}
75%doc README.md
76%license LICENSE
77%{python3_sitelib}/socks.py*
78%{python3_sitelib}/sockshandler.py*
79%{python3_sitelib}/__pycache__/*socks*
80%{python3_sitelib}/%{pypi_name}-%{version}-*
81
82
83%changelog
84* Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.7.1-1
85- new upstream release.
86
87* Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.6.8-7
88- initial build for Vine Linux.
89
90* Sun Nov 11 2018 Kevin Fenzi <kevin@scrye.com> - 1.6.8-6
91- Add upstream patch to avoid DeprecationWarning. Fixes bug #1648583
92
93* Wed Oct 03 2018 Raphael Groner <projects.rg@smart.ms> - 1.6.8-5
94- add python3_other subpackage for epel7
95- prepare removal of python2 subpackage in Fedora
96- use pypi macros
97- try to enable tests provided actually from tarball
98
99* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.8-4
100- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
101
102* Thu Jun 14 2018 Miro Hrončok <mhroncok@redhat.com> - 1.6.8-3
103- Rebuilt for Python 3.7
104
105* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.8-2
106- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
107
108* Fri Dec 22 2017 Kevin Fenzi <kevin@scrye.com> - 1.6.8-1
109- Update to 1.6.8. Fixes bug #1528490
110
111* Mon Sep 11 2017 Carl George <carl@george.computer> - 1.6.7-1
112- Latest upstream
113- Add setuptools dependency
114
115* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.7-5
116- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
117
118* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.7-4
119- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
120
121* Fri Dec 09 2016 Charalampos Stratakis <cstratak@redhat.com> - 1.5.7-3
122- Rebuild for Python 3.6
123
124* Mon Nov 28 2016 Tim Orling <ticotimo@gmail.com> - 1.5.7-2
125- Ship python34-pysocks in EL6
126
127* Sat Sep 17 2016 Kevin Fenzi <kevin@scrye.com> - 1.5.7-1
128- Update to 1.5.7
129
130* Fri Sep 16 2016 Orion Poplawski <orion@cora.nwra.com> - 1.5.6-6
131- Ship python34-pysocks in EPEL7
132
133* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.6-5
134- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
135
136* Fri Jul 15 2016 Ralph Bean <rbean@redhat.com> - 1.5.6-4
137- Change our conflicts on python-SocksiPy to an obsoletes/provides.
138  https://bugzilla.redhat.com/show_bug.cgi?id=1334407
139
140* Mon May 09 2016 Ralph Bean <rbean@redhat.com> - 1.5.6-3
141- Fix typo in explicit conflicts.
142
143* Tue May 03 2016 Ralph Bean <rbean@redhat.com> - 1.5.6-2
144- We don't actually need setuptools here.
145
146* Mon May 02 2016 Ralph Bean <rbean@redhat.com> - 1.5.6-1
147- Initial package for Fedora
Note: See TracBrowser for help on using the repository browser.