source: projects/specs/trunk/p/python-pygments/python-pygments-vl.spec @ 11946

Revision 11946, 6.4 KB checked in by tomop, 5 years ago (diff)

python-pygments-2.3.0-2

Line 
1%global with_python3 1
2%global upstream_name Pygments
3%global srcname pygments
4
5Name:           python-pygments
6Version:        2.3.0
7Release:        2%{?_dist_release}
8Summary:        A syntax highlighting engine written in Python
9
10Group:          Development/Libraries
11License:        BSD
12URL:            http://pygments.org/
13Source0:        http://pypi.python.org/packages/source/P/%{upstream_name}/%{upstream_name}-%{version}.tar.gz
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
16
17BuildArch:      noarch
18BuildRequires:  python-devel >= 2.4, python-setuptools, python-nose
19BuildRequires:  python-sphinx
20BuildRequires:  python-rpm-macros
21%if 0%{?with_python3}
22BuildRequires:  python3-devel, python3-setuptools, python3-nose
23BuildRequires:  python3-rpm-macros
24%endif # if with_python3
25Requires:       python-setuptools
26
27Vendor: Project Vine
28Distribution: Vine Linux
29
30%description
31Pygments is a generic syntax highlighter for general use in all kinds
32of software such as forum systems, wikis or other applications that
33need to prettify source code. Highlights are:
34
35  * a wide range of common languages and markup formats is supported
36  * special attention is paid to details that increase highlighting
37    quality
38  * support for new languages and formats are added easily; most
39    languages use a simple regex-based lexing mechanism
40  * a number of output formats is available, among them HTML, RTF,
41    LaTeX and ANSI sequences
42  * it is usable as a command-line tool and as a library
43  * ... and it highlights even Brainf*ck!
44
45%if 0%{?with_python3}
46%package -n python3-pygments
47Summary:        A syntax highlighting engine written in Python 3
48Group:          Development/Libraries
49Requires:       python3-setuptools
50
51%description -n python3-pygments
52Pygments is a generic syntax highlighter for general use in all kinds
53of software such as forum systems, wikis or other applications that
54need to prettify source code. Highlights are:
55
56  * a wide range of common languages and markup formats is supported
57  * special attention is paid to details that increase highlighting
58    quality
59  * support for new languages and formats are added easily; most
60    languages use a simple regex-based lexing mechanism
61  * a number of output formats is available, among them HTML, RTF,
62    LaTeX and ANSI sequences
63  * it is usable as a command-line tool and as a library
64  * ... and it highlights even Brainf*ck!
65%endif # if with_python3
66
67
68%prep
69%setup -q -n %{upstream_name}-%{version}
70
71%build
72%{__sed} -i 's/\r//' LICENSE
73
74%if 0%{?with_python3}
75%py3_build
76%endif
77
78%py_build
79
80%install
81%__rm -rf $RPM_BUILD_ROOT
82
83%if 0%{?with_python3}
84# Python 3 install
85%py3_install
86%endif
87
88# Python 2 install
89# NOTE: sphinx is built on Python2 and packages with python2 and python3
90%py_install
91%{__python} setup.py build_sphinx
92pushd doc
93install -d %{buildroot}%{_mandir}/man1
94mv pygmentize.1 $RPM_BUILD_ROOT%{_mandir}/man1/pygmentize.1
95popd
96cp -r doc/docs doc/reST
97
98%clean
99%__rm -rf $RPM_BUILD_ROOT
100
101%check
102make test PYTHON=%{__python}
103%if 0%{?with_python3}
104make test PYTHON=%{__python3}
105%endif
106
107%files
108%defattr(-,root,root,-)
109%doc AUTHORS CHANGES build/sphinx/html doc/reST TODO
110%license LICENSE
111# For noarch packages: sitelib
112%{python_sitelib}/*
113%{_bindir}/pygmentize
114%lang(en) %{_mandir}/man1/pygmentize.1*
115
116%if 0%{?with_python3}
117%files -n python3-pygments
118%defattr(-,root,root,-)
119%doc AUTHORS CHANGES build/sphinx/html doc/reST TODO
120%license LICENSE
121%{python3_sitelib}/*
122#{_bindir}/pygmentize
123#lang(en) %{_mandir}/man1/pygmentize.1*
124%endif # with_python3
125
126
127%changelog
128* Thu Nov 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.3.0-2
129- packed pygmentize for python2.
130
131* Tue Nov 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.3.0-1
132- new upstream release.
133- added python3 support.
134
135* Tue Jul 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.1.3-1
136- new upstream release.
137
138* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.3.1-3
139- rebuild with VineSeed environment
140
141* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.3.1-2
142- rebuild with python-2.7.2
143
144* Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 1.3.1-1
145- initial build based on Fedora development
146
147* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1.3.1-6
148- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
149
150* Thu May  6 2010 Gareth Armstrong <gareth.armstrong@hp.com> - 1.3.1-5
151- Enforce that Pygments requires Python 2.4 or later via an explicit BR
152- Minor tweaks to spec file
153- Deliver html and reST doc files to specifically named directories
154- Align description with that of http://pygments.org/
155- Add %%check section for Python2 and add BR on python-nose
156
157* Fri Apr 23 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.1-4
158- switched with_python3 back to 1
159
160* Fri Apr 23 2010 David Malcolm <dmalcolm@redhat.com> - 1.3.1-3
161- add python3 subpackage (BZ#537244), ignoring soft-dep on imaging for now
162
163* Tue Apr 13 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.1-2
164- added python-imaging as a dependency per BZ#581663.
165
166* Sat Mar  6 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.1-1
167- Updated for release.
168
169* Tue Sep 29 2009 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.1.1-1
170- Updated for release.
171
172* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-5
173- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
174
175* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-4
176- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
177
178* Sun Dec 21 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.0-3
179- Updated for release.
180
181* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.0-2
182- Rebuild for Python 2.6
183
184* Thu Nov 27 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.0-1
185- Updated for upstream 1.0.
186
187* Sun Sep 14 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 0.11.1-1
188- Updated for upstream 0.11.
189
190* Mon Jul 21 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 0.10-1
191- Updated for upstream 0.10.
192
193* Thu Nov 29 2007 Steve 'Ashcrow' Milner <me@stevemilner.org> - 0.9-2
194- Added python-setuptools as a Requires per bz#403601.
195
196* Mon Nov 12 2007 Steve 'Ashcrow' Milner <me@stevemilner.org> - 0.9-1
197- Updated for upstream 0.9.
198
199* Fri Aug 17 2007 Steve 'Ashcrow' Milner <me@stevemilner.org> - 0.8.1-2
200- Removed the dos2unix build dependency.
201
202* Thu Jun 28 2007 Steve 'Ashcrow' Milner <me@stevemilner.org> - 0.8.1-1
203- Initial packaging for Fedora.
Note: See TracBrowser for help on using the repository browser.