source: projects/specs/trunk/p/python-pygments/python-pygments-vl.spec @ 12321

Revision 12321, 6.5 KB checked in by tomop, 4 years ago (diff)

updated 7 packages

bash-5.0.16-1

gtk-doc-1.32-3

libmariadb-3.1.7-1

libpq-12.2-1

librsvg2-2.46.4-1

postgresql-12.2-1

python-pygments-2.5.2-1

Line 
1%bcond_with test
2%global with_python3 1
3%global upstream_name Pygments
4%global srcname pygments
5
6Name:           python-pygments
7Version:        2.5.2
8Release:        1%{?_dist_release}
9Summary:        A syntax highlighting engine written in Python
10
11Group:          Development/Libraries
12License:        BSD
13URL:            http://pygments.org/
14Source0:        https://pypi.python.org/packages/source/P/%{upstream_name}/%{upstream_name}-%{version}.tar.gz
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18BuildArch:      noarch
19BuildRequires:  python-devel >= 2.4, python-setuptools, python-nose
20BuildRequires:  python-sphinx
21BuildRequires:  python-rpm-macros
22%if 0%{?with_python3}
23BuildRequires:  python3-devel, python3-setuptools, python3-nose
24BuildRequires:  python3-rpm-macros
25%endif # if with_python3
26Requires:       python-setuptools
27
28Vendor: Project Vine
29Distribution: Vine Linux
30
31%description
32Pygments is a generic syntax highlighter for general use in all kinds
33of software such as forum systems, wikis or other applications that
34need to prettify source code. Highlights are:
35
36  * a wide range of common languages and markup formats is supported
37  * special attention is paid to details that increase highlighting
38    quality
39  * support for new languages and formats are added easily; most
40    languages use a simple regex-based lexing mechanism
41  * a number of output formats is available, among them HTML, RTF,
42    LaTeX and ANSI sequences
43  * it is usable as a command-line tool and as a library
44  * ... and it highlights even Brainf*ck!
45
46%if 0%{?with_python3}
47%package -n python3-pygments
48Summary:        A syntax highlighting engine written in Python 3
49Group:          Development/Libraries
50Requires:       python3-setuptools
51
52%description -n python3-pygments
53Pygments is a generic syntax highlighter for general use in all kinds
54of software such as forum systems, wikis or other applications that
55need to prettify source code. Highlights are:
56
57  * a wide range of common languages and markup formats is supported
58  * special attention is paid to details that increase highlighting
59    quality
60  * support for new languages and formats are added easily; most
61    languages use a simple regex-based lexing mechanism
62  * a number of output formats is available, among them HTML, RTF,
63    LaTeX and ANSI sequences
64  * it is usable as a command-line tool and as a library
65  * ... and it highlights even Brainf*ck!
66%endif # if with_python3
67
68
69%prep
70%setup -q -n %{upstream_name}-%{version}
71
72%build
73%{__sed} -i 's/\r//' LICENSE
74
75%if 0%{?with_python3}
76%py3_build
77%endif
78
79%py_build
80
81%install
82%__rm -rf $RPM_BUILD_ROOT
83
84%if 0%{?with_python3}
85# Python 3 install
86%py3_install
87%endif
88
89# Python 2 install
90# NOTE: sphinx is built on Python2 and packages with python2 and python3
91%py_install
92%{__python} setup.py build_sphinx
93pushd doc
94install -d %{buildroot}%{_mandir}/man1
95mv pygmentize.1 $RPM_BUILD_ROOT%{_mandir}/man1/pygmentize.1
96popd
97cp -r doc/docs doc/reST
98
99%clean
100%__rm -rf $RPM_BUILD_ROOT
101
102%if %{with test}
103%check
104make test PYTHON=%{__python}
105%if 0%{?with_python3}
106make test PYTHON=%{__python3}
107%endif
108%endif
109
110%files
111%defattr(-,root,root,-)
112%doc AUTHORS CHANGES build/sphinx/html doc/reST TODO
113%license LICENSE
114# For noarch packages: sitelib
115%{python_sitelib}/*
116%{_bindir}/pygmentize
117%lang(en) %{_mandir}/man1/pygmentize.1*
118
119%if 0%{?with_python3}
120%files -n python3-pygments
121%defattr(-,root,root,-)
122%doc AUTHORS CHANGES build/sphinx/html doc/reST TODO
123%license LICENSE
124%{python3_sitelib}/*
125#{_bindir}/pygmentize
126#lang(en) %{_mandir}/man1/pygmentize.1*
127%endif # with_python3
128
129
130%changelog
131* Sat Feb 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.5.2-1
132
133* Thu Nov 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.3.0-2
134- packed pygmentize for python2.
135
136* Tue Nov 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.3.0-1
137- new upstream release.
138- added python3 support.
139
140* Tue Jul 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.1.3-1
141- new upstream release.
142
143* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.3.1-3
144- rebuild with VineSeed environment
145
146* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.3.1-2
147- rebuild with python-2.7.2
148
149* Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 1.3.1-1
150- initial build based on Fedora development
151
152* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1.3.1-6
153- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
154
155* Thu May  6 2010 Gareth Armstrong <gareth.armstrong@hp.com> - 1.3.1-5
156- Enforce that Pygments requires Python 2.4 or later via an explicit BR
157- Minor tweaks to spec file
158- Deliver html and reST doc files to specifically named directories
159- Align description with that of http://pygments.org/
160- Add %%check section for Python2 and add BR on python-nose
161
162* Fri Apr 23 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.1-4
163- switched with_python3 back to 1
164
165* Fri Apr 23 2010 David Malcolm <dmalcolm@redhat.com> - 1.3.1-3
166- add python3 subpackage (BZ#537244), ignoring soft-dep on imaging for now
167
168* Tue Apr 13 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.1-2
169- added python-imaging as a dependency per BZ#581663.
170
171* Sat Mar  6 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.1-1
172- Updated for release.
173
174* Tue Sep 29 2009 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.1.1-1
175- Updated for release.
176
177* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-5
178- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
179
180* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-4
181- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
182
183* Sun Dec 21 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.0-3
184- Updated for release.
185
186* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.0-2
187- Rebuild for Python 2.6
188
189* Thu Nov 27 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.0-1
190- Updated for upstream 1.0.
191
192* Sun Sep 14 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 0.11.1-1
193- Updated for upstream 0.11.
194
195* Mon Jul 21 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 0.10-1
196- Updated for upstream 0.10.
197
198* Thu Nov 29 2007 Steve 'Ashcrow' Milner <me@stevemilner.org> - 0.9-2
199- Added python-setuptools as a Requires per bz#403601.
200
201* Mon Nov 12 2007 Steve 'Ashcrow' Milner <me@stevemilner.org> - 0.9-1
202- Updated for upstream 0.9.
203
204* Fri Aug 17 2007 Steve 'Ashcrow' Milner <me@stevemilner.org> - 0.8.1-2
205- Removed the dos2unix build dependency.
206
207* Thu Jun 28 2007 Steve 'Ashcrow' Milner <me@stevemilner.org> - 0.8.1-1
208- Initial packaging for Fedora.
Note: See TracBrowser for help on using the repository browser.