source: projects/specs/trunk/p/python-pygments/python-pygments-vl.spec @ 12469

Revision 12469, 6.3 KB checked in by tomop, 4 years ago (diff)

python-3.8.5 and related packages.

RevLine 
[12321]1%bcond_with test
[10602]2%global with_python3 1
[1741]3%global upstream_name Pygments
[11925]4%global srcname pygments
[1741]5
6Name:           python-pygments
[12469]7Version:        2.6.1
[12321]8Release:        1%{?_dist_release}
[1741]9Summary:        A syntax highlighting engine written in Python
[12469]10Group:          programming
11Vendor:         Project Vine
12Distribution:   Vine Linux
[1741]13
14License:        BSD
15URL:            http://pygments.org/
[12321]16Source0:        https://pypi.python.org/packages/source/P/%{upstream_name}/%{upstream_name}-%{version}.tar.gz
[11925]17
[1741]18BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
19
20BuildArch:      noarch
[11925]21BuildRequires:  python-rpm-macros
[12469]22
[1741]23%if 0%{?with_python3}
[11925]24BuildRequires:  python3-devel, python3-setuptools, python3-nose
25BuildRequires:  python3-rpm-macros
[12469]26BuildRequires:  python3-sphinx
[1741]27%endif # if with_python3
28
29%description
30Pygments is a generic syntax highlighter for general use in all kinds
31of software such as forum systems, wikis or other applications that
32need to prettify source code. Highlights are:
33
34  * a wide range of common languages and markup formats is supported
35  * special attention is paid to details that increase highlighting
36    quality
37  * support for new languages and formats are added easily; most
38    languages use a simple regex-based lexing mechanism
39  * a number of output formats is available, among them HTML, RTF,
40    LaTeX and ANSI sequences
41  * it is usable as a command-line tool and as a library
42  * ... and it highlights even Brainf*ck!
43
44%if 0%{?with_python3}
45%package -n python3-pygments
46Summary:        A syntax highlighting engine written in Python 3
[12469]47Group:          programming
[1741]48Requires:       python3-setuptools
[12469]49Obsoletes:      python-pygments < 2.6.0
[1741]50
51%description -n python3-pygments
52Pygments is a generic syntax highlighter for general use in all kinds
53of software such as forum systems, wikis or other applications that
54need to prettify source code. Highlights are:
55
56  * a wide range of common languages and markup formats is supported
57  * special attention is paid to details that increase highlighting
58    quality
59  * support for new languages and formats are added easily; most
60    languages use a simple regex-based lexing mechanism
61  * a number of output formats is available, among them HTML, RTF,
62    LaTeX and ANSI sequences
63  * it is usable as a command-line tool and as a library
64  * ... and it highlights even Brainf*ck!
65%endif # if with_python3
66
67
68%prep
[11925]69%setup -q -n %{upstream_name}-%{version}
[1741]70
71%build
72%{__sed} -i 's/\r//' LICENSE
73%if 0%{?with_python3}
[11925]74%py3_build
75%endif
[1741]76
[11946]77
[1741]78%install
79%__rm -rf $RPM_BUILD_ROOT
80
[11946]81%if 0%{?with_python3}
82# Python 3 install
83%py3_install
84%endif
85
[12469]86%{__python3} setup.py build_sphinx
[10602]87pushd doc
[11925]88install -d %{buildroot}%{_mandir}/man1
89mv pygmentize.1 $RPM_BUILD_ROOT%{_mandir}/man1/pygmentize.1
[1741]90popd
[10602]91cp -r doc/docs doc/reST
[1741]92
[12469]93
[1741]94%clean
95%__rm -rf $RPM_BUILD_ROOT
96
[12469]97
[12321]98%if %{with test}
[1741]99%check
[11925]100make test PYTHON=%{__python}
[1741]101%if 0%{?with_python3}
[11925]102make test PYTHON=%{__python3}
103%endif
[12321]104%endif
[1741]105
106
107%if 0%{?with_python3}
108%files -n python3-pygments
109%defattr(-,root,root,-)
[11925]110%doc AUTHORS CHANGES build/sphinx/html doc/reST TODO
[10602]111%license LICENSE
[1741]112%{python3_sitelib}/*
[12469]113%{_bindir}/pygmentize
114%lang(en) %{_mandir}/man1/pygmentize.1*
[1741]115%endif # with_python3
116
117
118%changelog
[12469]119* Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.6.1-1
120- new upstream release.
121- built with python3 only.
122
[12321]123* Sat Feb 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.5.2-1
[12469]124- new upstream release.
[12321]125
[11946]126* Thu Nov 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.3.0-2
127- packed pygmentize for python2.
128
[11925]129* Tue Nov 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.3.0-1
130- new upstream release.
131- added python3 support.
132
[10602]133* Tue Jul 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.1.3-1
134- new upstream release.
135
[8158]136* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.3.1-3
137- rebuild with VineSeed environment
138
[5701]139* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.3.1-2
140- rebuild with python-2.7.2
141
[1741]142* Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 1.3.1-1
143- initial build based on Fedora development
144
145* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1.3.1-6
146- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
147
148* Thu May  6 2010 Gareth Armstrong <gareth.armstrong@hp.com> - 1.3.1-5
149- Enforce that Pygments requires Python 2.4 or later via an explicit BR
150- Minor tweaks to spec file
151- Deliver html and reST doc files to specifically named directories
152- Align description with that of http://pygments.org/
153- Add %%check section for Python2 and add BR on python-nose
154
155* Fri Apr 23 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.1-4
156- switched with_python3 back to 1
157
158* Fri Apr 23 2010 David Malcolm <dmalcolm@redhat.com> - 1.3.1-3
159- add python3 subpackage (BZ#537244), ignoring soft-dep on imaging for now
160
[8158]161* Tue Apr 13 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.1-2
[1741]162- added python-imaging as a dependency per BZ#581663.
163
164* Sat Mar  6 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.1-1
165- Updated for release.
166
167* Tue Sep 29 2009 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.1.1-1
168- Updated for release.
169
170* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-5
171- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
172
173* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-4
174- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
175
176* Sun Dec 21 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.0-3
177- Updated for release.
178
179* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.0-2
180- Rebuild for Python 2.6
181
[8158]182* Thu Nov 27 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.0-1
[1741]183- Updated for upstream 1.0.
184
185* Sun Sep 14 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 0.11.1-1
186- Updated for upstream 0.11.
187
188* Mon Jul 21 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 0.10-1
189- Updated for upstream 0.10.
190
191* Thu Nov 29 2007 Steve 'Ashcrow' Milner <me@stevemilner.org> - 0.9-2
192- Added python-setuptools as a Requires per bz#403601.
193
194* Mon Nov 12 2007 Steve 'Ashcrow' Milner <me@stevemilner.org> - 0.9-1
195- Updated for upstream 0.9.
196
[8158]197* Fri Aug 17 2007 Steve 'Ashcrow' Milner <me@stevemilner.org> - 0.8.1-2
[1741]198- Removed the dos2unix build dependency.
199
200* Thu Jun 28 2007 Steve 'Ashcrow' Milner <me@stevemilner.org> - 0.8.1-1
201- Initial packaging for Fedora.
Note: See TracBrowser for help on using the repository browser.