source: projects/specs/trunk/p/python-progressbar2/python-progressbar2-vl.spec @ 12545

Revision 12545, 4.5 KB checked in by tomop, 3 years ago (diff)

rpm-4.16.1.2-1 and requirements

Line 
1%bcond_with tests
2
3%global srcname progressbar2
4
5%global desc %{expand: \
6A text progress bar is typically used to display the progress of a long running
7operation, providing a visual cue that processing is underway.
8
9The ProgressBar class manages the current progress, and the format of the line
10is given by a number of widgets.
11
12The progressbar module is very easy to use, yet very powerful. It will also
13automatically enable features like auto-resizing when the system supports it.}
14
15Name:           python-%{srcname}
16Version:        3.53.1
17Release:        1%{?dist}
18Summary:        A Progressbar library to provide visual progress to long running operations
19Group:          programming
20Vendor:         Project Vine
21Distribution:   Vine Linux
22
23License:        BSD
24URL:            https://pypi.python.org/pypi/%{srcname}
25Source0:        %pypi_source
26
27BuildArch:      noarch
28BuildRequires:  python3-devel
29
30%description
31%{desc}
32
33
34%package -n python3-%{srcname}
35Summary:        %{summary}
36Group:          programming
37Requires:       python3
38Requires:       python3-six
39BuildRequires:  python3-utils
40BuildRequires:  python3-six
41BuildRequires:  python3-setuptools
42BuildRequires:  python3-sphinx
43%if %{with tests}
44BuildRequires:  %{py3_dist freezegun} >= 0.3.10
45%endif
46
47# obsolete python-progressbar
48Obsoletes:      python3-progressbar < 2.3-14
49Provides:       python3-progressbar == %{version}
50
51%{?python_provide:%python_provide python3-%{srcname}}
52
53%description -n python3-%{srcname}
54%{desc}
55
56
57%prep
58%autosetup -n %{srcname}-%{version}
59rm -rfv %{srcname}.egg-info
60
61find . -name '*.pyc' -print -delete
62find . -name '*.swp' -print -delete
63rm -rfv tests/__pycache__/
64
65
66%build
67%py3_build
68
69
70%install
71%py3_install
72
73
74%check
75%if %{with tests}
76PYTHONPATH=. %pytest tests
77%endif
78
79
80%files -n python3-%{srcname}
81%license LICENSE
82%doc README.rst CHANGES.rst CONTRIBUTING.rst
83%{python3_sitelib}/%{srcname}-%{version}-py3.*.egg-info/
84%{python3_sitelib}/progressbar
85
86
87%changelog
88* Tue Feb 23 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.53.1-1
89- initial build for Vine Linux.
90- new upstream release.
91
92* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3.52.1-2
93- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
94
95* Tue Sep 01 2020 Petr Viktorin <pviktori@redhat.com> - 3.52.1-1
96- Update to 3.52.1
97  Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=1873701
98  The only behavior change is that ProgressBar gets a `start_time`
99  keyword argument, which can override the starting time (e.g. for
100  ETA calculations).
101
102* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.51.4-2
103- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
104
105* Sat Jun 27 2020 Petr Viktorin <pviktori@redhat.com> - 3.51.4-1
106- Update to 3.51.4
107- Run pytest directly
108
109* Tue May 26 2020 Miro Hrončok <mhroncok@redhat.com> - 3.47.0-2
110- Rebuilt for Python 3.9
111
112* Wed Feb 12 2020 Petr Viktorin <pviktori@redhat.com> - 3.47.0-1
113- Update to latest upstream version
114  https://github.com/WoLpH/python-progressbar/compare/v3.39.3...vv3.47.0
115  Highlights:
116  - Rate limiting
117  - Added proper support for non-terminal output
118  - Add MultiProgressBar
119
120* Wed Feb 12 2020 Petr Viktorin <pviktori@redhat.com> - 3.39.3-7
121- Remove linting BuildRequires
122  https://bugzilla.redhat.com/show_bug.cgi?id=1795451
123- Fix egg-info glob to work for Python 3.10+
124
125* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.39.3-6
126- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
127
128* Thu Oct 03 2019 Miro Hrončok <mhroncok@redhat.com> - 3.39.3-5
129- Rebuilt for Python 3.8.0rc1 (#1748018)
130
131* Mon Aug 19 2019 Miro Hrončok <mhroncok@redhat.com> - 3.39.3-4
132- Rebuilt for Python 3.8
133
134* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.39.3-3
135- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
136
137* Sun May 12 2019 Orion Poplawski <orion@nwra.com> - 3.39.3-2
138- Drop unneeded BR on pytest-cache
139
140* Wed Apr 10 2019 Ankur Sinha <ankursinha AT fedoraproject DOT org> - 3.39.3-1
141- Update to 3.39.3
142
143* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.39.2-3
144- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
145
146* Wed Dec 19 2018 Petr Viktorin <pviktori@redhat.com> - 3.39.2-2
147- Provide python3-progressbar
148
149* Wed Dec 19 2018 Ankur Sinha <ankursinha AT fedoraproject DOT org> - 3.39.2-1
150- Update to latest upstream commit
151- Should fix failing tests
152
153* Thu Dec 13 2018 Ankur Sinha <ankursinha AT fedoraproject DOT org> - 3.38.0-1
154- Check tests and file issue upstream
155- Initial build
156- Drop py2 subpackage
157- Obsolete python-progressbar
Note: See TracBrowser for help on using the repository browser.