source: projects/specs/trunk/p/python-pexpect/python-pexpect-vl.spec @ 8374

Revision 8374, 6.8 KB checked in by Takemikaduchi, 10 years ago (diff)

Cinnamon-2.2.3

Line 
1Summary:        Unicode-aware Pure Python Expect-like module
2Name:           python-pexpect
3Version:        3.0
4Release:        1%{?_dist_release}
5License:        MIT
6Group:          Development/Languages
7URL:            https://github.com/pexpect/pexpect
8Source0:        https://github.com/pexpect/pexpect/releases/download/%{version}%{?relcand}/pexpect-%{version}%{?relcand}.tar.gz
9BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
10
11BuildArch:      noarch
12
13BuildRequires:  python-devel python-nose ed
14
15%description
16Pexpect is a pure Python module for spawning child applications; controlling
17them; and responding to expected patterns in their output. Pexpect works like
18Don Libes' Expect. Pexpect allows your script to spawn a child application and
19control it as if a human were typing commands.
20
21Pexpect can be used for automating interactive applications such as ssh, ftp,
22passwd, telnet, etc. It can be used to automate setup scripts for duplicating
23software package installations on different servers. And it can be used for
24automated software testing. Pexpect is in the spirit of Don Libes' Expect, but
25Pexpect is pure Python. Unlike other Expect-like modules for Python, Pexpect
26does not require TCL or Expect nor does it require C extensions to be
27compiled.  It should work on any platform that supports the standard Python
28pty module.
29
30%prep
31%setup -q -n pexpect-%{version}
32
33%build
34%{__python} setup.py build
35
36%check
37. ./test.env
38./tools/testall.py
39
40%install
41rm -rf $RPM_BUILD_ROOT
42
43%{__python} setup.py install --skip-build \
44    --root $RPM_BUILD_ROOT --install-lib %{python_sitelib}
45
46rm -rf $RPM_BUILD_ROOT%{python_sitelib}/setuptools/tests
47
48# Correct some permissions
49find examples -type f -exec chmod a-x \{\} \;
50
51%clean
52rm -rf %{buildroot}
53
54%files
55%defattr(-,root,root)
56%doc doc examples LICENSE
57%{python_sitelib}/*.py*
58%{python_sitelib}/pexpect/
59%{python_sitelib}/pexpect-%{version}%{?relcand}-py?.?.egg-info
60%exclude %{python_sitelib}/pexpect/tests/
61
62%changelog
63* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 3.0-1
64- initial build for Vine Linux
65
66
67* Tue Nov 12 2013 Thomas Spura <tomspur@fedoraproject.org> - 3.0-1
68- update to 3.0
69
70* Wed Oct 30 2013 Thomas Spura <tomspur@fedoraproject.org> - 3.0-0.1
71- new upstream is github/pexpect/pexpect
72- update to rc3
73- build on noarch again
74- consistently use %%{buildroot} everywhere
75- be more explicit in %%files
76- remove CFLAGS
77
78* Thu Sep 05 2013 Andrew McNabb <amcnabb@mcnabbs.org> - 2.5.1-11
79- Fix the name of the arm architecture in ExcludeArch
80
81* Thu Sep 05 2013 Andrew McNabb <amcnabb@mcnabbs.org> - 2.5.1-10
82- Remove noarch because of arm build problems (bug #999174)
83
84* Tue Aug 20 2013 Andrew McNabb <amcnabb@mcnabbs.org> - 2.5.1-9
85- Exclude the arm architecture (bug #999174)
86
87* Tue Aug 20 2013 Andrew McNabb <amcnabb@mcnabbs.org> - 2.5.1-8
88- Bump the obsoletes version
89
90* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.1-7
91- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
92
93* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.1-6
94- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
95
96* Tue Nov 20 2012 Andrew McNabb <amcnabb@mcnabbs.org> - 2.5.1-5
97- Exclude test scripts from the files list
98
99* Tue Nov 20 2012 Andrew McNabb <amcnabb@mcnabbs.org> - 2.5.1-4
100- Moved unit tests to a check section
101
102* Tue Nov 20 2012 Andrew McNabb <amcnabb@mcnabbs.org> - 2.5.1-3
103- Added unit tests and fixed metadata fields
104
105* Tue Nov 20 2012 Andrew McNabb <amcnabb@mcnabbs.org> - 2.5.1-2
106- Added versions to the obsoletes and provides fields
107
108* Tue Nov 20 2012 Andrew McNabb <amcnabb@mcnabbs.org> - 2.5.1-1
109- Updated to version 2.5.1 (pexpect-u fork) and added support for Python 3
110
111* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3-6
112- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
113
114* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 2.3-5
115- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
116
117* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3-4
118- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
119
120* Mon Feb 23 2009 Robert Scheck <robert@fedoraproject.org> 2.3-3
121- Rebuild for gcc 4.4 and rpm 4.6
122
123* Fri Dec  5 2008 Jeremy Katz <katzj@redhat.com> - 2.3-2
124- Rebuild for python 2.6
125
126* Tue Jan 08 2008 Robert Scheck <robert@fedoraproject.org> 2.3-1
127- Upgrade to 2.3
128- Updated the source URL to match with the guidelines
129
130* Wed Aug 29 2007 Robert Scheck <robert@fedoraproject.org> 2.1-5
131- Rebuilt (and some minor spec file tweaks)
132
133* Sat Dec 09 2006 Toshio Kuratomi <toshio@tiki-lounge.com> - 2.1-4
134- Bump and rebuild because I forgot to cvs up before the last build.
135
136* Sat Dec 09 2006 Toshio Kuratomi <toshio@tiki-lounge.com> - 2.1-3
137- Bump and rebuild for python 2.5 on devel.
138- Add BR: python-devel as it provides a header necessary for python modules
139  on python 2.5.
140
141* Fri Sep 01 2006 Toshio Kuratomi <toshio@tiki-lounge.com> - 2.1-2
142- Remove pyver define as it's not needed with the automatic python(abi).
143- Stop ghosting .pyos.
144- Let automatic python compilation take care of creating pyos.
145- Rebuild for FC6.
146
147* Mon Jul 17 2006 Toshio Kuratomi <toshio@tiki-lounge.com> - 2.1-1
148- Update to 2.1.
149
150* Thu Feb 16 2006 Toshio Kuratomi <toshio@tiki-lounge.com> - 2.0-2
151- Bump and rebuild for FC5.
152- Convert from python-abi to python(abi) requires.
153
154* Thu Nov 17 2005 Toshio Kuratomi <toshio@tiki-lounge.com> - 2.0-1
155- Update to 2.0.
156
157* Sat Sep 3 2005 Toshio Kuratomi <toshio@tiki-lounge.com> 0.99999b-2
158- Add LICENSE File.
159- Make noarch.
160- Remove executable permissions from the modules copied to examples.
161
162* Fri Sep  2 2005 Toshio Kuratomi <toshio@tiki-lounge.com> 0.99999b
163- Update to version 0.99999b.
164- Add dist tag.
165
166* Thu Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
167- rebuilt
168
169* Thu Feb 03 2005 Toshio Kuratomi <toshio@tiki-lounge.com> 0.999-2
170- Use python_sitelib macro to resolve build issues on x86_64.
171- %%ghost *.pyo
172- Install ANSI.py, screen.py, and FSM.py into the examples.  These are intended
173  to suplement pexpect eventually but they are currently much less robust and
174  not installed to by default.  But they are needed by some examples.
175- Use __python macro in build/install for consistency.
176- Add --skip-build to the invocation of setup.py in install.
177
178* Mon May 31 2004 Panu Matilainen <pmatilai@welho.com> 0.999-0.fdr.1
179- get rid of distrel munging, buildsys does that...
180- update to 0.999
181- update doc and example tarballs
182- fix build on python <> 2.2
183- use -O1 in install to generate .pyo files instead of manually creating the files
184- require python-abi = pyver to get dependencies right
185
186* Sun Jul 27 2003 Panu Matilainen <pmatilai@welho.com> 0.98-0.fdr.3
187- own .pyo files too as suggested by Ville (#517)
188
189* Sat Jul 26 2003 Panu Matilainen <pmatilai@welho.com> 0.98-0.fdr.2
190- fixes by Ville (bug #517) applied
191
192* Sat Jul 26 2003 Panu Matilainen <pmatilai@welho.com>
193- Initial Fedora packaging
194
Note: See TracBrowser for help on using the repository browser.