source: projects/specs/trunk/p/python-paramiko/python-paramiko-vl.spec @ 8167

Revision 8167, 4.7 KB checked in by kudoh, 10 years ago (diff)

new upstream release and rebuild

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3%define srcname paramiko
4
5Name:           python-paramiko
6Version:        1.12.1
7Release:        1%{?_dist_release}
8Summary:        A SSH2 protocol library for python
9Summary(ja):    python 用 SSH2 プロトコルライブラリ
10
11Group:          Development/Libraries
12# No version specified.
13License:        LGPLv2+
14URL:            https://github.com/paramiko/paramiko/
15Source0:        https://pypi.python.org/packages/source/p/paramiko/paramiko-%{version}.tar.gz
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17BuildArch:      noarch
18
19BuildRequires: python-ecdsa
20BuildRequires: python-setuptools
21BuildRequires: python-devel
22BuildRequires: python-crypto >= 2.1
23
24Requires:       python-crypto >= 2.1
25
26%description
27Paramiko (a combination of the esperanto words for "paranoid" and "friend") is
28a module for python 2.3 or greater that implements the SSH2 protocol for secure
29(encrypted and authenticated) connections to remote machines. Unlike SSL (aka
30TLS), the SSH2 protocol does not require heirarchical certificates signed by a
31powerful central authority. You may know SSH2 as the protocol that replaced
32telnet and rsh for secure access to remote shells, but the protocol also
33includes the ability to open arbitrary channels to remote services across an
34encrypted tunnel. (This is how sftp works, for example.)
35
36%prep
37%setup -q -n %{srcname}-%{version}
38%{__chmod} a-x demos/*
39#%{__sed} -i -e '/^#!/,1d' demos/* paramiko/rng*
40%{__sed} -i -e '/^#!/,1d' demos/*
41
42%build
43CFLAGS="$RPM_OPT_FLAGS" %{__python} -c 'import setuptools; execfile("setup.py")' build
44
45%install
46rm -rf $RPM_BUILD_ROOT
47%{__python} -c 'import setuptools; execfile("setup.py")' install --skip-build --root %{buildroot}
48
49%check
50python ./test.py
51
52%clean
53rm -rf $RPM_BUILD_ROOT
54
55%files
56%defattr(-,root,root,-)
57%doc LICENSE README demos/
58%{python_sitelib}/*
59
60%changelog
61* Mon Jan 13 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.12.1-1
62- new upstream release
63- added BuildRequires: python-ecdsa
64
65* Fri Sep 06 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.11.0-1
66- new upstream release
67- added BuildRequires: python-crypto >= 2.1
68- run test script
69
70* Sun Apr 28 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.10.1-1
71- new upstream release
72- changed Source0 and URL
73
74* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.7.1-2
75- rebuild with python-2.7.2
76
77* Wed Jul 20 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.7.7.1-1
78- new upstream release
79- changed Requires: python-crypto >= 2.1
80
81* Thu Nov 5 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.7.6-2
82- added BuildRequires: python-devel
83
84* Tue Nov 3 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.7.6-1
85- new upstream release
86
87* Wed Jul 29 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.7.5-1
88- initial build for VineSeed
89
90* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.4-5
91- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
92
93* Mon Feb 16 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.4-4
94- Add demos as documentation. BZ#485742
95
96* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.7.4-3
97- Rebuild for Python 2.6
98
99* Wed Sep  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.7.4-2
100- fix license tag
101
102* Sun Jul  6 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.4-1
103- Update to 1.7.4
104
105* Mon Mar 24 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.3-1
106- Update to 1.7.3.
107
108* Tue Jan 22 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.2-1
109- Update to 1.7.2.
110- Remove upstreamed patch.
111
112* Mon Jan 14 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.1-3
113- Update to latest Python packaging guidelines.
114- Apply patch that fixes insecure use of RandomPool.
115
116* Thu Jul 19 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.1-2
117- Bump rev
118
119* Thu Jul 19 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.1-1
120- Update to 1.7.1
121
122* Sat Dec 09 2006 Toshio Kuratomi <toshio@tiki-lounge.com> - 1.6.4-1
123- Update to 1.6.4
124- Upstream is now shipping tarballs
125- Bump for python 2.5 in devel
126
127* Mon Oct  9 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.6.2-1
128- Update to 1.6.2
129
130* Sat Sep 16 2006 Shahms E. King <shahms@shahms.com> 1.6.1-3
131- Rebuild for FC6
132
133* Fri Aug 11 2006 Shahms E. King <shahms@shahms.com> 1.6.1-2
134- Include, don't ghost .pyo files per new guidelines
135
136* Tue Aug 08 2006 Shahms E. King <shahms@shahms.com> 1.6.1-1
137- Update to new upstream version
138
139* Fri Jun 02 2006 Shahms E. King <shahms@shahms.com> 1.6-1
140- Update to new upstream version
141- ghost the .pyo files
142
143* Fri May 05 2006 Shahms E. King <shahms@shahms.com> 1.5.4-2
144- Fix source line and rebuild
145
146* Fri May 05 2006 Shahms E. King <shahms@shahms.com> 1.5.4-1
147- Update to new upstream version
148
149* Wed Apr 12 2006 Shahms E. King <shahms@shahms.com> 1.5.3-1
150  - Initial package
Note: See TracBrowser for help on using the repository browser.