source: projects/specs/trunk/p/python-paramiko/python-paramiko-vl.spec @ 7785

Revision 7785, 4.6 KB checked in by kudoh, 11 years ago (diff)

--force-log

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3%define srcname paramiko
4
5Name:           python-paramiko
6Version:        1.11.0
7Release:        1%{?_dist_release}
8Summary:        A SSH2 protocol library for python
9Summary(ja):    python 用 SSH2 プロトコルライブラリ
10
11Group:          Development/Libraries
12# No version specified.
13License:        LGPLv2+
14URL:            https://github.com/paramiko/paramiko/
15Source0:        https://pypi.python.org/packages/source/p/paramiko/paramiko-%{version}.tar.gz
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17BuildArch:      noarch
18BuildRequires: python-setuptools
19BuildRequires: python-devel
20BuildRequires: python-crypto >= 2.1
21
22Requires:       python-crypto >= 2.1
23
24%description
25Paramiko (a combination of the esperanto words for "paranoid" and "friend") is
26a module for python 2.3 or greater that implements the SSH2 protocol for secure
27(encrypted and authenticated) connections to remote machines. Unlike SSL (aka
28TLS), the SSH2 protocol does not require heirarchical certificates signed by a
29powerful central authority. You may know SSH2 as the protocol that replaced
30telnet and rsh for secure access to remote shells, but the protocol also
31includes the ability to open arbitrary channels to remote services across an
32encrypted tunnel. (This is how sftp works, for example.)
33
34%prep
35%setup -q -n %{srcname}-%{version}
36%{__chmod} a-x demos/*
37#%{__sed} -i -e '/^#!/,1d' demos/* paramiko/rng*
38%{__sed} -i -e '/^#!/,1d' demos/*
39
40%build
41CFLAGS="$RPM_OPT_FLAGS" %{__python} -c 'import setuptools; execfile("setup.py")' build
42
43%install
44rm -rf $RPM_BUILD_ROOT
45%{__python} -c 'import setuptools; execfile("setup.py")' install --skip-build --root %{buildroot}
46
47%check
48python ./test.py
49
50%clean
51rm -rf $RPM_BUILD_ROOT
52
53%files
54%defattr(-,root,root,-)
55%doc LICENSE README demos/
56%{python_sitelib}/*
57
58%changelog
59* Fri Sep 06 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.11.0-1
60- new upstream release
61- added BuildRequires: python-crypto >= 2.1
62- run test script
63
64* Sun Apr 28 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.10.1-1
65- new upstream release
66- changed Source0 and URL
67
68* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.7.1-2
69- rebuild with python-2.7.2
70
71* Wed Jul 20 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.7.7.1-1
72- new upstream release
73- changed Requires: python-crypto >= 2.1
74
75* Thu Nov 5 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.7.6-2
76- added BuildRequires: python-devel
77
78* Tue Nov 3 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.7.6-1
79- new upstream release
80
81* Wed Jul 29 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.7.5-1
82- initial build for VineSeed
83
84* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.4-5
85- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
86
87* Mon Feb 16 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.4-4
88- Add demos as documentation. BZ#485742
89
90* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.7.4-3
91- Rebuild for Python 2.6
92
93* Wed Sep  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.7.4-2
94- fix license tag
95
96* Sun Jul  6 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.4-1
97- Update to 1.7.4
98
99* Mon Mar 24 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.3-1
100- Update to 1.7.3.
101
102* Tue Jan 22 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.2-1
103- Update to 1.7.2.
104- Remove upstreamed patch.
105
106* Mon Jan 14 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.1-3
107- Update to latest Python packaging guidelines.
108- Apply patch that fixes insecure use of RandomPool.
109
110* Thu Jul 19 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.1-2
111- Bump rev
112
113* Thu Jul 19 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.1-1
114- Update to 1.7.1
115
116* Sat Dec 09 2006 Toshio Kuratomi <toshio@tiki-lounge.com> - 1.6.4-1
117- Update to 1.6.4
118- Upstream is now shipping tarballs
119- Bump for python 2.5 in devel
120
121* Mon Oct  9 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.6.2-1
122- Update to 1.6.2
123
124* Sat Sep 16 2006 Shahms E. King <shahms@shahms.com> 1.6.1-3
125- Rebuild for FC6
126
127* Fri Aug 11 2006 Shahms E. King <shahms@shahms.com> 1.6.1-2
128- Include, don't ghost .pyo files per new guidelines
129
130* Tue Aug 08 2006 Shahms E. King <shahms@shahms.com> 1.6.1-1
131- Update to new upstream version
132
133* Fri Jun 02 2006 Shahms E. King <shahms@shahms.com> 1.6-1
134- Update to new upstream version
135- ghost the .pyo files
136
137* Fri May 05 2006 Shahms E. King <shahms@shahms.com> 1.5.4-2
138- Fix source line and rebuild
139
140* Fri May 05 2006 Shahms E. King <shahms@shahms.com> 1.5.4-1
141- Update to new upstream version
142
143* Wed Apr 12 2006 Shahms E. King <shahms@shahms.com> 1.5.3-1
144  - Initial package
Note: See TracBrowser for help on using the repository browser.