source: projects/specs/trunk/p/python-paramiko/python-paramiko-vl.spec @ 7634

Revision 7634, 4.4 KB checked in by kudoh, 11 years ago (diff)

--force-log

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3%define srcname paramiko
4
5Name:           python-paramiko
6Version:        1.10.1
7Release:        1%{?_dist_release}
8Summary:        A SSH2 protocol library for python
9Summary(ja):    python 用 SSH2 プロトコルライブラリ
10
11Group:          Development/Libraries
12# No version specified.
13License:        LGPLv2+
14URL:            https://github.com/paramiko/paramiko/
15Source0:        https://pypi.python.org/packages/source/p/paramiko/paramiko-%{version}.tar.gz
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17BuildArch:      noarch
18BuildRequires: python-setuptools
19BuildRequires: python-devel
20
21Requires:       python-crypto >= 2.1
22
23%description
24Paramiko (a combination of the esperanto words for "paranoid" and "friend") is
25a module for python 2.3 or greater that implements the SSH2 protocol for secure
26(encrypted and authenticated) connections to remote machines. Unlike SSL (aka
27TLS), the SSH2 protocol does not require heirarchical certificates signed by a
28powerful central authority. You may know SSH2 as the protocol that replaced
29telnet and rsh for secure access to remote shells, but the protocol also
30includes the ability to open arbitrary channels to remote services across an
31encrypted tunnel. (This is how sftp works, for example.)
32
33%prep
34%setup -q -n %{srcname}-%{version}
35%{__chmod} a-x demos/*
36#%{__sed} -i -e '/^#!/,1d' demos/* paramiko/rng*
37%{__sed} -i -e '/^#!/,1d' demos/*
38
39%build
40CFLAGS="$RPM_OPT_FLAGS" %{__python} -c 'import setuptools; execfile("setup.py")' build
41
42%install
43rm -rf $RPM_BUILD_ROOT
44%{__python} -c 'import setuptools; execfile("setup.py")' install --skip-build --root %{buildroot}
45
46%clean
47rm -rf $RPM_BUILD_ROOT
48
49%files
50%defattr(-,root,root,-)
51%doc LICENSE PKG-INFO README docs/ demos/
52%{python_sitelib}/*
53
54%changelog
55* Sun Apr 28 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.10.1-1
56- new upstream release
57- changed Source0 and URL
58
59* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.7.1-2
60- rebuild with python-2.7.2
61
62* Wed Jul 20 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.7.7.1-1
63- new upstream release
64- changed Requires: python-crypto >= 2.1
65
66* Thu Nov 5 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.7.6-2
67- added BuildRequires: python-devel
68
69* Tue Nov 3 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.7.6-1
70- new upstream release
71
72* Wed Jul 29 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.7.5-1
73- initial build for VineSeed
74
75* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.4-5
76- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
77
78* Mon Feb 16 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.4-4
79- Add demos as documentation. BZ#485742
80
81* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.7.4-3
82- Rebuild for Python 2.6
83
84* Wed Sep  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.7.4-2
85- fix license tag
86
87* Sun Jul  6 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.4-1
88- Update to 1.7.4
89
90* Mon Mar 24 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.3-1
91- Update to 1.7.3.
92
93* Tue Jan 22 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.2-1
94- Update to 1.7.2.
95- Remove upstreamed patch.
96
97* Mon Jan 14 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.1-3
98- Update to latest Python packaging guidelines.
99- Apply patch that fixes insecure use of RandomPool.
100
101* Thu Jul 19 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.1-2
102- Bump rev
103
104* Thu Jul 19 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.1-1
105- Update to 1.7.1
106
107* Sat Dec 09 2006 Toshio Kuratomi <toshio@tiki-lounge.com> - 1.6.4-1
108- Update to 1.6.4
109- Upstream is now shipping tarballs
110- Bump for python 2.5 in devel
111
112* Mon Oct  9 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.6.2-1
113- Update to 1.6.2
114
115* Sat Sep 16 2006 Shahms E. King <shahms@shahms.com> 1.6.1-3
116- Rebuild for FC6
117
118* Fri Aug 11 2006 Shahms E. King <shahms@shahms.com> 1.6.1-2
119- Include, don't ghost .pyo files per new guidelines
120
121* Tue Aug 08 2006 Shahms E. King <shahms@shahms.com> 1.6.1-1
122- Update to new upstream version
123
124* Fri Jun 02 2006 Shahms E. King <shahms@shahms.com> 1.6-1
125- Update to new upstream version
126- ghost the .pyo files
127
128* Fri May 05 2006 Shahms E. King <shahms@shahms.com> 1.5.4-2
129- Fix source line and rebuild
130
131* Fri May 05 2006 Shahms E. King <shahms@shahms.com> 1.5.4-1
132- Update to new upstream version
133
134* Wed Apr 12 2006 Shahms E. King <shahms@shahms.com> 1.5.3-1
135  - Initial package
Note: See TracBrowser for help on using the repository browser.