source: projects/specs/trunk/p/python-lxml/python-lxml-vl.spec @ 11173

Revision 11173, 3.2 KB checked in by tomop, 7 years ago (diff)

python-lxml-3.8.0-1

Line 
1%{!?python3_sitelib: %global python3_sitelib %(python3 -c "from distutils.sysconfig import get_python_lib; print (get_python_lib())")}
2%{!?python3_sitearch: %global python3_sitearch %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
3
4%define _lxml lxml
5Summary: lxml is a Pythonic binding for the libxml2 and libxslt libraries
6Summary(ja): lxml は libxml2 と libxslt の Python バインディングです
7Name: python-%{_lxml}
8Group: Development/Libraries
9Version: 3.8.0
10Release: 1%{?_dist_release}
11License: BSD
12URL: http://codespeak.net/lxml
13#URL: http://pypi.python.org/pypi/lxml
14Source: http://pypi.python.org/packages/source/l/%{_lxml}/%{_lxml}-%{version}.tar.gz
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16Vendor: Project Vine
17Distribution: Vine Linux
18
19BuildRequires: libxml2-devel >= 2.6.21
20BuildRequires: libxslt-devel >= 1.1.15
21BuildRequires: python-devel >= 2.3
22BuildRequires: python3-devel
23BuildRequires: python-pyrex
24
25%description
26lxml is a Pythonic binding for the libxml2_ and libxslt_ libraries.  It is
27unique in that it combines the speed and feature completeness of these
28libraries with the simplicity of a native Python API, mostly compatible but
29superior to the well-known ElementTree_ API.  See the introduction_ for more
30information about background and goals.
31
32%package -n python3-lxml
33Summary: lxml is a Pythonic binding for the libxml2 and libxslt libraries
34Summary(ja): lxml は libxml2 と libxslt の Python バインディングです
35Group: Development/Libraries
36
37%description -n python3-lxml
38lxml is a Pythonic binding for the libxml2_ and libxslt_ libraries.  It is
39unique in that it combines the speed and feature completeness of these
40libraries with the simplicity of a native Python API, mostly compatible but
41superior to the well-known ElementTree_ API.  See the introduction_ for more
42information about background and goals.
43
44%prep
45%setup -q -T -c -n %{_lxml}-%{version}
46
47tar xvf %{SOURCE0}
48mv %{_lxml}-%{version} py2
49
50cp -a py2 py3
51
52%build
53pushd py2
54%{__python} setup.py build
55popd
56
57pushd py3
58python3 setup.py build
59popd
60
61%install
62rm -rf $RPM_BUILD_ROOT
63
64pushd py2
65%{__python} setup.py install --root=$RPM_BUILD_ROOT
66popd
67
68pushd py3
69python3 setup.py install --root=$RPM_BUILD_ROOT
70popd
71
72%clean
73rm -rf $RPM_BUILD_ROOT
74
75%files
76%defattr(-,root,root)
77%doc py2/CHANGES.txt py2/CREDITS.txt py2/LICENSES.txt py2/README.* py2/TODO.txt
78%doc py2/doc
79%{python_sitearch}/%{_lxml}
80%{python_sitearch}/%{_lxml}-*-info
81
82%files -n python3-lxml
83%defattr(-,root,root)
84%doc py3/CHANGES.txt py3/CREDITS.txt py3/LICENSES.txt py3/README.* py3/TODO.txt
85%doc py3/doc
86%{python3_sitearch}/%{_lxml}
87%{python3_sitearch}/%{_lxml}-*-info
88
89%changelog
90* Sat Sep 09 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.0-1
91- new upstream release.
92- added python3 support.
93
94* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.6-4
95- rebuild with VineSeed environment
96
97* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.6-3
98- rebuild with python-2.7.2
99
100* Wed Mar 10 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 2.2.6-2
101- change required version of libxml2-devel for Vine Plus/5
102  (2.7.2 or later is recomended, but works with 2.6.21 or later)
103
104* Sun Mar 07 2010 Shu KONNO <owa@bg.wakwak.com> 2.2.6-1
105- initial build for vine linux
106
Note: See TracBrowser for help on using the repository browser.