source: projects/specs/trunk/p/python-lxml/python-lxml-vl.spec @ 12469

Revision 12469, 2.9 KB checked in by tomop, 4 years ago (diff)

python-3.8.5 and related packages.

Line 
1%define _lxml lxml
2Summary: lxml is a Pythonic binding for the libxml2 and libxslt libraries
3Summary(ja): lxml は libxml2 と libxslt の Python バインディングです
4Name: python-%{_lxml}
5Group: programming
6Version: 4.5.2
7Release: 1%{?_dist_release}
8Vendor: Project Vine
9Distribution: Vine Linux
10
11License: BSD
12URL: https://lxml.de/
13#URL: http://pypi.python.org/pypi/lxml
14Source: https://pypi.python.org/packages/source/l/%{_lxml}/%{_lxml}-%{version}.tar.gz
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16
17BuildRequires: libxml2-devel >= 2.6.21
18BuildRequires: libxslt-devel >= 1.1.15
19BuildRequires: python-rpm-macros
20
21BuildRequires: python-devel >= 2.3
22BuildRequires: python2-rpm-macros
23BuildRequires: python-pyrex
24
25BuildRequires: python3-devel
26BuildRequires: python3-rpm-macros
27
28%description
29lxml is a Pythonic binding for the libxml2_ and libxslt_ libraries.  It is
30unique in that it combines the speed and feature completeness of these
31libraries with the simplicity of a native Python API, mostly compatible but
32superior to the well-known ElementTree_ API.  See the introduction_ for more
33information about background and goals.
34
35
36%package -n python3-lxml
37Summary: lxml is a Pythonic binding for the libxml2 and libxslt libraries
38Summary(ja): lxml は libxml2 と libxslt の Python バインディングです
39Group: programming
40
41%description -n python3-lxml
42lxml is a Pythonic binding for the libxml2_ and libxslt_ libraries.  It is
43unique in that it combines the speed and feature completeness of these
44libraries with the simplicity of a native Python API, mostly compatible but
45superior to the well-known ElementTree_ API.  See the introduction_ for more
46information about background and goals.
47
48
49%prep
50%setup -q -n %{_lxml}-%{version}
51
52
53%build
54%py2_build
55%py3_build
56
57
58%install
59rm -rf $RPM_BUILD_ROOT
60%py2_install
61%py3_install
62
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67
68%files
69%defattr(-,root,root)
70%license LICENSE*
71%doc CHANGES.txt CREDITS.txt README.* TODO.txt
72%doc doc
73%{python2_sitearch}/%{_lxml}
74%{python2_sitearch}/%{_lxml}-*-info
75
76%files -n python3-lxml
77%defattr(-,root,root)
78%license LICENSE*
79%doc CHANGES.txt CREDITS.txt README.* TODO.txt
80%doc doc
81%{python3_sitearch}/%{_lxml}
82%{python3_sitearch}/%{_lxml}-*-info
83
84
85%changelog
86* Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.5.2-1
87- new upstream release.
88
89* Sat Sep 09 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.0-1
90- new upstream release.
91- added python3 support.
92
93* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.6-4
94- rebuild with VineSeed environment
95
96* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.6-3
97- rebuild with python-2.7.2
98
99* Wed Mar 10 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 2.2.6-2
100- change required version of libxml2-devel for Vine Plus/5
101  (2.7.2 or later is recomended, but works with 2.6.21 or later)
102
103* Sun Mar 07 2010 Shu KONNO <owa@bg.wakwak.com> 2.2.6-1
104- initial build for vine linux
105
Note: See TracBrowser for help on using the repository browser.