source: projects/specs/trunk/p/python-ldap/python-ldap-vl.spec @ 868

Revision 868, 5.7 KB checked in by owa, 14 years ago (diff)

rebuilt with python-2.6

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3%define openldap_version 2.1.22
4
5### Abstract ###
6
7Name: python-ldap
8Version: 2.3.11
9Release: 1%{?_dist_release}
10Epoch: 0
11License: Python
12Group: System Environment/Libraries
13Summary: An object-oriented API for Python to access LDAP directory servers
14Summary(ja): Python 用 LDAP インタフェースモジュール
15URL: http://python-ldap.sourceforge.net/
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17Source0: http://download.sourceforge.net/python-ldap/python-ldap-%{version}.tar.gz
18
19### Patches ###
20
21#Patch0: python-ldap-2.2.0-dirs.patch
22Patch0: python-ldap-2.3.11-dirs.patch
23
24### Dependencies ###
25
26Requires: openldap >= %{openldap_version}
27
28### Build Dependencies ###
29
30# the openldap from RHL <= 9 and RHEL <= 3 is too old for python-ldap
31BuildRequires: openldap-devel >= %{openldap_version}
32BuildRequires: openssl-devel
33BuildRequires: python-devel >= 2.2
34BuildRequires: cyrus-sasl-devel
35
36
37%description
38python-ldap provides an object-oriented API for working with LDAP within
39Python programs.  It allows access to LDAP directory servers by wrapping the
40OpenLDAP 2.x libraries, and contains modules for other LDAP-related tasks
41(including processing LDIF, LDAPURLs, LDAPv3 schema, etc.).
42
43%description -l ja
44python-ldap により、Python プログラムから LDAP へアクセスするための
45オブジェクト志向 API が提供されます。OpenLDAP 2.x のライブラリのラッパー
46として動作し、LDAP ディレクトリサーバへのアクセスを行うことができます。
47また他に LDIF、LDAPURL、LDAPv3 スキーマといった LDAP 関連用のモジュールも
48収録されています。
49
50
51%prep
52%setup -q -n python-ldap-%{version}
53%patch0 -p0 -b .dirs
54
55# clean up cvs hidden files
56rm -rf Demo/Lib/ldap/.cvsignore Demo/.cvsignore Demo/Lib/ldif/.cvsignore Demo/Lib/ldap/async/.cvsignore \
57       Demo/Lib/.cvsignore Demo/Lib/ldapurl/.cvsignore
58
59# Fix interpreter
60sed -i 's|#! python|#!/usr/bin/python|g' Demo/simplebrowse.py
61
62
63%build
64%{__python} setup.py build
65
66
67%install
68rm -rf $RPM_BUILD_ROOT
69%{__python} setup.py install --skip-build --root $RPM_BUILD_ROOT
70
71
72%clean
73rm -rf $RPM_BUILD_ROOT
74
75
76%files
77%defattr(-,root,root,-)
78%doc LICENCE CHANGES README TODO Demo
79%{python_sitearch}/_ldap.so
80%{python_sitearch}/dsml.py*
81%{python_sitearch}/ldapurl.py*
82%{python_sitearch}/ldif.py*
83%{python_sitearch}/ldap/
84%{python_sitearch}/python_ldap-%{version}-*.egg-info/
85
86
87%changelog
88* Mon Apr 19 2010 Shu KONNO <owa@bg.wakwak.com> 2.3.11-1
89- updated python-ldap to 2.3.11
90- updated Patch0: python-ldap-%{version}-dirs.patch
91- rebuilt with python-2.6, openldap-2.4.21
92
93* Sat Apr  4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.3.5-2
94- rebuilt with openldap-2.4.11
95
96* Tue Feb  3 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.3.5-1
97- initial build for Vine Linux
98
99* Fri Jan 16 2009 Tomas Mraz <tmraz@redhat.com> - 0:2.3.5-3
100- rebuild with new openssl
101
102* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0:2.3.5-2
103- Rebuild for Python 2.6
104
105* Wed Sep  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0:2.3.5-1
106- fix license tag
107- update to 2.3.5
108
109* Sun Feb 17 2008 Matthew Barnes <mbarnes@redhat.com> - 0:2.3.1-3.fc9
110- Rebuild with GCC 4.3
111
112* Wed Dec 05 2007 Matthew Barnes <mbarnes@redhat.com> - 0:2.3.1-2.fc9
113- Rebuild against new openssl.
114
115* Wed Oct 10 2007 Matthew Barnes <mbarnes@redhat.com> - 0:2.3.1-1.fc8
116- Update to 2.3.1
117
118* Fri Jun 08 2007 Matthew Barnes <mbarnes@redhat.com> - 0:2.3.0-1.fc8
119- Update to 2.3
120- Spec file cleanups.
121
122* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 0:2.2.0-3
123- rebuild against python 2.5
124
125* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com>
126- rebuild
127
128* Wed May 17 2006 Matthew Barnes <mbarnes@redhat.com> - 2.2.0-2
129- Put back the epoch line... happy beehive?
130
131* Tue May 15 2006 Matthew Barnes <mbarnes@redhat.com> - 2.2.0-1
132- Update to 2.2.0
133- Update python-ldap-2.0.6-rpath.patch and rename it to
134  python-ldap-2.2.0-dirs.patch.
135
136* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0:2.0.6-5.2.1
137- bump again for double-long bug on ppc(64)
138
139* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0:2.0.6-5.2
140- rebuilt for new gcc4.1 snapshot and glibc changes
141
142* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
143- rebuilt
144
145* Tue Nov  8 2005 Tomas Mraz <tmraz@redhat.com> - 2.0.6-5
146- rebuilt with new openssl
147
148* Tue Mar 22 2005 Warren Togami <wtogami@redhat.com> - 2.0.6-4
149- add LICENCE (#150842)
150- simplify python reqs
151- remove invalid rpath
152
153* Wed Mar 16 2005 Dan Williams <dcbw@redhat.com> - 0:2.0.6-2
154- rebuilt to pick up new libssl.so.5
155
156* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 0:2.0.6-1
157- 2.0.6
158
159* Tue Nov 16 2004 Nalin Dahyabhai <nalin@redhat.com> - 0:2.0.1-3
160- rebuild (#139161)
161
162* Mon Aug 30 2004 David Malcolm <dmalcolm@redhat.com> - 0:2.0.1-2
163- Rewrote description; added requirement for openldap
164
165* Tue Aug 17 2004 David Malcolm <dmalcolm@redhat.com> - 0:2.0.1-1
166- imported into Red Hat's packaging system from Fedora.us; set release to 1
167
168* Wed Jun 30 2004 Panu Matilainen <pmatilai@welho.com> 0:2.0.1-0.fdr.1
169- update to 2.0.1
170
171* Sun Dec 07 2003 Panu Matilainen <pmatilai@welho.com> 0:2.0.0-0.fdr.0.4.pre16
172- fix spec permissions + release tag order (bug 1099)
173
174* Sat Dec  6 2003 Ville Skyttä <ville.skytta at iki.fi> 0:2.0.0-0.fdr.0.pre16.3
175- Stricter python version requirements.
176- BuildRequire openssl-devel.
177- Explicitly build *.pyo, install them as %%ghost.
178- Own more installed dirs.
179- Remove $RPM_BUILD_ROOT at start of %%install.
180
181* Wed Dec 03 2003 Panu Matilainen <pmatilai@welho.com> 0:2.0.0-0.fdr.0.pre16.2
182- duh, build requires python-devel, not just python...
183
184* Wed Dec 03 2003 Panu Matilainen <pmatilai@welho.com> 0:2.0.0-0.fdr.0.pre16.1
185- Initial Fedora packaging.
Note: See TracBrowser for help on using the repository browser.