source: projects/specs/trunk/p/python-ldap/python-ldap-vl.spec @ 521

Revision 521, 5.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3%define openldap_version 2.1.22
4
5### Abstract ###
6
7Name: python-ldap
8Version: 2.3.5
9Release: 2%{?_dist_release}
10Epoch: 0
11License: Python
12Group: System Environment/Libraries
13Summary: An object-oriented API for Python to access LDAP directory servers
14Summary(ja): Python 用 LDAP インタフェースモジュール
15URL: http://python-ldap.sourceforge.net/
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17Source0: http://download.sourceforge.net/python-ldap/python-ldap-%{version}.tar.gz
18
19### Patches ###
20
21Patch0: python-ldap-2.2.0-dirs.patch
22
23### Dependencies ###
24
25Requires: openldap >= %{openldap_version}
26
27### Build Dependencies ###
28
29# the openldap from RHL <= 9 and RHEL <= 3 is too old for python-ldap
30BuildRequires: openldap-devel >= %{openldap_version}
31BuildRequires: openssl-devel
32BuildRequires: python-devel >= 2.2
33BuildRequires: cyrus-sasl-devel
34
35
36%description
37python-ldap provides an object-oriented API for working with LDAP within
38Python programs.  It allows access to LDAP directory servers by wrapping the
39OpenLDAP 2.x libraries, and contains modules for other LDAP-related tasks
40(including processing LDIF, LDAPURLs, LDAPv3 schema, etc.).
41
42%description -l ja
43python-ldap により、Python プログラムから LDAP へアクセスするための
44オブジェクト志向 API が提供されます。OpenLDAP 2.x のライブラリのラッパー
45として動作し、LDAP ディレクトリサーバへのアクセスを行うことができます。
46また他に LDIF、LDAPURL、LDAPv3 スキーマといった LDAP 関連用のモジュールも
47収録されています。
48
49
50%prep
51%setup -q -n python-ldap-%{version}
52%patch0 -p1 -b .dirs
53
54# clean up cvs hidden files
55rm -rf Demo/Lib/ldap/.cvsignore Demo/.cvsignore Demo/Lib/ldif/.cvsignore Demo/Lib/ldap/async/.cvsignore \
56       Demo/Lib/.cvsignore Demo/Lib/ldapurl/.cvsignore
57
58# Fix interpreter
59sed -i 's|#! python|#!/usr/bin/python|g' Demo/simplebrowse.py
60
61
62%build
63%{__python} setup.py build
64
65
66%install
67rm -rf $RPM_BUILD_ROOT
68%{__python} setup.py install --skip-build --root $RPM_BUILD_ROOT
69
70
71%clean
72rm -rf $RPM_BUILD_ROOT
73
74
75%files
76%defattr(-,root,root,-)
77%doc LICENCE CHANGES README TODO Demo
78%{python_sitearch}/_ldap.so
79%{python_sitearch}/dsml.py*
80%{python_sitearch}/ldapurl.py*
81%{python_sitearch}/ldif.py*
82%{python_sitearch}/ldap/
83%{python_sitearch}/python_ldap-%{version}-*.egg-info/
84
85
86%changelog
87* Sat Apr  4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.3.5-2
88- rebuilt with openldap-2.4.11
89
90* Tue Feb  3 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.3.5-1
91- initial build for Vine Linux
92
93* Fri Jan 16 2009 Tomas Mraz <tmraz@redhat.com> - 0:2.3.5-3
94- rebuild with new openssl
95
96* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0:2.3.5-2
97- Rebuild for Python 2.6
98
99* Wed Sep  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0:2.3.5-1
100- fix license tag
101- update to 2.3.5
102
103* Sun Feb 17 2008 Matthew Barnes <mbarnes@redhat.com> - 0:2.3.1-3.fc9
104- Rebuild with GCC 4.3
105
106* Wed Dec 05 2007 Matthew Barnes <mbarnes@redhat.com> - 0:2.3.1-2.fc9
107- Rebuild against new openssl.
108
109* Wed Oct 10 2007 Matthew Barnes <mbarnes@redhat.com> - 0:2.3.1-1.fc8
110- Update to 2.3.1
111
112* Fri Jun 08 2007 Matthew Barnes <mbarnes@redhat.com> - 0:2.3.0-1.fc8
113- Update to 2.3
114- Spec file cleanups.
115
116* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 0:2.2.0-3
117- rebuild against python 2.5
118
119* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com>
120- rebuild
121
122* Wed May 17 2006 Matthew Barnes <mbarnes@redhat.com> - 2.2.0-2
123- Put back the epoch line... happy beehive?
124
125* Tue May 15 2006 Matthew Barnes <mbarnes@redhat.com> - 2.2.0-1
126- Update to 2.2.0
127- Update python-ldap-2.0.6-rpath.patch and rename it to
128  python-ldap-2.2.0-dirs.patch.
129
130* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0:2.0.6-5.2.1
131- bump again for double-long bug on ppc(64)
132
133* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0:2.0.6-5.2
134- rebuilt for new gcc4.1 snapshot and glibc changes
135
136* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
137- rebuilt
138
139* Tue Nov  8 2005 Tomas Mraz <tmraz@redhat.com> - 2.0.6-5
140- rebuilt with new openssl
141
142* Tue Mar 22 2005 Warren Togami <wtogami@redhat.com> - 2.0.6-4
143- add LICENCE (#150842)
144- simplify python reqs
145- remove invalid rpath
146
147* Wed Mar 16 2005 Dan Williams <dcbw@redhat.com> - 0:2.0.6-2
148- rebuilt to pick up new libssl.so.5
149
150* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 0:2.0.6-1
151- 2.0.6
152
153* Tue Nov 16 2004 Nalin Dahyabhai <nalin@redhat.com> - 0:2.0.1-3
154- rebuild (#139161)
155
156* Mon Aug 30 2004 David Malcolm <dmalcolm@redhat.com> - 0:2.0.1-2
157- Rewrote description; added requirement for openldap
158
159* Tue Aug 17 2004 David Malcolm <dmalcolm@redhat.com> - 0:2.0.1-1
160- imported into Red Hat's packaging system from Fedora.us; set release to 1
161
162* Wed Jun 30 2004 Panu Matilainen <pmatilai@welho.com> 0:2.0.1-0.fdr.1
163- update to 2.0.1
164
165* Sun Dec 07 2003 Panu Matilainen <pmatilai@welho.com> 0:2.0.0-0.fdr.0.4.pre16
166- fix spec permissions + release tag order (bug 1099)
167
168* Sat Dec  6 2003 Ville Skyttä <ville.skytta at iki.fi> 0:2.0.0-0.fdr.0.pre16.3
169- Stricter python version requirements.
170- BuildRequire openssl-devel.
171- Explicitly build *.pyo, install them as %%ghost.
172- Own more installed dirs.
173- Remove $RPM_BUILD_ROOT at start of %%install.
174
175* Wed Dec 03 2003 Panu Matilainen <pmatilai@welho.com> 0:2.0.0-0.fdr.0.pre16.2
176- duh, build requires python-devel, not just python...
177
178* Wed Dec 03 2003 Panu Matilainen <pmatilai@welho.com> 0:2.0.0-0.fdr.0.pre16.1
179- Initial Fedora packaging.
Note: See TracBrowser for help on using the repository browser.