source: projects/specs/trunk/p/python-ldap/python-ldap-vl.spec @ 11827

Revision 11827, 6.1 KB checked in by ara_t, 5 years ago (diff)

rebuild with openssl-1.1.1

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3%define openldap_version 2.1.22
4
5### Abstract ###
6
7Name: python-ldap
8Version: 2.3.11
9Release: 5%{?_dist_release}
10Epoch: 0
11License: Python
12Group: System Environment/Libraries
13Summary: An object-oriented API for Python to access LDAP directory servers
14Summary(ja): Python 用 LDAP インタフェースモジュール
15URL: http://python-ldap.sourceforge.net/
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17Source0: http://download.sourceforge.net/python-ldap/python-ldap-%{version}.tar.gz
18
19### Patches ###
20
21#Patch0: python-ldap-2.2.0-dirs.patch
22Patch0: python-ldap-2.3.11-dirs.patch
23
24### Dependencies ###
25
26Requires: openldap >= %{openldap_version}
27
28### Build Dependencies ###
29
30# the openldap from RHL <= 9 and RHEL <= 3 is too old for python-ldap
31BuildRequires: openldap-devel >= %{openldap_version}
32BuildRequires: openssl-devel
33BuildRequires: python-devel >= 2.2
34BuildRequires: cyrus-sasl-devel
35
36
37%description
38python-ldap provides an object-oriented API for working with LDAP within
39Python programs.  It allows access to LDAP directory servers by wrapping the
40OpenLDAP 2.x libraries, and contains modules for other LDAP-related tasks
41(including processing LDIF, LDAPURLs, LDAPv3 schema, etc.).
42
43%description -l ja
44python-ldap により、Python プログラムから LDAP へアクセスするための
45オブジェクト志向 API が提供されます。OpenLDAP 2.x のライブラリのラッパー
46として動作し、LDAP ディレクトリサーバへのアクセスを行うことができます。
47また他に LDIF、LDAPURL、LDAPv3 スキーマといった LDAP 関連用のモジュールも
48収録されています。
49
50
51%prep
52%setup -q -n python-ldap-%{version}
53%patch0 -p0 -b .dirs
54
55# clean up cvs hidden files
56rm -rf Demo/Lib/ldap/.cvsignore Demo/.cvsignore Demo/Lib/ldif/.cvsignore Demo/Lib/ldap/async/.cvsignore \
57       Demo/Lib/.cvsignore Demo/Lib/ldapurl/.cvsignore
58
59# Fix interpreter
60sed -i 's|#! python|#!/usr/bin/python|g' Demo/simplebrowse.py
61
62
63%build
64%{__python} setup.py build
65
66
67%install
68rm -rf $RPM_BUILD_ROOT
69%{__python} setup.py install --skip-build --root $RPM_BUILD_ROOT
70
71
72%clean
73rm -rf $RPM_BUILD_ROOT
74
75
76%files
77%defattr(-,root,root,-)
78%doc LICENCE CHANGES README TODO Demo
79%{python_sitearch}/_ldap.so
80%{python_sitearch}/dsml.py*
81%{python_sitearch}/ldapurl.py*
82%{python_sitearch}/ldif.py*
83%{python_sitearch}/ldap/
84%{python_sitearch}/python_ldap-%{version}-*.egg-info
85
86
87%changelog
88* Fri Nov 02 2018 Toshiaki Ara <ara_t@384.jp> 2.3.11-5
89- rebuild with openssl-1.1.1
90
91* Fri Dec 26 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.3.11-4
92- rebuilt with cyrus-sasl 2.1.26
93
94* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.3.11-3
95- rebuild with VineSeed environment
96
97* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.3.11-2
98- rebuild with python-2.7.2
99
100* Mon Apr 19 2010 Shu KONNO <owa@bg.wakwak.com> 2.3.11-1
101- updated python-ldap to 2.3.11
102- updated Patch0: python-ldap-%{version}-dirs.patch
103- rebuilt with python-2.6, openldap-2.4.21
104
105* Sat Apr  4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.3.5-2
106- rebuilt with openldap-2.4.11
107
108* Tue Feb  3 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.3.5-1
109- initial build for Vine Linux
110
111* Fri Jan 16 2009 Tomas Mraz <tmraz@redhat.com> - 0:2.3.5-3
112- rebuild with new openssl
113
114* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0:2.3.5-2
115- Rebuild for Python 2.6
116
117* Wed Sep  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0:2.3.5-1
118- fix license tag
119- update to 2.3.5
120
121* Sun Feb 17 2008 Matthew Barnes <mbarnes@redhat.com> - 0:2.3.1-3.fc9
122- Rebuild with GCC 4.3
123
124* Wed Dec 05 2007 Matthew Barnes <mbarnes@redhat.com> - 0:2.3.1-2.fc9
125- Rebuild against new openssl.
126
127* Wed Oct 10 2007 Matthew Barnes <mbarnes@redhat.com> - 0:2.3.1-1.fc8
128- Update to 2.3.1
129
130* Fri Jun 08 2007 Matthew Barnes <mbarnes@redhat.com> - 0:2.3.0-1.fc8
131- Update to 2.3
132- Spec file cleanups.
133
134* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 0:2.2.0-3
135- rebuild against python 2.5
136
137* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com>
138- rebuild
139
140* Wed May 17 2006 Matthew Barnes <mbarnes@redhat.com> - 2.2.0-2
141- Put back the epoch line... happy beehive?
142
143* Mon May 15 2006 Matthew Barnes <mbarnes@redhat.com> - 2.2.0-1
144- Update to 2.2.0
145- Update python-ldap-2.0.6-rpath.patch and rename it to
146  python-ldap-2.2.0-dirs.patch.
147
148* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0:2.0.6-5.2.1
149- bump again for double-long bug on ppc(64)
150
151* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0:2.0.6-5.2
152- rebuilt for new gcc4.1 snapshot and glibc changes
153
154* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
155- rebuilt
156
157* Tue Nov  8 2005 Tomas Mraz <tmraz@redhat.com> - 2.0.6-5
158- rebuilt with new openssl
159
160* Tue Mar 22 2005 Warren Togami <wtogami@redhat.com> - 2.0.6-4
161- add LICENCE (#150842)
162- simplify python reqs
163- remove invalid rpath
164
165* Wed Mar 16 2005 Dan Williams <dcbw@redhat.com> - 0:2.0.6-2
166- rebuilt to pick up new libssl.so.5
167
168* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 0:2.0.6-1
169- 2.0.6
170
171* Tue Nov 16 2004 Nalin Dahyabhai <nalin@redhat.com> - 0:2.0.1-3
172- rebuild (#139161)
173
174* Mon Aug 30 2004 David Malcolm <dmalcolm@redhat.com> - 0:2.0.1-2
175- Rewrote description; added requirement for openldap
176
177* Tue Aug 17 2004 David Malcolm <dmalcolm@redhat.com> - 0:2.0.1-1
178- imported into Red Hat's packaging system from Fedora.us; set release to 1
179
180* Wed Jun 30 2004 Panu Matilainen <pmatilai@welho.com> 0:2.0.1-0.fdr.1
181- update to 2.0.1
182
183* Sun Dec 07 2003 Panu Matilainen <pmatilai@welho.com> 0:2.0.0-0.fdr.0.4.pre16
184- fix spec permissions + release tag order (bug 1099)
185
186* Sat Dec  6 2003 Ville Skyttä <ville.skytta at iki.fi> 0:2.0.0-0.fdr.0.pre16.3
187- Stricter python version requirements.
188- BuildRequire openssl-devel.
189- Explicitly build *.pyo, install them as %%ghost.
190- Own more installed dirs.
191- Remove $RPM_BUILD_ROOT at start of %%install.
192
193* Wed Dec 03 2003 Panu Matilainen <pmatilai@welho.com> 0:2.0.0-0.fdr.0.pre16.2
194- duh, build requires python-devel, not just python...
195
196* Wed Dec 03 2003 Panu Matilainen <pmatilai@welho.com> 0:2.0.0-0.fdr.0.pre16.1
197- Initial Fedora packaging.
Note: See TracBrowser for help on using the repository browser.