source: projects/specs/trunk/p/python-imaging/python-imaging-vl.spec @ 5701

Revision 5701, 4.3 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1Summary: The Python Imaging Library
2Summary(ja): Python イメージ処理ライブラリ
3Name: python-imaging
4Version: 1.1.7
5Release: 3%{?_dist_release}
6License: Distributable
7Group: Development/Languages
8URL: http://www.pythonware.com/products/pil
9Source0: http://effbot.org/downloads/Imaging-%{version}.tar.gz
10Patch0: Imaging-1.1.7-setup.lib64.patch
11BuildRequires: python-devel >= 2.6
12BuildRequires: libjpeg-devel libpng-devel zlib-devel freetype2-devel
13BuildRequires: xorg-x11-devel
14BuildRequires: sane-devel
15Requires: python >= 2.6
16Requires: libjpeg >= 6a
17Requires: libpng >= 1.0.12
18Requires: zlib >= 1.1.4
19Requires: freetype2 >= 2.1.3
20Provides: Imaging, python-PIL
21Obsoletes: Imaging < %{version}
22Obsoletes: python-PIL < %{version}
23Obsoletes: python-Imaging <= %{version}
24BuildRoot: %{_tmppath}/%{name}-%{version}-root
25Distribution: Vine Linux
26Vendor: Project Vine
27Packager: owa
28
29%description
30The Python Imaging Library (PIL) adds image processing capabilities
31to your Python environment.  This library provides extensive file
32format support, an efficient internal representation, and fairly
33powerful image processing capabilities.
34%description -l ja
35Python Imaging Library (PIL) は Python 環境にイメージ処理能力を加えます.
36このライブラリには広範なファイル型式への対応, 効果的な内部表現, そして
37真にパワフルなイメージ処理能力が備わっています.
38
39
40%prep
41%setup -q -n Imaging-%{version}
42%ifarch x86_64
43%patch0 -p1 -b .lib64~
44%endif
45
46
47%build
48python setup.py build_ext -i
49python selftest.py
50
51
52%install
53rm -rf $RPM_BUILD_ROOT
54python setup.py install --root=$RPM_BUILD_ROOT
55
56mkdir -p $RPM_BUILD_ROOT%{_includedir}/python%{pyver}/PIL
57cp -p libImaging/*.h $RPM_BUILD_ROOT%{_includedir}/python%{pyver}/PIL/
58
59mkdir -p $RPM_BUILD_ROOT%{python_sitearch}/Sane
60pushd Sane
61python setup.py install --root=$RPM_BUILD_ROOT --install-lib=%{python_sitearch}/Sane
62install -m644 demo_numarray.py $RPM_BUILD_ROOT%{python_sitearch}/Sane
63install -m644 CHANGES README sanedoc.txt $RPM_BUILD_ROOT%{python_sitearch}/Sane
64popd
65
66
67%clean
68rm -rf $RPM_BUILD_ROOT
69
70%files
71%defattr(-, root, root)
72%doc BUILDME CHANGES CONTENTS README
73%doc Docs
74%dir %{python_sitearch}/PIL
75%dir %{python_sitearch}/Sane
76%{_bindir}/pil*.py
77%{_includedir}/python%{pyver}/PIL/*.h
78%{python_sitearch}/PIL.pth
79%{python_sitearch}/PIL/*
80%{python_sitearch}/Sane/*
81
82
83%changelog
84* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.7-3
85- rebuild with python-2.7.2
86
87* Sat May 07 2011 Shu KONNO <owa@bg.wakwak.com> 1.1.7-2
88- install PIL with setup.py
89- install Sane with setup.py
90- install %{_bindir}/pil*.py
91- added BR: sane-devel
92
93* Thu Feb 03 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.7-1
94- new upstream release
95- recreated Patch0
96
97* Wed Feb 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.6-3
98- rebuild for python-2.6
99
100* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.6-2vl5
101- rebuilt with python-2.5.2
102
103* Sat Jun 14 2008 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.6-1vl5
104- applied new versioning policy and spec in utf-8
105- added BuildRequires: xorg-x11-devel
106- fixed typo at Distribution
107
108* Sat Dec 01 2007 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.6-0vl4
109- fixed prereq, buildrequires pkgs
110
111* Wed Mar 21 2007 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.6-0vl2
112- updated Imaging to 1.1.6
113- added BuildRequires: XOrg-devel zlib-devel libjpeg-devel libpng-devel freetype2-devel
114
115* Sat Oct 14 2006 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.5-0vl5
116- added Imaging-1.1.5-setup.lib64.patch
117- rebuilt for x86_64 architecture support
118
119* Wed May 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> python-imaging-1.1.5-0vl4
120- changed Group:
121
122* Fri Oct 07 2005 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.5-0vl3
123- rebuilt
124
125* Sun May 22 2005 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.5-0vl2
126- changed package name 'python-Imaging' to 'python-imaging'
127
128* Fri May 20 2005 Shu KONNO <owa@bg.wakwak.com> python-Imaging-1.1.5-0vl1
129- changed package name 'Imaging' to 'python-Imaging'
130- updated Python Imaging Library (PIL) to 1.1.5
131- rebuilt with python-2.4
132
133* Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 1.1.3-0vl1
134- updated 1.1.3
135
136* Thu Jul 26 2001 Satoshi MACHINO <machino@vinelinux.org> 1.1.2-0vl1
137- updated 1.1.2
138
139* Thu Aug 03 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
140- Imaging-1.1-0vl1
141- build on VineSeed
142
143* Sun Mar  7 1999 MATSUMOTO Shoji <vine@flatout.org>
144- make spec
Note: See TracBrowser for help on using the repository browser.