source: projects/specs/trunk/p/python-imaging/python-imaging-vl.spec @ 8158

Revision 8158, 4.6 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1Summary: The Python Imaging Library
2Summary(ja): Python イメージ処理ライブラリ
3Name: python-imaging
4Version: 1.1.7
5Release: 4%{?_dist_release}
6License: Distributable
7Group: Development/Languages
8URL: http://www.pythonware.com/products/pil
9
10Source0: http://effbot.org/downloads/Imaging-%{version}.tar.gz
11
12Patch0: Imaging-1.1.7-setup.lib64.patch
13Patch1: Imaging-1.1.7-freetype-2.5.x.patch
14
15BuildRequires: python-devel >= 2.6
16BuildRequires: libjpeg-devel libpng-devel zlib-devel freetype2-devel
17BuildRequires: xorg-x11-devel
18BuildRequires: sane-devel
19Requires: python >= 2.6
20Requires: libjpeg >= 6a
21Requires: libpng >= 1.0.12
22Requires: zlib >= 1.1.4
23Requires: freetype2 >= 2.1.3
24Provides: Imaging, python-PIL
25Obsoletes: Imaging < %{version}
26Obsoletes: python-PIL < %{version}
27Obsoletes: python-Imaging <= %{version}
28BuildRoot: %{_tmppath}/%{name}-%{version}-root
29
30Distribution: Vine Linux
31Vendor: Project Vine
32Packager: owa
33
34%description
35The Python Imaging Library (PIL) adds image processing capabilities
36to your Python environment.  This library provides extensive file
37format support, an efficient internal representation, and fairly
38powerful image processing capabilities.
39%description -l ja
40Python Imaging Library (PIL) は Python 環境にイメージ処理能力を加えます.
41このライブラリには広範なファイル型式への対応, 効果的な内部表現, そして
42真にパワフルなイメージ処理能力が備わっています.
43
44
45%prep
46%setup -q -n Imaging-%{version}
47%ifarch x86_64
48%patch0 -p1 -b .lib64~
49%endif
50%patch1 -p1 -b .ft
51
52
53%build
54python setup.py build_ext -i
55python selftest.py
56
57
58%install
59rm -rf $RPM_BUILD_ROOT
60python setup.py install --root=$RPM_BUILD_ROOT
61
62mkdir -p $RPM_BUILD_ROOT%{_includedir}/python%{pyver}/PIL
63cp -p libImaging/*.h $RPM_BUILD_ROOT%{_includedir}/python%{pyver}/PIL/
64
65mkdir -p $RPM_BUILD_ROOT%{python_sitearch}/Sane
66pushd Sane
67python setup.py install --root=$RPM_BUILD_ROOT --install-lib=%{python_sitearch}/Sane
68install -m644 demo_numarray.py $RPM_BUILD_ROOT%{python_sitearch}/Sane
69install -m644 CHANGES README sanedoc.txt $RPM_BUILD_ROOT%{python_sitearch}/Sane
70popd
71
72
73%clean
74rm -rf $RPM_BUILD_ROOT
75
76%files
77%defattr(-, root, root)
78%doc BUILDME CHANGES CONTENTS README
79%doc Docs
80%dir %{python_sitearch}/PIL
81%dir %{python_sitearch}/Sane
82%{_bindir}/pil*.py
83%{_includedir}/python%{pyver}/PIL/*.h
84%{python_sitearch}/PIL.pth
85%{python_sitearch}/PIL/*
86%{python_sitearch}/Sane/*
87
88
89%changelog
90* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.7-4
91- rebuild with VineSeed environment
92- add Patch0 (Imaging-1.1.7-freetype-2.5.x.patch)
93
94* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.7-3
95- rebuild with python-2.7.2
96
97* Sat May 07 2011 Shu KONNO <owa@bg.wakwak.com> 1.1.7-2
98- install PIL with setup.py
99- install Sane with setup.py
100- install %{_bindir}/pil*.py
101- added BR: sane-devel
102
103* Thu Feb 03 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.7-1
104- new upstream release
105- recreated Patch0
106
107* Wed Feb 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.6-3
108- rebuild for python-2.6
109
110* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.6-2vl5
111- rebuilt with python-2.5.2
112
113* Sat Jun 14 2008 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.6-1vl5
114- applied new versioning policy and spec in utf-8
115- added BuildRequires: xorg-x11-devel
116- fixed typo at Distribution
117
118* Sat Dec 01 2007 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.6-0vl4
119- fixed prereq, buildrequires pkgs
120
121* Wed Mar 21 2007 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.6-0vl2
122- updated Imaging to 1.1.6
123- added BuildRequires: XOrg-devel zlib-devel libjpeg-devel libpng-devel freetype2-devel
124
125* Sat Oct 14 2006 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.5-0vl5
126- added Imaging-1.1.5-setup.lib64.patch
127- rebuilt for x86_64 architecture support
128
129* Wed May 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> python-imaging-1.1.5-0vl4
130- changed Group:
131
132* Fri Oct 07 2005 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.5-0vl3
133- rebuilt
134
135* Sun May 22 2005 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.5-0vl2
136- changed package name 'python-Imaging' to 'python-imaging'
137
138* Fri May 20 2005 Shu KONNO <owa@bg.wakwak.com> python-Imaging-1.1.5-0vl1
139- changed package name 'Imaging' to 'python-Imaging'
140- updated Python Imaging Library (PIL) to 1.1.5
141- rebuilt with python-2.4
142
143* Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 1.1.3-0vl1
144- updated 1.1.3
145
146* Thu Jul 26 2001 Satoshi MACHINO <machino@vinelinux.org> 1.1.2-0vl1
147- updated 1.1.2
148
149* Thu Aug 03 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
150- Imaging-1.1-0vl1
151- build on VineSeed
152
153* Sun Mar  7 1999 MATSUMOTO Shoji <vine@flatout.org>
154- make spec
Note: See TracBrowser for help on using the repository browser.