source: projects/specs/trunk/p/python-imaging/python-imaging-vl.spec @ 2627

Revision 2627, 3.9 KB checked in by kudoh, 13 years ago (diff)
Line 
1%define pyver %(python -c 'import sys;print(sys.version[0:3])')
2%define pysite %{_libdir}/python%{pyver}/site-packages
3%define pyinc %{_includedir}/python%{pyver}
4Summary: The Python Imaging Library
5Summary(ja): Python イメージ処理ライブラリ
6Name: python-imaging
7Version: 1.1.7
8Release: 1%{?_dist_release}
9License: Distributable
10Distribution: Vine Linux
11Vendor: Project Vine
12Group: Development/Languages
13URL: http://www.pythonware.com/products/pil
14Source0: http://effbot.org/downloads/Imaging-%{version}.tar.gz
15Patch0: Imaging-1.1.7-setup.lib64.patch
16BuildRequires: python-devel >= 2.6
17BuildRequires: libjpeg-devel libpng-devel zlib-devel freetype2-devel
18BuildRequires: xorg-x11-devel
19Requires: python >= 2.6
20Requires: libjpeg >= 6a
21Requires: libpng >= 1.0.12
22Requires: zlib >= 1.1.4
23Requires: freetype2 >= 2.1.3
24Provides: Imaging, python-PIL
25Obsoletes: Imaging < %{version}
26Obsoletes: python-PIL < %{version}
27Obsoletes: python-Imaging <= %{version}
28BuildRoot: %{_tmppath}/%{name}-%{version}-root
29
30%description
31The Python Imaging Library (PIL) adds image processing capabilities
32to your Python environment.  This library provides extensive file
33format support, an efficient internal representation, and fairly
34powerful image processing capabilities.
35%description -l ja
36Python Imaging Library (PIL) は Python 環境にイメージ処理能力を加えます.
37このライブラリには広範なファイル型式への対応, 効果的な内部表現, そして
38真にパワフルなイメージ処理能力が備わっています.
39
40%prep
41%setup -q -n Imaging-%{version}
42%ifarch x86_64
43%patch0 -p1 -b .lib64~
44%endif
45
46%build
47python setup.py build_ext -i
48python selftest.py
49
50%install
51rm -rf $RPM_BUILD_ROOT
52#python setup.py install --root=$RPM_BUILD_ROOT
53
54mkdir -p $RPM_BUILD_ROOT%{pysite}/PIL
55mkdir -p $RPM_BUILD_ROOT%{pysite}/Sane
56cp PIL.pth $RPM_BUILD_ROOT%{pysite}/
57cp PIL/* $RPM_BUILD_ROOT%{pysite}/PIL/
58cp Sane/*[^\.c$] $RPM_BUILD_ROOT%{pysite}/Sane/
59
60mkdir -p $RPM_BUILD_ROOT%{pyinc}/PIL
61cp -p libImaging/*.h $RPM_BUILD_ROOT%{pyinc}/PIL/
62
63%clean
64rm -rf $RPM_BUILD_ROOT
65
66%files
67%defattr(-, root, root)
68%doc BUILDME CHANGES CONTENTS README
69%doc Docs
70%{pysite}/*
71%{pyinc}/*
72
73%changelog
74* Thu Feb 03 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.7-1
75- new upstream release
76- recreated Patch0
77
78* Wed Feb 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.6-3
79- rebuild for python-2.6
80
81* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.6-2vl5
82- rebuilt with python-2.5.2
83
84* Sat Jun 14 2008 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.6-1vl5
85- applied new versioning policy and spec in utf-8
86- added BuildRequires: xorg-x11-devel
87- fixed typo at Distribution
88
89* Sat Dec 01 2007 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.6-0vl4
90- fixed prereq, buildrequires pkgs
91
92* Wed Mar 21 2007 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.6-0vl2
93- updated Imaging to 1.1.6
94- added BuildRequires: XOrg-devel zlib-devel libjpeg-devel libpng-devel freetype2-devel
95
96* Sat Oct 14 2006 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.5-0vl5
97- added Imaging-1.1.5-setup.lib64.patch
98- rebuilt for x86_64 architecture support
99
100* Wed May 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> python-imaging-1.1.5-0vl4
101- changed Group:
102
103* Fri Oct 07 2005 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.5-0vl3
104- rebuilt
105
106* Sun May 22 2005 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.5-0vl2
107- changed package name 'python-Imaging' to 'python-imaging'
108
109* Fri May 20 2005 Shu KONNO <owa@bg.wakwak.com> python-Imaging-1.1.5-0vl1
110- changed package name 'Imaging' to 'python-Imaging'
111- updated Python Imaging Library (PIL) to 1.1.5
112- rebuilt with python-2.4
113
114* Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 1.1.3-0vl1
115- updated 1.1.3
116
117* Thu Jul 26 2001 Satoshi MACHINO <machino@vinelinux.org> 1.1.2-0vl1
118- updated 1.1.2
119
120* Thu Aug 03 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
121- Imaging-1.1-0vl1
122- build on VineSeed
123
124* Sun Mar  7 1999 MATSUMOTO Shoji <vine@flatout.org>
125- make spec
Note: See TracBrowser for help on using the repository browser.