source: projects/specs/trunk/p/python-imagesize/python-imagesize-vl.spec @ 12469

Revision 12469, 3.1 KB checked in by tomop, 4 years ago (diff)

python-3.8.5 and related packages.

Line 
1%global pypi_name imagesize
2%global sum  Python module for analyzing image file headers and returning image sizes
3
4Summary:        %{sum}
5Name:           python-%{pypi_name}
6Version:        1.2.0
7Release:        1%{?_dist_release}
8Group:          programming
9Vendor:         Project Vine
10Distribution:   Vine Linux
11
12License:        MIT
13URL:            https://github.com/shibukawa/imagesize_py
14Source0:        https://files.pythonhosted.org/packages/source/i/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
15
16BuildArch:      noarch
17
18BuildRequires:  python-rpm-macros
19
20BuildRequires:  python-setuptools
21BuildRequires:  python-devel
22BuildRequires:  python2-rpm-macros
23
24BuildRequires:  python3-setuptools
25BuildRequires:  python3-devel
26BuildRequires:  python3-rpm-macros
27
28%{?python_provide:%python_provide python2-%{pypi_name}}
29
30%description
31The imagesize package parses image file headers and returns the image sizes.
32
33* PNG
34* JPEG
35* JPEG2000
36* GIF
37
38This is a pure Python library.
39
40
41%package -n     python3-%{pypi_name}
42Summary:        %{sum}
43Group:          programming
44%{?python_provide:%python_provide python3-%{pypi_name}}
45
46%description -n python3-%{pypi_name}
47The imagesize package parses image file headers and returns the image sizes.
48
49* PNG
50* JPEG
51* JPEG2000
52* GIF
53
54This is a pure Python library.
55
56
57%prep
58%autosetup -n %{pypi_name}-%{version}
59# Remove bundled egg-info
60rm -rf %{pypi_name}.egg-info
61
62
63%build
64%py2_build
65%py3_build
66
67
68%install
69%py3_install
70%py2_install
71
72
73%check
74#py.test-2
75#py.test-3
76
77
78%files
79%doc README.rst
80%license LICENSE.rst
81%{python2_sitelib}/*
82
83%files -n python3-%{pypi_name}
84%doc README.rst
85%license LICENSE.rst
86%{python3_sitelib}/*
87
88
89%changelog
90* Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.2.0-1
91- new upstream release.
92
93* Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.1.0-1
94- initial build for Vine Linux.
95- new upstream release.
96
97* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.0-3
98- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
99
100* Thu Jun 14 2018 Miro Hrončok <mhroncok@redhat.com> - 1.0.0-2
101- Rebuilt for Python 3.7
102
103* Mon Apr 16 2018 Avram Lubkin <aviso@rockhopper.net> - 1.0.0-1
104- Updated to 1.0.0 (bz#1545961)
105
106* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.1-7
107- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
108
109* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.1-6
110- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
111
112* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.1-5
113- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
114
115* Tue Dec 13 2016 Stratakis Charalampos <cstratak@redhat.com> - 0.7.1-4
116- Enable tests
117
118* Fri Dec 09 2016 Charalampos Stratakis <cstratak@redhat.com> - 0.7.1-3
119- Rebuild for Python 3.6
120- Disable python3 tests
121
122* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.1-2
123- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
124
125* Thu May 26 2016 Avram Lubkin <aviso@rockhopper.net> - 0.7.1-1
126- Initial package.
Note: See TracBrowser for help on using the repository browser.