source: projects/specs/trunk/p/python-dns/python-dns-vl.spec @ 5997

Revision 5997, 9.1 KB checked in by daisuke, 12 years ago (diff)

python-dns: new package

Line 
1Name:           python-dns
2Version:        1.9.4
3Release:        1%{?_dist_release}
4Summary:        DNS toolkit for Python
5Summary(ja):    Python 用 DNS ツールキット
6
7Group:          Development/Languages
8License:        MIT
9URL:            http://www.dnspython.org/
10Source0:        http://www.dnspython.org/kits/%{version}/dnspython-%{version}.tar.gz
11Source1:        http://www.dnspython.org/kits/%{version}/dnspython-%{version}.tar.gz.asc
12BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
13
14BuildArch:      noarch
15BuildRequires: python-setuptools
16
17%description
18dnspython is a DNS toolkit for Python. It supports almost all record
19types. It can be used for queries, zone transfers, and dynamic
20updates. It supports TSIG authenticated messages and EDNS0.
21
22dnspython provides both high and low level access to DNS. The high
23level classes perform queries for data of a given name, type, and
24class, and return an answer set. The low level classes allow direct
25manipulation of DNS zones, messages, names, and records.
26
27%prep
28%setup0 -q -n dnspython-%{version}
29
30# strip executable permissions so that we don't pick up dependencies
31# from documentation
32find examples -type f | xargs chmod a-x
33
34%build
35CFLAGS="%{optflags}" %{__python} -c 'import setuptools; execfile("setup.py")' build
36
37%install
38rm -rf %{buildroot}
39%{__python} -c 'import setuptools; execfile("setup.py")' install --skip-build --root %{buildroot}
40
41%check
42pushd tests
43# skip one test because it queries the network
44for py in *.py
45do
46        if [ $py != resolver.py ]
47        then
48                PYTHONPATH=%{buildroot}%{python_sitelib} %{__python} $py
49        fi
50done
51
52%clean
53rm -rf %{buildroot}
54
55%files
56%defattr(-,root,root,-)
57%doc ChangeLog LICENSE README TODO examples
58
59%{python_sitelib}/*egg-info
60%{python_sitelib}/dns
61
62%changelog
63* Thu Apr 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.4-1
64- initial build for Vine Linux
65
66* Mon Mar 28 2011 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.4-1
67-
68- dnspython 1.9.4 has been released and is available at
69- http://www.dnspython.org/kits/1.9.4/
70-
71- There is no new functionality in this release; just a few bug fixes
72- in RRSIG and SIG code.
73-
74- I will be eliminating legacy code for earlier versions of DNSSEC in a
75- future release of dnspython.
76
77* Fri Mar 25 2011 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.3-1
78-
79- New since 1.9.2:
80-
81-     A boolean parameter, 'raise_on_no_answer', has been added to
82- the query() methods.  In no-error, no-data situations, this
83- parameter determines whether NoAnswer should be raised or not.
84- If True, NoAnswer is raised.  If False, then an Answer()
85- object with a None rrset will be returned.
86-
87- Resolver Answer() objects now have a canonical_name field.
88-
89- Rdata now have a __hash__ method.
90-
91- Bugs fixed since 1.9.2:
92-
93-        Dnspython was erroneously doing case-insensitive comparisons
94- of the names in NSEC and RRSIG RRs.
95-
96- We now use "is" and not "==" when testing what section an RR
97- is in.
98-
99- The resolver now disallows metaqueries.
100
101* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9.2-2
102- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
103
104* Tue Nov 23 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.2-1
105- It's brown paper bag time :) The fix for the import problems was
106- actually bad, but didn't show up in testing because the test suite's
107- conditional importing code hid the problem.
108-
109- Any, 1.9.2 is out.
110-
111- Sorry for the churn!
112
113* Mon Nov 22 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.1-1
114- New since 1.9.0:
115-
116-        Nothing.
117-
118- Bugs fixed since 1.9.0
119-
120-        The dns.dnssec module didn't work with DSA due to namespace
121-        contamination from a "from"-style import.
122-
123- New since 1.8.0:
124-
125-        dnspython now uses poll() instead of select() when available.
126-
127-        Basic DNSSEC validation can be done using dns.dnsec.validate()
128-        and dns.dnssec.validate_rrsig() if you have PyCrypto 2.3 or
129-        later installed.  Complete secure resolution is not yet
130-        available.
131-
132-        Added key_id() to the DNSSEC module, which computes the DNSSEC
133-        key id of a DNSKEY rdata.
134-
135-        Added make_ds() to the DNSSEC module, which returns the DS RR
136-        for a given DNSKEY rdata.
137-
138-        dnspython now raises an exception if HMAC-SHA284 or
139-        HMAC-SHA512 are used with a Python older than 2.5.2.  (Older
140-        Pythons do not compute the correct value.)
141-
142-        Symbolic constants are now available for TSIG algorithm names.
143-
144- Bugs fixed since 1.8.0
145-
146-        dns.resolver.zone_for_name() didn't handle a query response
147-        with a CNAME or DNAME correctly in some cases.
148-
149-        When specifying rdata types and classes as text, Unicode
150-        strings may now be used.
151-
152-        Hashlib compatibility issues have been fixed.
153-
154-        dns.message now imports dns.edns.
155-
156-        The TSIG algorithm value was passed incorrectly to use_tsig()
157-        in some cases.
158
159* Fri Aug 13 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.8.0-3
160- Add a patch from upstream to fix a Python 2.7 issue.
161
162* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1.8.0-2.1
163- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
164
165* Wed Jan 27 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.8.0-1.1
166- Fix error
167
168* Wed Jan 27 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.8.0-1
169- New since 1.7.1:
170-
171-  Support for hmac-sha1, hmac-sha224, hmac-sha256, hmac-sha384 and
172-  hmac-sha512 has been contributed by Kevin Chen.
173-
174-  The tokenizer's tokens are now Token objects instead of (type,
175-  value) tuples.
176-
177- Bugs fixed since 1.7.1:
178-
179-  Escapes in masterfiles now work correctly.  Previously they were
180-  only working correctly when the text involved was part of a domain
181-  name.
182-
183-  When constructing a DDNS update, if the present() method was used
184-  with a single rdata, a zero TTL was not added.
185-
186-  The entropy pool needed locking to be thread safe.
187-
188-  The entropy pool's reading of /dev/random could cause dnspython to
189-  block.
190-
191-  The entropy pool did buffered reads, potentially consuming more
192-  randomness than we needed.
193-
194-  The entropy pool did not seed with high quality randomness on
195-  Windows.
196-
197-  SRV records were compared incorrectly.
198-
199-  In the e164 query function, the resolver parameter was not used.
200
201* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.1-2
202- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
203
204* Fri Jun 19 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.1-1
205- New since 1.7.0:
206-
207-        Nothing
208-
209- Bugs fixed since 1.7.0:
210-
211-        The 1.7.0 kitting process inadventently omitted the code for the
212-        DLV RR.
213-
214-        Negative DDNS prerequisites are now handled correctly.
215
216* Fri Jun 19 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.0-1
217- New since 1.6.0:
218-
219-        Rdatas now have a to_digestable() method, which returns the
220-        DNSSEC canonical form of the rdata, suitable for use in
221-        signature computations.
222-
223-        The NSEC3, NSEC3PARAM, DLV, and HIP RR types are now supported.
224-
225-        An entropy module has been added and is used to randomize query ids.
226-
227-        EDNS0 options are now supported.
228-
229-        UDP IXFR is now supported.
230-
231-        The wire format parser now has a 'one_rr_per_rrset' mode, which
232-        suppresses the usual coalescing of all RRs of a given type into a
233-        single RRset.
234-
235-        Various helpful DNSSEC-related constants are now defined.
236-
237-        The resolver's query() method now has an optional 'source' parameter,
238-        allowing the source IP address to be specified.
239-
240- Bugs fixed since 1.6.0:
241-
242-        On Windows, the resolver set the domain incorrectly.
243-
244-        DS RR parsing only allowed one Base64 chunk.
245-
246-        TSIG validation didn't always use absolute names.
247-
248-        NSEC.to_text() only printed the last window.
249-
250-        We did not canonicalize IPv6 addresses before comparing them; we
251-        would thus treat equivalent but different textual forms, e.g.
252-        "1:00::1" and "1::1" as being non-equivalent.
253-
254-        If the peer set a TSIG error, we didn't raise an exception.
255-
256-        Some EDNS bugs in the message code have been fixed (see the ChangeLog
257-        for details).
258
259* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-4
260- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
261
262* Sat Nov 29 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.6.0-3
263- Rebuild for Python 2.6
264
265* Fri Aug 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.6.0-2
266- fix license tag
267
268* Sat Dec  4 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.6.0-1
269- Update to 1.6.0
270
271* Tue Oct  9 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.5.0-2
272- Follow new Python egg packaging specs
273
274* Thu Jan 11 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.5.0-1
275- Update to 1.5.0
276
277* Fri Dec  8 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.4.0-3
278- Bump release for rebuild with Python 2.5
279
280* Mon Aug 14 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.4.0-2
281- No longer ghost *.pyo files, thus further simplifying the files section.
282
283* Sat Aug  5 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.4.0-1
284- Update to 1.4.0
285- Remove unneeded python-abi requires
286- Remove unneeded python_sitearch macro
287
288* Fri May 26 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.3.5-1
289- First version for Fedora Extras
290
Note: See TracBrowser for help on using the repository browser.