source: projects/specs/trunk/p/python-dns/python-dns-vl.spec @ 12103

Revision 12103, 10.3 KB checked in by tomop, 5 years ago (diff)

python-dns-1.16.0-1

Line 
1Name:           python-dns
2Version:        1.16.0
3Release:        1%{?_dist_release}
4Summary:        DNS toolkit for Python
5Summary(ja):    Python 用 DNS ツールキット
6
7Group:          Development/Languages
8License:        MIT
9URL:            http://www.dnspython.org/
10Source0:        http://www.dnspython.org/kits/%{version}/dnspython-%{version}.tar.gz
11Source1:        http://www.dnspython.org/kits/%{version}/dnspython-%{version}.tar.gz.asc
12BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
13
14BuildArch:      noarch
15BuildRequires: python-setuptools
16BuildRequires: python-devel
17BuildRequires: python-rpm-macros
18BuildRequires: python3-setuptools
19BuildRequires: python3-devel
20BuildRequires: python3-rpm-macros
21
22BuildRequires:  python-crypto
23
24Vendor: Project Vine
25Distribution: Vine Linux
26
27%description
28dnspython is a DNS toolkit for Python. It supports almost all record
29types. It can be used for queries, zone transfers, and dynamic
30updates. It supports TSIG authenticated messages and EDNS0.
31
32dnspython provides both high and low level access to DNS. The high
33level classes perform queries for data of a given name, type, and
34class, and return an answer set. The low level classes allow direct
35manipulation of DNS zones, messages, names, and records.
36
37%package -n python3-dns
38Summary:        DNS toolkit for Python 3
39%{?python_provide:%python_provide python3-dns}
40Requires:       python3-crypto
41
42%description -n python3-dns
43dnspython3 is a DNS toolkit for Python 3. It supports almost all
44record types. It can be used for queries, zone transfers, and dynamic
45updates. It supports TSIG authenticated messages and EDNS0.
46
47dnspython3 provides both high and low level access to DNS. The high
48level classes perform queries for data of a given name, type, and
49class, and return an answer set. The low level classes allow direct
50manipulation of DNS zones, messages, names, and records.
51
52%prep
53%setup0 -q -n dnspython-%{version}
54
55# strip executable permissions so that we don't pick up dependencies
56# from documentation
57find examples -type f | xargs chmod a-x
58
59%build
60%py_build
61%py3_build
62
63%install
64rm -rf %{buildroot}
65%py_install
66%py3_install
67
68#%check
69#%{__python} setup.py test
70#%{__python3} setup.py test
71
72%clean
73rm -rf %{buildroot}
74
75%files
76%defattr(-,root,root,-)
77%license LICENSE
78%doc README* examples
79%{python_sitelib}/*egg-info
80%{python_sitelib}/dns
81
82%files -n python3-dns
83%defattr(-,root,root,-)
84%license LICENSE
85%doc README* examples
86%{python3_sitelib}/*egg-info
87%{python3_sitelib}/dns
88
89%changelog
90* Tue May 14 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16.0-1
91- new upstream release.
92- added python3 support.
93
94* Sun Jan 12 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-3
95- rebuild with VineSeed environment
96
97* Mon Apr 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-2
98- add BR: python-devel, python
99
100* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
101- new upstream release
102
103* Thu Apr 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.4-1
104- initial build for Vine Linux
105
106* Mon Mar 28 2011 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.4-1
107-
108- dnspython 1.9.4 has been released and is available at
109- http://www.dnspython.org/kits/1.9.4/
110-
111- There is no new functionality in this release; just a few bug fixes
112- in RRSIG and SIG code.
113-
114- I will be eliminating legacy code for earlier versions of DNSSEC in a
115- future release of dnspython.
116
117* Fri Mar 25 2011 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.3-1
118-
119- New since 1.9.2:
120-
121-     A boolean parameter, 'raise_on_no_answer', has been added to
122- the query() methods.  In no-error, no-data situations, this
123- parameter determines whether NoAnswer should be raised or not.
124- If True, NoAnswer is raised.  If False, then an Answer()
125- object with a None rrset will be returned.
126-
127- Resolver Answer() objects now have a canonical_name field.
128-
129- Rdata now have a __hash__ method.
130-
131- Bugs fixed since 1.9.2:
132-
133-        Dnspython was erroneously doing case-insensitive comparisons
134- of the names in NSEC and RRSIG RRs.
135-
136- We now use "is" and not "==" when testing what section an RR
137- is in.
138-
139- The resolver now disallows metaqueries.
140
141* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9.2-2
142- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
143
144* Tue Nov 23 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.2-1
145- It's brown paper bag time :) The fix for the import problems was
146- actually bad, but didn't show up in testing because the test suite's
147- conditional importing code hid the problem.
148-
149- Any, 1.9.2 is out.
150-
151- Sorry for the churn!
152
153* Mon Nov 22 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.1-1
154- New since 1.9.0:
155-
156-        Nothing.
157-
158- Bugs fixed since 1.9.0
159-
160-        The dns.dnssec module didn't work with DSA due to namespace
161-        contamination from a "from"-style import.
162-
163- New since 1.8.0:
164-
165-        dnspython now uses poll() instead of select() when available.
166-
167-        Basic DNSSEC validation can be done using dns.dnsec.validate()
168-        and dns.dnssec.validate_rrsig() if you have PyCrypto 2.3 or
169-        later installed.  Complete secure resolution is not yet
170-        available.
171-
172-        Added key_id() to the DNSSEC module, which computes the DNSSEC
173-        key id of a DNSKEY rdata.
174-
175-        Added make_ds() to the DNSSEC module, which returns the DS RR
176-        for a given DNSKEY rdata.
177-
178-        dnspython now raises an exception if HMAC-SHA284 or
179-        HMAC-SHA512 are used with a Python older than 2.5.2.  (Older
180-        Pythons do not compute the correct value.)
181-
182-        Symbolic constants are now available for TSIG algorithm names.
183-
184- Bugs fixed since 1.8.0
185-
186-        dns.resolver.zone_for_name() didn't handle a query response
187-        with a CNAME or DNAME correctly in some cases.
188-
189-        When specifying rdata types and classes as text, Unicode
190-        strings may now be used.
191-
192-        Hashlib compatibility issues have been fixed.
193-
194-        dns.message now imports dns.edns.
195-
196-        The TSIG algorithm value was passed incorrectly to use_tsig()
197-        in some cases.
198
199* Fri Aug 13 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.8.0-3
200- Add a patch from upstream to fix a Python 2.7 issue.
201
202* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1.8.0-2.1
203- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
204
205* Wed Jan 27 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.8.0-1.1
206- Fix error
207
208* Wed Jan 27 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.8.0-1
209- New since 1.7.1:
210-
211-  Support for hmac-sha1, hmac-sha224, hmac-sha256, hmac-sha384 and
212-  hmac-sha512 has been contributed by Kevin Chen.
213-
214-  The tokenizer's tokens are now Token objects instead of (type,
215-  value) tuples.
216-
217- Bugs fixed since 1.7.1:
218-
219-  Escapes in masterfiles now work correctly.  Previously they were
220-  only working correctly when the text involved was part of a domain
221-  name.
222-
223-  When constructing a DDNS update, if the present() method was used
224-  with a single rdata, a zero TTL was not added.
225-
226-  The entropy pool needed locking to be thread safe.
227-
228-  The entropy pool's reading of /dev/random could cause dnspython to
229-  block.
230-
231-  The entropy pool did buffered reads, potentially consuming more
232-  randomness than we needed.
233-
234-  The entropy pool did not seed with high quality randomness on
235-  Windows.
236-
237-  SRV records were compared incorrectly.
238-
239-  In the e164 query function, the resolver parameter was not used.
240
241* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.1-2
242- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
243
244* Fri Jun 19 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.1-1
245- New since 1.7.0:
246-
247-        Nothing
248-
249- Bugs fixed since 1.7.0:
250-
251-        The 1.7.0 kitting process inadventently omitted the code for the
252-        DLV RR.
253-
254-        Negative DDNS prerequisites are now handled correctly.
255
256* Fri Jun 19 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.0-1
257- New since 1.6.0:
258-
259-        Rdatas now have a to_digestable() method, which returns the
260-        DNSSEC canonical form of the rdata, suitable for use in
261-        signature computations.
262-
263-        The NSEC3, NSEC3PARAM, DLV, and HIP RR types are now supported.
264-
265-        An entropy module has been added and is used to randomize query ids.
266-
267-        EDNS0 options are now supported.
268-
269-        UDP IXFR is now supported.
270-
271-        The wire format parser now has a 'one_rr_per_rrset' mode, which
272-        suppresses the usual coalescing of all RRs of a given type into a
273-        single RRset.
274-
275-        Various helpful DNSSEC-related constants are now defined.
276-
277-        The resolver's query() method now has an optional 'source' parameter,
278-        allowing the source IP address to be specified.
279-
280- Bugs fixed since 1.6.0:
281-
282-        On Windows, the resolver set the domain incorrectly.
283-
284-        DS RR parsing only allowed one Base64 chunk.
285-
286-        TSIG validation didn't always use absolute names.
287-
288-        NSEC.to_text() only printed the last window.
289-
290-        We did not canonicalize IPv6 addresses before comparing them; we
291-        would thus treat equivalent but different textual forms, e.g.
292-        "1:00::1" and "1::1" as being non-equivalent.
293-
294-        If the peer set a TSIG error, we didn't raise an exception.
295-
296-        Some EDNS bugs in the message code have been fixed (see the ChangeLog
297-        for details).
298
299* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-4
300- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
301
302* Sat Nov 29 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.6.0-3
303- Rebuild for Python 2.6
304
305* Fri Aug 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.6.0-2
306- fix license tag
307
308* Tue Dec  4 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.6.0-1
309- Update to 1.6.0
310
311* Tue Oct  9 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.5.0-2
312- Follow new Python egg packaging specs
313
314* Thu Jan 11 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.5.0-1
315- Update to 1.5.0
316
317* Fri Dec  8 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.4.0-3
318- Bump release for rebuild with Python 2.5
319
320* Mon Aug 14 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.4.0-2
321- No longer ghost *.pyo files, thus further simplifying the files section.
322
323* Sat Aug  5 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.4.0-1
324- Update to 1.4.0
325- Remove unneeded python-abi requires
326- Remove unneeded python_sitearch macro
327
328* Fri May 26 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.3.5-1
329- First version for Fedora Extras
330
Note: See TracBrowser for help on using the repository browser.