source: projects/specs/trunk/p/python-django/python-django-vl.spec @ 5701

Revision 5701, 5.1 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1Summary: A high-level Python Web framework
2Summary(ja): Python の高度なウェブフレームワーク
3Name: python-django
4Version: 1.3
5Release: 2%{?_dist_release}
6Group: Development/Languages
7BuildArch: noarch
8License: BSD
9URL: http://www.djangoproject.com/
10Source0: Django-%{version}.tar.gz
11Source1: simplejson-init.py
12Patch0: Django-hash-compat-13310.patch
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: python-devel
15BuildRequires: python-sphinx
16Requires: python-simplejson
17Vendor: Project Vine
18Distribution: Vine Linux
19Packager: owa, munepi
20
21%description
22Django is a high-level Python Web framework that encourages rapid
23development and a clean, pragmatic design. It focuses on automating as
24much as possible and adhering to the DRY (Don't Repeat Yourself)
25principle.
26
27%description -l ja
28Django はハイレベルな Python Web フレームワークであり、素早い開発と
29クリーンで実用的な設計を勧めています。Django は可能な限りの自動化と
30無駄な繰返しを徹底的に排除することに注目しています。
31
32
33%package docs
34Summary:  Documentation for Django
35Group:    Documentation
36Requires: %{name} = %{version}-%{release}
37
38%description docs
39This package contains the documentation for the Django high-level
40Python Web framework.
41
42
43%prep
44%setup -q -n Django-%{version}
45#%patch0 -p3
46
47# remove bundled simplejson
48cd django/utils/simplejson/
49%__rm -rf *
50# and put the replacement stub in place
51%__cp -p %{SOURCE1} __init__.py
52
53
54%build
55%{__python} setup.py build
56
57
58%install
59%__rm -rf $RPM_BUILD_ROOT
60%{__python} setup.py install --skip-build --root $RPM_BUILD_ROOT
61
62# Permission fixes
63pushd $RPM_BUILD_ROOT%{python_sitelib}/django
64        chmod +x conf/project_template/manage.py*
65        chmod +x contrib/admin/media/js/compress.py*
66        chmod +x bin/profiling/gather_profile_stats.py*
67        #chmod +x bin/compile-messages.py*
68        chmod +x bin/daily_cleanup.py*
69        chmod +x bin/django-admin.py*
70        #chmod +x bin/make-messages.py*
71        chmod +x bin/unique-messages.py*
72popd
73
74# Fix items in %{_bindir}
75%__mv $RPM_BUILD_ROOT%{_bindir}/django-admin.py $RPM_BUILD_ROOT%{_bindir}/django-admin
76
77# install man pages
78%__mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1/
79%__cp -p docs/man/* $RPM_BUILD_ROOT%{_mandir}/man1/
80
81# Handling locale files
82# This is adapted from the %%find_lang macro, which cannot be directly
83# used since Django locale files are not located in %%{_datadir}
84#
85# The rest of the packaging guideline still apply -- do not list
86# locale files by hand!
87%__rm -f %{name}.lang
88(cd $RPM_BUILD_ROOT && find . -name 'django*.mo') | %{__sed} -e 's|^.||' | %{__sed} -e \
89  's:\(.*/locale/\)\([^/_]\+\)\(.*\.mo$\):%lang(\2) \1\2\3:' \
90  >> %{name}.lang
91find $RPM_BUILD_ROOT -name "*.po" | xargs %__rm -f
92
93
94%clean
95rm -rf $RPM_BUILD_ROOT
96
97
98%files -f %{name}.lang
99%defattr(-,root,root,-)
100%doc AUTHORS LICENSE README
101%{_bindir}/django-admin
102%{_mandir}/man1/*
103%{python_sitelib}/django/bin/*.py*
104%{python_sitelib}/django/bin/profiling/
105# Include everything but the locale data ...
106%{python_sitelib}/django/db/
107%{python_sitelib}/django/*.py*
108%{python_sitelib}/django/shortcuts/
109%{python_sitelib}/django/utils/
110%{python_sitelib}/django/dispatch/
111%{python_sitelib}/django/template/
112%{python_sitelib}/django/views/
113%{python_sitelib}/django/contrib/
114%{python_sitelib}/django/forms/
115%{python_sitelib}/django/templatetags/
116%{python_sitelib}/django/core/
117%{python_sitelib}/django/http/
118%{python_sitelib}/django/middleware/
119%{python_sitelib}/django/test/
120%{python_sitelib}/django/conf/*.py*
121%{python_sitelib}/django/conf/project_template/*.py*
122%{python_sitelib}/django/conf/app_template/
123%{python_sitelib}/django/conf/urls/
124%{python_sitelib}/django/conf/locale/*/*.py*
125%{python_sitelib}/django/conf/locale/*.py*
126%{python_sitelib}/Django-%{version}-py%{pyver}.egg-info
127
128
129%files docs
130%defattr(-,root,root,-)
131%doc docs/*
132
133
134%changelog
135* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3-2
136- rebuild with python-2.7.2
137
138* Mon May 02 2011 Shu KONNO <owa@bg.wakwak.com> 1.3-1
139- updated Django to 1.3
140
141* Wed Feb 16 2011 Shu KONNO <owa@bg.wakwak.com> 1.2.5-1
142- updated Django to 1.2.5 (include CVE-2011-0696, CVE-2011-0697)
143
144* Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.2.3-1
145- updated Django to 1.2.3
146- dropt Django-hash-compat-13310.patch
147
148* Thu Sep 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.2.1-2
149- added simplejson-init.py: removed bundled simplejson, and put the __init__.py
150- added Django-hash-compat-13310.patch: http://code.djangoproject.com/changeset/13310 per BZ#601212
151- added BR: python-devel python-sphinx
152- added RQ: python-simplejson
153- removed po files (per BZ#529188)
154- install man1
155  (merged from 'Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> - Django-1.2.1-1')
156
157* Sun Aug 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.2.1-1
158- updated Django to 1.2.1
159
160* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.1.1-2
161- rebuild with python-2.6
162
163* Sun Oct 18 2009 Shu KONNO <owa@bg.wakwak.com> 1.1.1-1
164- updated Django to 1.1.1
165
166* Fri Jul 31 2009 Shu KONNO <owa@bg.wakwak.com> 1.1-1
167- updated Django to 1.1
168- added japanese description
169
170* Fri Nov 28 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.2-1vl5
171- updated Django to 1.0.2-final
172
173* Wed Oct 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.0-1vl5
174- packaged new
175
Note: See TracBrowser for help on using the repository browser.