source: projects/specs/trunk/p/python-django/python-django-vl.spec @ 8158

Revision 8158, 5.2 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1Summary: A high-level Python Web framework
2Summary(ja): Python の高度なウェブフレームワーク
3Name: python-django
4Version: 1.3
5Release: 3%{?_dist_release}
6Group: Development/Languages
7BuildArch: noarch
8License: BSD
9URL: http://www.djangoproject.com/
10
11Source0: Django-%{version}.tar.gz
12Source1: simplejson-init.py
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: python-devel
16BuildRequires: python-sphinx
17Requires: python-simplejson
18
19Vendor: Project Vine
20Distribution: Vine Linux
21Packager: owa, munepi
22
23%description
24Django is a high-level Python Web framework that encourages rapid
25development and a clean, pragmatic design. It focuses on automating as
26much as possible and adhering to the DRY (Don't Repeat Yourself)
27principle.
28
29%description -l ja
30Django はハイレベルな Python Web フレームワークであり、素早い開発と
31クリーンで実用的な設計を勧めています。Django は可能な限りの自動化と
32無駄な繰返しを徹底的に排除することに注目しています。
33
34
35%package docs
36Summary:  Documentation for Django
37Group:    Documentation
38Requires: %{name} = %{version}-%{release}
39
40%description docs
41This package contains the documentation for the Django high-level
42Python Web framework.
43
44
45%prep
46%setup -q -n Django-%{version}
47
48# remove bundled simplejson
49cd django/utils/simplejson/
50%__rm -rf *
51# and put the replacement stub in place
52%__cp -p %{SOURCE1} __init__.py
53
54
55%build
56%{__python} setup.py build
57
58
59%install
60%__rm -rf $RPM_BUILD_ROOT
61%{__python} setup.py install --skip-build --root $RPM_BUILD_ROOT
62
63# Permission fixes
64pushd $RPM_BUILD_ROOT%{python_sitelib}/django
65        chmod +x conf/project_template/manage.py*
66        chmod +x contrib/admin/media/js/compress.py*
67        chmod +x bin/profiling/gather_profile_stats.py*
68        #chmod +x bin/compile-messages.py*
69        chmod +x bin/daily_cleanup.py*
70        chmod +x bin/django-admin.py*
71        #chmod +x bin/make-messages.py*
72        chmod +x bin/unique-messages.py*
73popd
74
75# Fix items in %{_bindir}
76%__mv $RPM_BUILD_ROOT%{_bindir}/django-admin.py $RPM_BUILD_ROOT%{_bindir}/django-admin
77
78# install man pages
79%__mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1/
80%__cp -p docs/man/* $RPM_BUILD_ROOT%{_mandir}/man1/
81
82# Handling locale files
83# This is adapted from the %%find_lang macro, which cannot be directly
84# used since Django locale files are not located in %%{_datadir}
85#
86# The rest of the packaging guideline still apply -- do not list
87# locale files by hand!
88%__rm -f %{name}.lang
89(cd $RPM_BUILD_ROOT && find . -name 'django*.mo') | %{__sed} -e 's|^.||' | %{__sed} -e \
90  's:\(.*/locale/\)\([^/_]\+\)\(.*\.mo$\):%lang(\2) \1\2\3:' \
91  >> %{name}.lang
92find $RPM_BUILD_ROOT -name "*.po" | xargs %__rm -f
93
94
95%clean
96rm -rf $RPM_BUILD_ROOT
97
98
99%files -f %{name}.lang
100%defattr(-,root,root,-)
101%doc AUTHORS LICENSE README
102%{_bindir}/django-admin
103%{_mandir}/man1/*
104%{python_sitelib}/django/bin/*.py*
105%{python_sitelib}/django/bin/profiling/
106# Include everything but the locale data ...
107%{python_sitelib}/django/db/
108%{python_sitelib}/django/*.py*
109%{python_sitelib}/django/shortcuts/
110%{python_sitelib}/django/utils/
111%{python_sitelib}/django/dispatch/
112%{python_sitelib}/django/template/
113%{python_sitelib}/django/views/
114%{python_sitelib}/django/contrib/
115%{python_sitelib}/django/forms/
116%{python_sitelib}/django/templatetags/
117%{python_sitelib}/django/core/
118%{python_sitelib}/django/http/
119%{python_sitelib}/django/middleware/
120%{python_sitelib}/django/test/
121%{python_sitelib}/django/conf/*.py*
122%{python_sitelib}/django/conf/project_template/*.py*
123%{python_sitelib}/django/conf/app_template/
124%{python_sitelib}/django/conf/urls/
125%{python_sitelib}/django/conf/locale/*/*.py*
126%{python_sitelib}/django/conf/locale/*.py*
127%{python_sitelib}/Django-%{version}-py%{pyver}.egg-info
128
129
130%files docs
131%defattr(-,root,root,-)
132%doc docs/*
133
134
135%changelog
136* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3-3
137- rebuild with VineSeed environment
138
139* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3-2
140- rebuild with python-2.7.2
141
142* Mon May 02 2011 Shu KONNO <owa@bg.wakwak.com> 1.3-1
143- updated Django to 1.3
144
145* Wed Feb 16 2011 Shu KONNO <owa@bg.wakwak.com> 1.2.5-1
146- updated Django to 1.2.5 (include CVE-2011-0696, CVE-2011-0697)
147
148* Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.2.3-1
149- updated Django to 1.2.3
150- dropt Django-hash-compat-13310.patch
151
152* Thu Sep 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.2.1-2
153- added simplejson-init.py: removed bundled simplejson, and put the __init__.py
154- added Django-hash-compat-13310.patch: http://code.djangoproject.com/changeset/13310 per BZ#601212
155- added BR: python-devel python-sphinx
156- added RQ: python-simplejson
157- removed po files (per BZ#529188)
158- install man1
159  (merged from 'Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> - Django-1.2.1-1')
160
161* Sun Aug 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.2.1-1
162- updated Django to 1.2.1
163
164* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.1.1-2
165- rebuild with python-2.6
166
167* Sun Oct 18 2009 Shu KONNO <owa@bg.wakwak.com> 1.1.1-1
168- updated Django to 1.1.1
169
170* Fri Jul 31 2009 Shu KONNO <owa@bg.wakwak.com> 1.1-1
171- updated Django to 1.1
172- added japanese description
173
174* Fri Nov 28 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.2-1vl5
175- updated Django to 1.0.2-final
176
177* Wed Oct 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.0-1vl5
178- packaged new
179
Note: See TracBrowser for help on using the repository browser.