source: projects/specs/trunk/p/python-django/python-django-vl.spec @ 1485

Revision 1485, 2.5 KB checked in by owa, 14 years ago (diff)

updated to django-1.2.1

Line 
1Summary: A high-level Python Web framework
2Summary(ja): Python の高度なウェブフレームワーク
3Name: python-django
4Version: 1.2.1
5Release: 1%{?_dist_release}
6Group: Development/Languages
7BuildArch: noarch
8License: BSD
9URL: http://www.djangoproject.com/
10Source0: Django-%{version}.tar.gz
11
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13
14Vendor: Project Vine
15Distribution: Vine Linux
16Packager: <owa>
17
18%description
19Django is a high-level Python Web framework that encourages rapid
20development and a clean, pragmatic design. It focuses on automating as
21much as possible and adhering to the DRY (Don't Repeat Yourself)
22principle.
23
24%description -l ja
25Django はハイレベルな Python Web フレームワークであり、素早い開発と
26クリーンで実用的な設計を勧めています。Django は可能な限りの自動化と
27無駄な繰返しを徹底的に排除することに注目しています。
28
29
30%package docs
31Summary:  Documentation for Django
32Group:    Documentation
33Requires: %{name} = %{version}-%{release}
34
35%description docs
36This package contains the documentation for the Django high-level
37Python Web framework.
38
39%prep
40%setup -q -n Django-%{version}
41
42%build
43%{__python} setup.py build
44
45%install
46rm -rf $RPM_BUILD_ROOT
47%{__python} setup.py install --skip-build --root $RPM_BUILD_ROOT
48
49## Documentation
50#mkdir -p $RPM_BUILD_ROOT%{_datadir}/%{name}
51#chmod +x examples/manage.py
52#mv examples $RPM_BUILD_ROOT%{_datadir}/%{name}/
53
54# Permission fixes
55pushd $RPM_BUILD_ROOT%{python_sitelib}/django
56        chmod +x conf/project_template/manage.py
57        chmod +x bin/compile-messages.py
58        chmod +x bin/daily_cleanup.py
59        chmod +x bin/django-admin.py
60        chmod +x bin/make-messages.py
61        chmod +x bin/unique-messages.py
62        chmod +x bin/profiling/gather_profile_stats.py
63popd
64
65%clean
66rm -rf $RPM_BUILD_ROOT
67
68%files
69%defattr(-,root,root,-)
70%doc AUTHORS LICENSE README
71%{_bindir}/django-admin.py
72%{python_sitelib}/django
73%{python_sitelib}/Django-%{version}-py%{pyver}.egg-info
74
75%files docs
76%defattr(-,root,root,-)
77%doc docs/*
78#%{_datadir}/%{name}
79
80%changelog
81* Sun Aug 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.2.1-1
82- updated Django to 1.2.1
83
84* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.1.1-2
85- rebuild with python-2.6
86
87* Sun Oct 18 2009 Shu KONNO <owa@bg.wakwak.com> 1.1.1-1
88- updated Django to 1.1.1
89
90* Fri Jul 31 2009 Shu KONNO <owa@bg.wakwak.com> 1.1-1
91- updated Django to 1.1
92- added japanese description
93
94* Fri Nov 28 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.2-1vl5
95- updated Django to 1.0.2-final
96
97* Wed Oct 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.0-1vl5
98- packaged new
99
Note: See TracBrowser for help on using the repository browser.