source: projects/specs/trunk/p/python-cryptography/python-cryptography-vl.spec @ 11921

Revision 11921, 9.6 KB checked in by tomop, 5 years ago (diff)

new: python-cryptography and requirements

Line 
1%global with_python3 1
2%{!?__python2: %global __python2 /usr/bin/python}
3%{!?python2_sitearch: %global python2_sitearch %(%{__python2} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
4
5%{!?python3_pkgversion:%global python3_pkgversion 3}
6
7%global srcname cryptography
8
9Name:           python-%{srcname}
10Version:        2.4.1
11Release:        1%{?_dist_release}
12Summary:        PyCA's cryptography library
13
14Group:          Development/Libraries
15License:        ASL 2.0 or BSD
16URL:            https://cryptography.io/en/latest/
17
18Vendor:         Project Vine
19Distribution:   Vine Linux
20
21Source0:        https://pypi.io/packages/source/c/%{srcname}/%{srcname}-%{version}.tar.gz
22
23Requires:       openssl
24Requires:       python-idna >= 2.1
25Requires:       python-asn1crypto >= 0.21
26Requires:       python-six >= 1.4.1
27Requires:       python-cffi >= 1.7
28Requires:       python-enum34
29Requires:       python-ipaddress
30
31BuildRequires:  openssl-devel
32BuildRequires:  gcc
33
34BuildRequires:  python-rpm-macros
35BuildRequires:  python-devel
36BuildRequires:  python-setuptools
37BuildRequires:  python-asn1crypto >= 0.21
38
39BuildRequires:  python-idna >= 2.1
40BuildRequires:  python-six >= 1.4.1
41BuildRequires:  python-cffi >= 1.7
42BuildRequires:  python-enum34
43BuildRequires:  python-ipaddress
44
45%if 0%{?with_python3}
46BuildRequires:  python%{python3_pkgversion}-rpm-macros
47BuildRequires:  python%{python3_pkgversion}-devel
48BuildRequires:  python%{python3_pkgversion}-setuptools
49BuildRequires:  python%{python3_pkgversion}-asn1crypto >= 0.21
50
51BuildRequires:  python%{python3_pkgversion}-idna >= 2.1
52BuildRequires:  python%{python3_pkgversion}-six >= 1.4.1
53BuildRequires:  python%{python3_pkgversion}-cffi >= 1.7
54%endif
55
56%description
57cryptography is a package designed to expose cryptographic primitives and
58recipes to Python developers.
59
60%if 0%{?with_python3}
61%{?python_provide:%python_provide python2-%{srcname}}
62%else
63Provides:       python-%{srcname}
64%endif
65
66%if 0%{?with_python3}
67%package -n  python%{python3_pkgversion}-%{srcname}
68Group:          Development/Libraries
69Summary:        PyCA's cryptography library
70%{?python_provide:%python_provide python%{python3_pkgversion}-%{srcname}}
71
72Requires:       openssl
73Requires:       python%{python3_pkgversion}-idna >= 2.1
74Requires:       python%{python3_pkgversion}-asn1crypto >= 0.21
75Requires:       python%{python3_pkgversion}-six >= 1.4.1
76Requires:       python%{python3_pkgversion}-cffi >= 1.7
77
78%description -n python%{python3_pkgversion}-%{srcname}
79cryptography is a package designed to expose cryptographic primitives and
80recipes to Python developers.
81%endif
82
83%prep
84%autosetup -p1 -n %{srcname}-%{version}
85
86%if 0%{?with_python3}
87rm -rf %{py3dir}
88cp -a . %{py3dir}
89find %{py3dir} -name '*.py' | xargs sed -i '1s|^#!/usr/bin/python|#!%{__python3}|'
90%endif
91
92%build
93%if 0%{?with_python3}
94%py_build
95pushd %{py3dir}
96%py3_build
97popd
98%else
99%{__python} setup.py build
100%endif # with_python3
101
102%install
103# Actually other *.c and *.h are appropriate
104# see https://github.com/pyca/cryptography/issues/1463
105find . -name .keep -print -delete
106
107%if 0%{?with_python3}
108%py_install
109pushd %{py3dir}
110%py3_install
111popd
112%else
113%{__python} setup.py install --skip-build --prefix=%{_prefix} --root %{buildroot}
114%endif # with_python3
115
116
117%check
118# workaround for pytest 3.2.0 bug https://github.com/pytest-dev/pytest/issues/2644
119rm -f tests/hazmat/primitives/test_padding.py
120#%{__python} setup.py test
121
122%if 0%{?with_python3}
123pushd %{py3dir}
124# workaround for pytest 3.2.0 bug https://github.com/pytest-dev/pytest/issues/2644
125rm -f tests/hazmat/primitives/test_padding.py
126#%{__python3} setup.py test
127popd
128%endif
129
130
131%files
132%doc LICENSE LICENSE.APACHE LICENSE.BSD README.rst docs
133%{python2_sitearch}/%{srcname}
134%{python2_sitearch}/%{srcname}-%{version}-py*.egg-info
135
136
137%if 0%{?with_python3}
138%files -n python%{python3_pkgversion}-%{srcname}
139%doc README.rst docs
140%license LICENSE LICENSE.APACHE LICENSE.BSD
141%{python3_sitearch}/*
142%{python3_sitearch}/%{srcname}-%{version}-py*.egg-info
143%endif
144
145
146%changelog
147* Mon Nov 19 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.4.1-1
148- initial build for Vine Linux.
149- new upstream release.
150
151* Mon Aug 13 2018 Christian Heimes <cheimes@redhat.com> - 2.3-2
152- Use TLSv1.2 in test as workaround for RHBZ#1615143
153
154* Wed Jul 18 2018 Christian Heimes <cheimes@redhat.com> - 2.3-1
155- New upstream release 2.3
156- Fix AEAD tag truncation bug, RHBZ#1602752
157
158* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.1-3
159- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
160
161* Fri Jun 15 2018 Miro Hrončok <mhroncok@redhat.com> - 2.2.1-2
162- Rebuilt for Python 3.7
163
164* Wed Mar 21 2018 Christian Heimes <cheimes@redhat.com> - 2.2.1-1
165- New upstream release 2.2.1
166
167* Sun Feb 18 2018 Christian Heimes <cheimes@redhat.com> - 2.1.4-1
168- New upstream release 2.1.4
169
170* Sun Feb 18 2018 Christian Heimes <cheimes@redhat.com> - 2.1.3-4
171- Build requires gcc
172
173* Mon Feb 12 2018 Iryna Shcherbina <ishcherb@redhat.com> - 2.1.3-3
174- Update Python 2 dependency declarations to new packaging standards
175  (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
176
177* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.3-2
178- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
179
180* Thu Nov 23 2017 Haïkel Guémar <hguemar@fedoraproject.org> - 2.1.3-1
181- Upstream 2.1.3
182
183* Tue Oct 24 2017 Christian Heimes <cheimes@redhat.com> - 2.1-2
184- Change Requires to openssl-libs
185
186* Thu Oct 12 2017 Christian Heimes <cheimes@redhat.com> - 2.1-1
187- New upstream release 2.1
188
189* Wed Sep 27 2017 Troy Dawson <tdawson@redhat.com> - 2.0.2-3
190- Cleanup spec file conditionals
191
192* Thu Aug 03 2017 Christian Heimes <cheimes@redhat.com> - 2.0.2-2
193- Add workaround for pytest bug
194
195* Thu Aug 03 2017 Christian Heimes <cheimes@redhat.com> - 2.0.2-1
196- New upstream release 2.0.2
197- Modernize spec
198
199* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.9-3
200- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
201
202* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.9-2
203- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
204
205* Tue Jun 27 2017 Christian Heimes <cheimes@redhat.com> - 1.9-1
206- Upstream release 1.9
207
208* Wed Feb 15 2017 Christian Heimes <cheimes@redhat.com> - 1.7.2-1
209- Update to latest upstream
210
211* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.1-2
212- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
213
214* Thu Jan 05 2017 Matěj Cepl <mcepl@redhat.com> - 1.7.1-1
215- Update to the latest upstream.
216- Add a patch from https://github.com/pyca/cryptography/pull/3328
217
218* Tue Dec 13 2016 Charalampos Stratakis <cstratak@redhat.com> - 1.5.3-5
219- Enable tests
220
221* Mon Dec 12 2016 Charalampos Stratakis <cstratak@redhat.com> - 1.5.3-4
222- Rebuild for Python 3.6
223- Disable python3 tests for now
224
225* Thu Nov 10 2016 Nathaniel McCallum <npmccallum@redhat.com> - 1.5.3-3
226- Revert previous change
227
228* Thu Nov 10 2016 Nathaniel McCallum <npmccallum@redhat.com> - 1.5.3-2
229- Disable tests on releases earlier than 24
230
231* Mon Nov 07 2016 Nathaniel McCallum <npmccallum@redhat.com> - 1.5.3-1
232- Update to v1.5.3
233- Update source URL
234- Add BR for pytz
235
236* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.1-4
237- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
238
239* Tue May 10 2016 Nathaniel McCallum <npmccallum@redhat.com> - 1.3.1-3
240- Remove versioned setuptools dependency
241
242* Tue May 10 2016 Nathaniel McCallum <npmccallum@redhat.com> - 1.3.1-2
243- Make it easier to build on EL7
244
245* Tue May 03 2016 Nathaniel McCallum <npmccallum@redhat.com> - 1.3.1-1
246- Update to v1.3.1
247
248* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.1-3
249- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
250
251* Mon Jan 11 2016 Nathaniel McCallum <npmccallum@redhat.com> - 1.2.1-2
252- Move python-cryptograph => python2-cryptography
253
254* Sat Jan 09 2016 Nathaniel McCallum <npmccallum@redhat.com> - 1.2.1-1
255- Update to v1.2.1
256
257* Wed Nov 11 2015 Robert Kuska <rkuska@redhat.com> - 1.1-1
258- Update to v1.1
259
260* Wed Nov 04 2015 Robert Kuska <rkuska@redhat.com> - 1.0.2-2
261- Rebuilt for Python3.5 rebuild
262
263* Wed Sep 30 2015 Matěj Cepl <mcepl@redhat.com> - 1.0.2-1
264- New upstream release (fix #1267548)
265
266* Wed Aug 12 2015 Nathaniel McCallum <npmccallum@redhat.com> - 1.0-1
267- New upstream release
268
269* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9-2
270- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
271
272* Thu May 14 2015 Nathaniel McCallum <npmccallum@redhat.com> - 0.9-1
273- New upstream release
274- Run tests on RHEL
275- New deps: python-idna, python-ipaddress
276
277* Fri Apr 17 2015 Nathaniel McCallum <npmccallum@redhat.com> - 0.8.2-1
278- New upstream release
279- Add python3-pyasn1 Requires (#1211073)
280
281* Tue Apr 14 2015 Matej Cepl <mcepl@redhat.com> - 0.8-2
282- Add python-pyasn1 Requires (#1211073)
283
284* Fri Mar 13 2015 Nathaniel McCallum <npmccallum@redhat.com> - 0.8-1
285- New upstream release
286- Remove upstreamed patch
287
288* Wed Mar 04 2015 Nathaniel McCallum <npmccallum@redhat.com> - 0.7.2-2
289- Add python3-cryptography-vectors build requires
290- Add python-enum34 requires
291
292* Tue Feb 03 2015 Nathaniel McCallum <npmccallum@redhat.com> - 0.7.2-1
293- New upstream release. BSD is now an optional license.
294- Fix test running on python3
295- Add upstream patch to fix test paths
296
297* Fri Nov 07 2014 Matej Cepl <mcepl@redhat.com> - 0.6.1-2
298- Fix requires, for reasons why other development files were not
299  eliminated see https://github.com/pyca/cryptography/issues/1463.
300
301* Wed Nov 05 2014 Matej Cepl <mcepl@redhat.com> - 0.6.1-1
302- New upstream release.
303
304* Sun Jun 29 2014 Terry Chia <terrycwk1994@gmail.com> 0.4-1
305- initial version
Note: See TracBrowser for help on using the repository browser.