source: projects/specs/trunk/p/python-cryptography/python-cryptography-vl.spec @ 12469

Revision 12469, 9.5 KB checked in by tomop, 4 years ago (diff)

python-3.8.5 and related packages.

Line 
1%global with_python3 1
2
3%{!?python3_pkgversion:%global python3_pkgversion 3}
4%global srcname cryptography
5
6Summary:        PyCA's cryptography library
7Name:           python-%{srcname}
8Version:        3.0
9Release:        1%{?_dist_release}
10Group:          programming
11Vendor:         Project Vine
12Distribution:   Vine Linux
13
14License:        ASL 2.0 or BSD
15URL:            https://cryptography.io/en/latest/
16Source0:        https://pypi.io/packages/source/c/%{srcname}/%{srcname}-%{version}.tar.gz
17
18Requires:       openssl
19Requires:       python-idna >= 2.1
20Requires:       python-asn1crypto >= 0.21
21Requires:       python-six >= 1.4.1
22Requires:       python-cffi >= 1.7
23Requires:       python-enum34
24Requires:       python-ipaddress
25
26BuildRequires:  openssl-devel
27BuildRequires:  gcc
28
29BuildRequires:  python-rpm-macros
30BuildRequires:  python2-rpm-macros
31BuildRequires:  python-devel
32BuildRequires:  python-setuptools
33BuildRequires:  python-asn1crypto >= 0.21
34
35BuildRequires:  python-idna >= 2.1
36BuildRequires:  python-six >= 1.4.1
37BuildRequires:  python-cffi >= 1.7
38BuildRequires:  python-enum34
39BuildRequires:  python-ipaddress
40
41%if 0%{?with_python3}
42BuildRequires:  python%{python3_pkgversion}-rpm-macros
43BuildRequires:  python%{python3_pkgversion}-devel
44BuildRequires:  python%{python3_pkgversion}-setuptools
45BuildRequires:  python%{python3_pkgversion}-asn1crypto >= 0.21
46
47BuildRequires:  python%{python3_pkgversion}-idna >= 2.1
48BuildRequires:  python%{python3_pkgversion}-six >= 1.4.1
49BuildRequires:  python%{python3_pkgversion}-cffi >= 1.7
50%endif
51
52%description
53cryptography is a package designed to expose cryptographic primitives and
54recipes to Python developers.
55
56%if 0%{?with_python3}
57%{?python_provide:%python_provide python2-%{srcname}}
58%else
59Provides:       python-%{srcname}
60%endif
61
62%if 0%{?with_python3}
63%package -n  python%{python3_pkgversion}-%{srcname}
64Group:          programming
65Summary:        PyCA's cryptography library
66%{?python_provide:%python_provide python%{python3_pkgversion}-%{srcname}}
67
68Requires:       openssl
69Requires:       python%{python3_pkgversion}-idna >= 2.1
70Requires:       python%{python3_pkgversion}-asn1crypto >= 0.21
71Requires:       python%{python3_pkgversion}-six >= 1.4.1
72Requires:       python%{python3_pkgversion}-cffi >= 1.7
73
74%description -n python%{python3_pkgversion}-%{srcname}
75cryptography is a package designed to expose cryptographic primitives and
76recipes to Python developers.
77%endif
78
79%prep
80%autosetup -p1 -n %{srcname}-%{version}
81
82%if 0%{?with_python3}
83rm -rf %{py3dir}
84cp -a . %{py3dir}
85find %{py3dir} -name '*.py' | xargs sed -i '1s|^#!/usr/bin/python|#!%{__python3}|'
86%endif
87
88%build
89%if 0%{?with_python3}
90%py_build
91pushd %{py3dir}
92%py3_build
93popd
94%else
95%{__python} setup.py build
96%endif # with_python3
97
98%install
99# Actually other *.c and *.h are appropriate
100# see https://github.com/pyca/cryptography/issues/1463
101find . -name .keep -print -delete
102
103%if 0%{?with_python3}
104%py_install
105pushd %{py3dir}
106%py3_install
107popd
108%else
109%{__python} setup.py install --skip-build --prefix=%{_prefix} --root %{buildroot}
110%endif # with_python3
111
112
113%check
114# workaround for pytest 3.2.0 bug https://github.com/pytest-dev/pytest/issues/2644
115rm -f tests/hazmat/primitives/test_padding.py
116#%{__python} setup.py test
117
118%if 0%{?with_python3}
119pushd %{py3dir}
120# workaround for pytest 3.2.0 bug https://github.com/pytest-dev/pytest/issues/2644
121rm -f tests/hazmat/primitives/test_padding.py
122#%{__python3} setup.py test
123popd
124%endif
125
126
127%files
128%license LICENSE*
129%doc README.rst docs
130%{python2_sitearch}/%{srcname}
131%{python2_sitearch}/%{srcname}-%{version}-py*.egg-info
132
133
134%if 0%{?with_python3}
135%files -n python%{python3_pkgversion}-%{srcname}
136%license LICENSE*
137%doc README.rst docs
138%{python3_sitearch}/*
139%{python3_sitearch}/%{srcname}-%{version}-py*.egg-info
140%endif
141
142
143%changelog
144* Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.0-1
145- new upstream release.
146
147* Mon Nov 19 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.4.1-1
148- initial build for Vine Linux.
149- new upstream release.
150
151* Mon Aug 13 2018 Christian Heimes <cheimes@redhat.com> - 2.3-2
152- Use TLSv1.2 in test as workaround for RHBZ#1615143
153
154* Wed Jul 18 2018 Christian Heimes <cheimes@redhat.com> - 2.3-1
155- New upstream release 2.3
156- Fix AEAD tag truncation bug, RHBZ#1602752
157
158* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.1-3
159- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
160
161* Fri Jun 15 2018 Miro Hrončok <mhroncok@redhat.com> - 2.2.1-2
162- Rebuilt for Python 3.7
163
164* Wed Mar 21 2018 Christian Heimes <cheimes@redhat.com> - 2.2.1-1
165- New upstream release 2.2.1
166
167* Sun Feb 18 2018 Christian Heimes <cheimes@redhat.com> - 2.1.4-1
168- New upstream release 2.1.4
169
170* Sun Feb 18 2018 Christian Heimes <cheimes@redhat.com> - 2.1.3-4
171- Build requires gcc
172
173* Mon Feb 12 2018 Iryna Shcherbina <ishcherb@redhat.com> - 2.1.3-3
174- Update Python 2 dependency declarations to new packaging standards
175  (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
176
177* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.3-2
178- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
179
180* Thu Nov 23 2017 Haïkel Guémar <hguemar@fedoraproject.org> - 2.1.3-1
181- Upstream 2.1.3
182
183* Tue Oct 24 2017 Christian Heimes <cheimes@redhat.com> - 2.1-2
184- Change Requires to openssl-libs
185
186* Thu Oct 12 2017 Christian Heimes <cheimes@redhat.com> - 2.1-1
187- New upstream release 2.1
188
189* Wed Sep 27 2017 Troy Dawson <tdawson@redhat.com> - 2.0.2-3
190- Cleanup spec file conditionals
191
192* Thu Aug 03 2017 Christian Heimes <cheimes@redhat.com> - 2.0.2-2
193- Add workaround for pytest bug
194
195* Thu Aug 03 2017 Christian Heimes <cheimes@redhat.com> - 2.0.2-1
196- New upstream release 2.0.2
197- Modernize spec
198
199* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.9-3
200- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
201
202* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.9-2
203- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
204
205* Tue Jun 27 2017 Christian Heimes <cheimes@redhat.com> - 1.9-1
206- Upstream release 1.9
207
208* Wed Feb 15 2017 Christian Heimes <cheimes@redhat.com> - 1.7.2-1
209- Update to latest upstream
210
211* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.1-2
212- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
213
214* Thu Jan 05 2017 Matěj Cepl <mcepl@redhat.com> - 1.7.1-1
215- Update to the latest upstream.
216- Add a patch from https://github.com/pyca/cryptography/pull/3328
217
218* Tue Dec 13 2016 Charalampos Stratakis <cstratak@redhat.com> - 1.5.3-5
219- Enable tests
220
221* Mon Dec 12 2016 Charalampos Stratakis <cstratak@redhat.com> - 1.5.3-4
222- Rebuild for Python 3.6
223- Disable python3 tests for now
224
225* Thu Nov 10 2016 Nathaniel McCallum <npmccallum@redhat.com> - 1.5.3-3
226- Revert previous change
227
228* Thu Nov 10 2016 Nathaniel McCallum <npmccallum@redhat.com> - 1.5.3-2
229- Disable tests on releases earlier than 24
230
231* Mon Nov 07 2016 Nathaniel McCallum <npmccallum@redhat.com> - 1.5.3-1
232- Update to v1.5.3
233- Update source URL
234- Add BR for pytz
235
236* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.1-4
237- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
238
239* Tue May 10 2016 Nathaniel McCallum <npmccallum@redhat.com> - 1.3.1-3
240- Remove versioned setuptools dependency
241
242* Tue May 10 2016 Nathaniel McCallum <npmccallum@redhat.com> - 1.3.1-2
243- Make it easier to build on EL7
244
245* Tue May 03 2016 Nathaniel McCallum <npmccallum@redhat.com> - 1.3.1-1
246- Update to v1.3.1
247
248* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.1-3
249- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
250
251* Mon Jan 11 2016 Nathaniel McCallum <npmccallum@redhat.com> - 1.2.1-2
252- Move python-cryptograph => python2-cryptography
253
254* Sat Jan 09 2016 Nathaniel McCallum <npmccallum@redhat.com> - 1.2.1-1
255- Update to v1.2.1
256
257* Wed Nov 11 2015 Robert Kuska <rkuska@redhat.com> - 1.1-1
258- Update to v1.1
259
260* Wed Nov 04 2015 Robert Kuska <rkuska@redhat.com> - 1.0.2-2
261- Rebuilt for Python3.5 rebuild
262
263* Wed Sep 30 2015 Matěj Cepl <mcepl@redhat.com> - 1.0.2-1
264- New upstream release (fix #1267548)
265
266* Wed Aug 12 2015 Nathaniel McCallum <npmccallum@redhat.com> - 1.0-1
267- New upstream release
268
269* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9-2
270- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
271
272* Thu May 14 2015 Nathaniel McCallum <npmccallum@redhat.com> - 0.9-1
273- New upstream release
274- Run tests on RHEL
275- New deps: python-idna, python-ipaddress
276
277* Fri Apr 17 2015 Nathaniel McCallum <npmccallum@redhat.com> - 0.8.2-1
278- New upstream release
279- Add python3-pyasn1 Requires (#1211073)
280
281* Tue Apr 14 2015 Matej Cepl <mcepl@redhat.com> - 0.8-2
282- Add python-pyasn1 Requires (#1211073)
283
284* Fri Mar 13 2015 Nathaniel McCallum <npmccallum@redhat.com> - 0.8-1
285- New upstream release
286- Remove upstreamed patch
287
288* Wed Mar 04 2015 Nathaniel McCallum <npmccallum@redhat.com> - 0.7.2-2
289- Add python3-cryptography-vectors build requires
290- Add python-enum34 requires
291
292* Tue Feb 03 2015 Nathaniel McCallum <npmccallum@redhat.com> - 0.7.2-1
293- New upstream release. BSD is now an optional license.
294- Fix test running on python3
295- Add upstream patch to fix test paths
296
297* Fri Nov 07 2014 Matej Cepl <mcepl@redhat.com> - 0.6.1-2
298- Fix requires, for reasons why other development files were not
299  eliminated see https://github.com/pyca/cryptography/issues/1463.
300
301* Wed Nov 05 2014 Matej Cepl <mcepl@redhat.com> - 0.6.1-1
302- New upstream release.
303
304* Sun Jun 29 2014 Terry Chia <terrycwk1994@gmail.com> 0.4-1
305- initial version
Note: See TracBrowser for help on using the repository browser.