source: projects/specs/trunk/p/python-cherrypy/python-cherrypy-vl.spec @ 1741

Revision 1741, 5.1 KB checked in by munepi, 14 years ago (diff)

NEW calibre: updated/added calibre's dependencies

Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           python-cherrypy
4Version:        3.1.2
5Release:        1%{?_dist_release}
6Summary:        Pythonic, object-oriented web development framework
7Group:          Development/Libraries
8License:        BSD
9URL:            http://www.cherrypy.org/
10Source0:        http://download.cherrypy.org/cherrypy/%{version}/CherryPy-%{version}.tar.gz
11Patch0:         python-cherrypy-tutorial-doc.patch
12Patch1: python-cherrypy-changederrormessage.patch
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
15
16BuildArch:      noarch
17
18BuildRequires:  python-devel
19BuildRequires:  python-setuptools
20BuildRequires:  tidy
21
22%description
23CherryPy allows developers to build web applications in much the same way
24they would build any other object-oriented Python program. This usually
25results in smaller source code developed in less time.
26
27%prep
28%setup -q -n CherryPy-%{version}
29%patch0 -p1
30%patch1 -p1 -b .errmsg
31
32%{__sed} -i 's/\r//' README.txt cherrypy/tutorial/README.txt cherrypy/tutorial/tutorial.conf
33
34%build
35%{__python} setup.py build
36
37%install
38%__rm -rf $RPM_BUILD_ROOT
39%{__python} setup.py install --skip-build --root $RPM_BUILD_ROOT
40
41%check
42cd cherrypy/test
43# The tidy tool test needs tidy in the test dir
44ln -s %{_bindir}/tidy tidy
45PYTHONPATH='../../' %{__python} test.py --dumb
46
47%clean
48%__rm -rf $RPM_BUILD_ROOT
49
50%files
51%defattr(-,root,root,-)
52%doc README.txt
53%doc cherrypy/tutorial
54%{_bindir}/cherryd
55%{python_sitelib}/*
56
57%changelog
58* Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> 3.1.2-1
59- initial build based on Fedora development
60
61* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 3.1.2-5
62- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
63
64* Mon May 31 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 3.1.2-4
65- Fix a failing unittest with newer python
66
67* Sat Apr 24 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 3.1.2-3
68- Revert a try at 3.2.x-rc1 as the tests won't pass without some work.
69
70* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1.2-2
71- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
72
73* Tue Jun 16 2009 Toshio Kuratomi <toshio@fedoraproject.org> - 3.1.2-1
74- New upstream with python-2.6 fixes.
75- BR tidy for tests.
76
77* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1.1-2
78- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
79
80* Mon Dec 1 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 3.1.1-1
81- Update to 3.1.1
82- Fix python-2.6 build errors
83- Make test code non-interactive via cmdline switch
84- Refresh the no test and tutorial patch
85
86* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 3.0.3-3
87- Rebuild for Python 2.6
88
89* Tue Jan 22 2008 Toshio Kuratomi <toshio@fedoraproject.org> 3.0.3-2
90- Forgot to upload the tarball.
91
92* Mon Jan 21 2008 Toshio Kuratomi <toshio@fedoraproject.org> 3.0.3-1
93- Upgrade to 3.0.3.
94
95* Thu Jan 17 2008 Toshio Kuratomi <toshio@fedoraproject.org> 2.3.0-2
96- EINTR Patch needed to be forwarded ported as well as it is only applied to
97  CP trunk (3.x).
98
99* Thu Jan 17 2008 Toshio Kuratomi <toshio@fedoraproject.org> 2.3.0-1
100- Update to new upstream which rolls in the backported security fix.
101- Refresh other patches to apply against new version.
102- Change to new canonical source URL.
103- Reenable tests.
104
105* Sun Jan  6 2008 Toshio Kuratomi <toshio@fedoraproject.org> 2.2.1-8
106- Fix a security bug with a backport of http://www.cherrypy.org/changeset/1775
107- Include the egginfo files as well as the python files.
108
109* Sat Nov  3 2007 Luke Macken <lmacken@redhat.com> 2.2.1-7
110- Apply backported fix from http://www.cherrypy.org/changeset/1766
111  to improve CherryPy's SIGSTOP/SIGCONT handling (Bug #364911).
112  Thanks to Nils Philippsen for the patch.
113
114* Mon Feb 19 2007 Luke Macken <lmacken@redhat.com> 2.2.1-6
115- Disable regression tests until we can figure out why they
116  are dying in mock.
117
118* Sun Dec 10 2006 Luke Macken <lmacken@redhat.com> 2.2.1-5
119- Add python-devel to BuildRequires
120
121* Sun Dec 10 2006 Luke Macken <lmacken@redhat.com> 2.2.1-4
122- Rebuild for python 2.5
123
124* Mon Sep 18 2006 Luke Macken <lmacken@redhat.com> 2.2.1-3
125- Rebuild for FC6
126- Include pyo files instead of ghosting them
127
128* Thu Jul 13 2006 Luke Macken <lmacken@redhat.com> 2.2.1-2
129- Rebuild
130
131* Thu Jul 13 2006 Luke Macken <lmacken@redhat.com> 2.2.1-1
132- Update to 2.2.1
133- Remove unnecessary python-abi requirement
134
135* Sat Apr 22 2006 Gijs Hollestelle <gijs@gewis.nl> 2.2.0-1
136- Update to 2.2.0
137
138* Wed Feb 22 2006 Gijs Hollestelle <gijs@gewis.nl> 2.1.1-1
139- Update to 2.1.1 (Security fix)
140
141* Tue Nov  1 2005 Gijs Hollestelle <gijs@gewis.nl> 2.1.0-1
142- Updated to 2.1.0
143
144* Sat May 14 2005 Gijs Hollestelle <gijs@gewis.nl> 2.0.0-2
145- Added dist tag
146
147* Sun May  8 2005 Gijs Hollestelle <gijs@gewis.nl> 2.0.0-1
148- Updated to 2.0.0 final
149- Updated python-cherrypy-tutorial-doc.patch to match new version
150
151* Wed Apr  6 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 2.0.0-0.2.b
152- Removed CFLAGS
153
154* Wed Mar 23 2005 Gijs Hollestelle <gijs[AT]gewis.nl> 2.0.0-0.1.b
155- Initial Fedora Package
Note: See TracBrowser for help on using the repository browser.