source: projects/specs/trunk/p/python-cherrypy/python-cherrypy-vl.spec @ 5701

Revision 5701, 5.2 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           python-cherrypy
4Version:        3.1.2
5Release:        2%{?_dist_release}
6Summary:        Pythonic, object-oriented web development framework
7Group:          Development/Libraries
8License:        BSD
9URL:            http://www.cherrypy.org/
10Source0:        http://download.cherrypy.org/cherrypy/%{version}/CherryPy-%{version}.tar.gz
11Patch0:         python-cherrypy-tutorial-doc.patch
12Patch1: python-cherrypy-changederrormessage.patch
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
15
16BuildArch:      noarch
17
18BuildRequires:  python-devel
19BuildRequires:  python-setuptools
20BuildRequires:  tidy
21
22%description
23CherryPy allows developers to build web applications in much the same way
24they would build any other object-oriented Python program. This usually
25results in smaller source code developed in less time.
26
27%prep
28%setup -q -n CherryPy-%{version}
29%patch0 -p1
30%patch1 -p1 -b .errmsg
31
32%{__sed} -i 's/\r//' README.txt cherrypy/tutorial/README.txt cherrypy/tutorial/tutorial.conf
33
34%build
35%{__python} setup.py build
36
37%install
38%__rm -rf $RPM_BUILD_ROOT
39%{__python} setup.py install --skip-build --root $RPM_BUILD_ROOT
40
41%check
42cd cherrypy/test
43# The tidy tool test needs tidy in the test dir
44ln -s %{_bindir}/tidy tidy
45PYTHONPATH='../../' %{__python} test.py --dumb
46
47%clean
48%__rm -rf $RPM_BUILD_ROOT
49
50%files
51%defattr(-,root,root,-)
52%doc README.txt
53%doc cherrypy/tutorial
54%{_bindir}/cherryd
55%{python_sitelib}/*
56
57%changelog
58* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-2
59- rebuild with python-2.7.2
60
61* Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> 3.1.2-1
62- initial build based on Fedora development
63
64* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 3.1.2-5
65- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
66
67* Mon May 31 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 3.1.2-4
68- Fix a failing unittest with newer python
69
70* Sat Apr 24 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 3.1.2-3
71- Revert a try at 3.2.x-rc1 as the tests won't pass without some work.
72
73* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1.2-2
74- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
75
76* Tue Jun 16 2009 Toshio Kuratomi <toshio@fedoraproject.org> - 3.1.2-1
77- New upstream with python-2.6 fixes.
78- BR tidy for tests.
79
80* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1.1-2
81- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
82
83* Mon Dec 1 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 3.1.1-1
84- Update to 3.1.1
85- Fix python-2.6 build errors
86- Make test code non-interactive via cmdline switch
87- Refresh the no test and tutorial patch
88
89* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 3.0.3-3
90- Rebuild for Python 2.6
91
92* Tue Jan 22 2008 Toshio Kuratomi <toshio@fedoraproject.org> 3.0.3-2
93- Forgot to upload the tarball.
94
95* Mon Jan 21 2008 Toshio Kuratomi <toshio@fedoraproject.org> 3.0.3-1
96- Upgrade to 3.0.3.
97
98* Thu Jan 17 2008 Toshio Kuratomi <toshio@fedoraproject.org> 2.3.0-2
99- EINTR Patch needed to be forwarded ported as well as it is only applied to
100  CP trunk (3.x).
101
102* Thu Jan 17 2008 Toshio Kuratomi <toshio@fedoraproject.org> 2.3.0-1
103- Update to new upstream which rolls in the backported security fix.
104- Refresh other patches to apply against new version.
105- Change to new canonical source URL.
106- Reenable tests.
107
108* Sun Jan  6 2008 Toshio Kuratomi <toshio@fedoraproject.org> 2.2.1-8
109- Fix a security bug with a backport of http://www.cherrypy.org/changeset/1775
110- Include the egginfo files as well as the python files.
111
112* Sat Nov  3 2007 Luke Macken <lmacken@redhat.com> 2.2.1-7
113- Apply backported fix from http://www.cherrypy.org/changeset/1766
114  to improve CherryPy's SIGSTOP/SIGCONT handling (Bug #364911).
115  Thanks to Nils Philippsen for the patch.
116
117* Mon Feb 19 2007 Luke Macken <lmacken@redhat.com> 2.2.1-6
118- Disable regression tests until we can figure out why they
119  are dying in mock.
120
121* Sun Dec 10 2006 Luke Macken <lmacken@redhat.com> 2.2.1-5
122- Add python-devel to BuildRequires
123
124* Sun Dec 10 2006 Luke Macken <lmacken@redhat.com> 2.2.1-4
125- Rebuild for python 2.5
126
127* Mon Sep 18 2006 Luke Macken <lmacken@redhat.com> 2.2.1-3
128- Rebuild for FC6
129- Include pyo files instead of ghosting them
130
131* Thu Jul 13 2006 Luke Macken <lmacken@redhat.com> 2.2.1-2
132- Rebuild
133
134* Thu Jul 13 2006 Luke Macken <lmacken@redhat.com> 2.2.1-1
135- Update to 2.2.1
136- Remove unnecessary python-abi requirement
137
138* Sat Apr 22 2006 Gijs Hollestelle <gijs@gewis.nl> 2.2.0-1
139- Update to 2.2.0
140
141* Wed Feb 22 2006 Gijs Hollestelle <gijs@gewis.nl> 2.1.1-1
142- Update to 2.1.1 (Security fix)
143
144* Tue Nov  1 2005 Gijs Hollestelle <gijs@gewis.nl> 2.1.0-1
145- Updated to 2.1.0
146
147* Sat May 14 2005 Gijs Hollestelle <gijs@gewis.nl> 2.0.0-2
148- Added dist tag
149
150* Sun May  8 2005 Gijs Hollestelle <gijs@gewis.nl> 2.0.0-1
151- Updated to 2.0.0 final
152- Updated python-cherrypy-tutorial-doc.patch to match new version
153
154* Wed Apr  6 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 2.0.0-0.2.b
155- Removed CFLAGS
156
157* Wed Mar 23 2005 Gijs Hollestelle <gijs[AT]gewis.nl> 2.0.0-0.1.b
158- Initial Fedora Package
Note: See TracBrowser for help on using the repository browser.