source: projects/specs/trunk/p/pyparted/pyparted-vl.spec @ 6580

Revision 6580, 4.4 KB checked in by Takemikaduchi, 12 years ago (diff)

parted-3.1 & gparted-0.13.0

Line 
1%define python_sitearch %(python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)')
2Summary: Python module for GNU parted
3Summary(ja): parted の python モジュール
4Name:    pyparted
5Version: 3.8
6Release: 3%{?_dist_release}
7License: GPLv2+
8Group:   System Environment/Libraries
9
10Source0: https://fedorahosted.org/releases/p/y/%{name}/%{name}-%{version}.tar.gz
11BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
12
13BuildRequires: python-devel, parted-devel >= 3.0
14Requires: parted >= 3.0
15
16%description
17Python modules for the parted library.  It is used for manipulation
18partition tables.
19
20%prep
21%setup -q
22
23%build
24export CFLAGS="%{optflags}"
25%__make %{?_smp_mflags}
26
27%install
28rm -rf $RPM_BUILD_ROOT
29%__make install DESTDIR=$RPM_BUILD_ROOT
30
31%clean
32rm -rf $RPM_BUILD_ROOT
33
34%files
35%defattr(-,root,root,-)
36%doc README COPYING AUTHORS ChangeLog
37%{python_sitearch}/parted
38%{python_sitearch}/*.egg-info
39%{python_sitearch}/*.so
40
41%changelog
42* Sun Jul 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8-3
43- rebuild with parted-3.1
44
45* Sat Feb 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8-2
46- rebuild with python-2.7.2
47
48* Fri Jan 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8-1
49- new upstream release
50
51* Sat Dec 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.9-3
52- rebuild with parted-2.3
53
54* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.8.9-2
55- rebuilt with python-2.6.4
56
57* Tue Aug 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.9-1
58- new upstream release
59- build with parted-1.8.8
60
61* Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> 1.8.1-4vl5
62- rebuilt with python-2.5.2
63- added pyexeclib macro
64- applied new versioning policy and spec in utf-8
65
66* Wed Dec 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.1-3vl1
67- rebuilt for VineSeed with parted-1.8.1 and python-2.4
68
69* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 1.8.1-3
70- rebuild for python 2.5
71
72* Tue Dec 05 2006 David Cantrell <dcantrell@redhat.com> - 1.8.1-2
73- Rebuild for GNU parted-1.8.1
74
75* Thu Nov 30 2006 David Cantrell <dcantrell@redhat.com> - 1.8.1-1
76- Determine Python version to use in %%build so the source RPM is more
77  easily moved between distribution releases.
78
79* Fri Nov 17 2006 David Cantrell <dcantrell@redhat.com> - 1.8.0-1
80- Bump version to 1.8.0 and require parted >= 1.8.0
81- Remove python-abi Requires line since rpm handles that automatically
82
83* Wed Aug 30 2006 David Cantrell <dcantrell@redhat.com> - 1.7.3-1
84- Include parted/constraint.h in required header files
85
86* Wed Aug 30 2006 David Cantrell <dcantrell@redhat.com> - 1.7.2-2
87- Require parted-1.7.1 or higher
88
89* Tue Jul 25 2006 David Cantrell <dcantrell@redhat.com> - 1.7.2-1
90- Add HPSERVICE, PALO, PREP, and MSFT_RESERVED to partition types list
91
92* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.7.1-1.1
93- rebuild
94
95* Sun May 28 2006 David Cantrell <dcantrell@redhat.com> - 1.7.1-1
96- Bump version to 1.7.1 and require parted >= 1.7.1
97
98* Fri May 19 2006 David Cantrell <dcantrell@redhat.com> - 1.7.0-1
99- Bump version to 1.7.0 and require parted >= 1.7.0
100
101* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
102- rebuilt
103
104* Fri Nov 11 2005 Peter Jones <pjones@redhat.com> - 1.6.10-1
105- rebuild for new parted.
106- add debugging options for make so debuginfo isn't useless
107
108* Wed Nov  9 2005 Jeremy Katz <katzj@redhat.com> - 1.6.9-5
109- rebuild for new parted
110
111* Wed Aug 31 2005 Chris Lumens <clumens@redhat.com> 1.6.9-4
112- Rebuilt for new parted library.
113
114* Wed Mar 16 2005 Chris Lumens <clumens@redhat.com> 1.6.9-3
115- Updated for gcc4 and python2.4.  Fixed build warnings.
116
117* Tue Dec 14 2004 Jeremy Katz <katzj@redhat.com> - 1.6.9-2
118- add support for sx8 devices
119
120* Mon Nov  8 2004 Jeremy Katz <katzj@redhat.com> - 1.6.8-3
121- rebuild for python 2.4
122
123* Mon Oct 11 2004 Warren Togami <wtogami@redhat.com> - 1.6.8-2
124- #135100 req python-abi (Robert Scheck)
125
126* Tue Aug 17 2004 Jeremy Katz <katzj@redhat.com> - 1.6.8-1
127- update for new parted ABI
128  - device -> heads, sectors, cylinders now refer to the bios geometry
129- require parted >= 1.6.12
130
131* Thu Jul 22 2004 Jeremy Katz <katzj@redhat.com> - 1.6.7-3
132- build on ppc64 again
133
134* Thu May 13 2004 Jeremy Katz <katzj@redhat.com> - 1.6.7-1
135- fix build for newer versions of gcc (fix from Jeff Law)
136
137* Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> 1.6.6-2
138- fix PARTITION_PROTECTED definition (#118451)
139
140* Fri Mar 12 2004 Jeremy Katz <katzj@redhat.com>
141- Initial build split out into separate source from the parted package.
142- Don't build on ppc64 right now due to parted build problems (#118183)
Note: See TracBrowser for help on using the repository browser.