source: projects/specs/trunk/p/pyparted/pyparted-vl.spec @ 5701

Revision 5701, 4.3 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1%define python_sitearch %(python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)')
2Summary: Python module for GNU parted
3Summary(ja): parted の python モジュール
4Name:    pyparted
5Version: 3.8
6Release: 2%{?_dist_release}
7License: GPLv2+
8Group:   System Environment/Libraries
9
10Source0: https://fedorahosted.org/releases/p/y/%{name}/%{name}-%{version}.tar.gz
11BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
12
13BuildRequires: python-devel, parted-devel >= 3.0
14Requires: parted >= 3.0
15
16%description
17Python modules for the parted library.  It is used for manipulation
18partition tables.
19
20%prep
21%setup -q
22
23%build
24export CFLAGS="%{optflags}"
25%__make %{?_smp_mflags}
26
27%install
28rm -rf $RPM_BUILD_ROOT
29%__make install DESTDIR=$RPM_BUILD_ROOT
30
31%clean
32rm -rf $RPM_BUILD_ROOT
33
34%files
35%defattr(-,root,root,-)
36%doc README COPYING AUTHORS ChangeLog
37%{python_sitearch}/parted
38%{python_sitearch}/*.egg-info
39%{python_sitearch}/*.so
40
41%changelog
42* Sat Feb 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8-2
43- rebuild with python-2.7.2
44
45* Fri Jan 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8-1
46- new upstream release
47
48* Sat Dec 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.9-3
49- rebuild with parted-2.3
50
51* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.8.9-2
52- rebuilt with python-2.6.4
53
54* Tue Aug 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.9-1
55- new upstream release
56- build with parted-1.8.8
57
58* Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> 1.8.1-4vl5
59- rebuilt with python-2.5.2
60- added pyexeclib macro
61- applied new versioning policy and spec in utf-8
62
63* Wed Dec 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.1-3vl1
64- rebuilt for VineSeed with parted-1.8.1 and python-2.4
65
66* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 1.8.1-3
67- rebuild for python 2.5
68
69* Tue Dec 05 2006 David Cantrell <dcantrell@redhat.com> - 1.8.1-2
70- Rebuild for GNU parted-1.8.1
71
72* Thu Nov 30 2006 David Cantrell <dcantrell@redhat.com> - 1.8.1-1
73- Determine Python version to use in %%build so the source RPM is more
74  easily moved between distribution releases.
75
76* Fri Nov 17 2006 David Cantrell <dcantrell@redhat.com> - 1.8.0-1
77- Bump version to 1.8.0 and require parted >= 1.8.0
78- Remove python-abi Requires line since rpm handles that automatically
79
80* Wed Aug 30 2006 David Cantrell <dcantrell@redhat.com> - 1.7.3-1
81- Include parted/constraint.h in required header files
82
83* Wed Aug 30 2006 David Cantrell <dcantrell@redhat.com> - 1.7.2-2
84- Require parted-1.7.1 or higher
85
86* Tue Jul 25 2006 David Cantrell <dcantrell@redhat.com> - 1.7.2-1
87- Add HPSERVICE, PALO, PREP, and MSFT_RESERVED to partition types list
88
89* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.7.1-1.1
90- rebuild
91
92* Sun May 28 2006 David Cantrell <dcantrell@redhat.com> - 1.7.1-1
93- Bump version to 1.7.1 and require parted >= 1.7.1
94
95* Fri May 19 2006 David Cantrell <dcantrell@redhat.com> - 1.7.0-1
96- Bump version to 1.7.0 and require parted >= 1.7.0
97
98* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
99- rebuilt
100
101* Fri Nov 11 2005 Peter Jones <pjones@redhat.com> - 1.6.10-1
102- rebuild for new parted.
103- add debugging options for make so debuginfo isn't useless
104
105* Wed Nov  9 2005 Jeremy Katz <katzj@redhat.com> - 1.6.9-5
106- rebuild for new parted
107
108* Wed Aug 31 2005 Chris Lumens <clumens@redhat.com> 1.6.9-4
109- Rebuilt for new parted library.
110
111* Wed Mar 16 2005 Chris Lumens <clumens@redhat.com> 1.6.9-3
112- Updated for gcc4 and python2.4.  Fixed build warnings.
113
114* Tue Dec 14 2004 Jeremy Katz <katzj@redhat.com> - 1.6.9-2
115- add support for sx8 devices
116
117* Mon Nov  8 2004 Jeremy Katz <katzj@redhat.com> - 1.6.8-3
118- rebuild for python 2.4
119
120* Mon Oct 11 2004 Warren Togami <wtogami@redhat.com> - 1.6.8-2
121- #135100 req python-abi (Robert Scheck)
122
123* Tue Aug 17 2004 Jeremy Katz <katzj@redhat.com> - 1.6.8-1
124- update for new parted ABI
125  - device -> heads, sectors, cylinders now refer to the bios geometry
126- require parted >= 1.6.12
127
128* Thu Jul 22 2004 Jeremy Katz <katzj@redhat.com> - 1.6.7-3
129- build on ppc64 again
130
131* Thu May 13 2004 Jeremy Katz <katzj@redhat.com> - 1.6.7-1
132- fix build for newer versions of gcc (fix from Jeff Law)
133
134* Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> 1.6.6-2
135- fix PARTITION_PROTECTED definition (#118451)
136
137* Fri Mar 12 2004 Jeremy Katz <katzj@redhat.com>
138- Initial build split out into separate source from the parted package.
139- Don't build on ppc64 right now due to parted build problems (#118183)
Note: See TracBrowser for help on using the repository browser.