source: projects/specs/trunk/p/pyparted/pyparted-vl.spec @ 12469

Revision 12469, 5.8 KB checked in by tomop, 4 years ago (diff)

python-3.8.5 and related packages.

Line 
1Summary:        Python module for GNU parted
2Summary(ja):    parted の python モジュール
3Name:           pyparted
4Version:        3.11.4
5Release:        1%{?_dist_release}
6Group:          programming
7Vendor:         Project Vine
8Distribution:   Vine Linux
9
10License:        GPLv2+
11URL:            https://github.com/dcantrell/pyparted
12Source0:        https://github.com/dcantrell/pyparted/releases/download/v%{version}/%{name}-%{version}.tar.gz
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16BuildRequires: python-rpm-macros
17
18BuildRequires: python-devel
19BuildRequires: python-setuptools
20BuildRequires: python2-rpm-macros
21BuildRequires: python-six
22
23BuildRequires: python3-devel
24BuildRequires: python3-setuptools
25BuildRequires: python3-rpm-macros
26BuildRequires: python3-six
27
28BuildRequires: parted-devel >= 3.2
29
30Requires: parted >= 3.2
31
32%description
33Python modules for the parted library.  It is used for manipulation
34partition tables.
35
36%package -n python3-pyparted
37Summary: Python 3 module for GNU parted
38Summary(ja): parted の python モジュール
39Group:   System Environment/Libraries
40
41%description -n python3-pyparted
42Python 3 modules for the parted library.  It is used for manipulation
43partition tables.
44
45%prep
46%setup -q
47
48rm -rf %{py3dir}
49mkdir -p %{py3dir}
50cp -a . %{py3dir}
51
52%build
53PYTHON=python make %{?_smp_mflags}
54
55pushd %{py3dir}
56PYTHON=python3 make %{?_smp_mflags}
57popd
58
59%install
60rm -rf $RPM_BUILD_ROOT
61PYTHON=python %__make install DESTDIR=$RPM_BUILD_ROOT
62
63pushd %{py3dir}
64PYTHON=python3 %__make install DESTDIR=$RPM_BUILD_ROOT
65popd
66
67%check
68PYTHON=python make test
69
70pushd %{py3dir}
71PYTHON=python3 make test
72popd
73
74%clean
75rm -rf $RPM_BUILD_ROOT
76
77%files
78%defattr(-,root,root,-)
79%license COPYING
80%doc AUTHORS NEWS README TODO
81%{python_sitearch}/parted
82%{python_sitearch}/*.egg-info
83%{python_sitearch}/*.so
84
85%files -n python3-pyparted
86%license COPYING
87%doc AUTHORS NEWS README TODO
88%{python3_sitearch}/_ped.*.so
89%{python3_sitearch}/parted
90%{python3_sitearch}/%{name}-%{version}-*.egg-info
91
92%changelog
93* Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.11.4-1
94- new upstream release: the latest version with python2 support.
95
96* Mon Sep 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.11.2-1
97- new upstream release.
98- added python3 support.
99- imported Patch0 from upstream.
100
101* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8-4
102- rebuild with VineSeed environment
103
104* Sun Jul 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8-3
105- rebuild with parted-3.1
106
107* Sat Feb 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8-2
108- rebuild with python-2.7.2
109
110* Fri Jan 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8-1
111- new upstream release
112
113* Sat Dec 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.9-3
114- rebuild with parted-2.3
115
116* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.8.9-2
117- rebuilt with python-2.6.4
118
119* Tue Aug 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.9-1
120- new upstream release
121- build with parted-1.8.8
122
123* Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> 1.8.1-4vl5
124- rebuilt with python-2.5.2
125- added pyexeclib macro
126- applied new versioning policy and spec in utf-8
127
128* Wed Dec 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.1-3vl1
129- rebuilt for VineSeed with parted-1.8.1 and python-2.4
130
131* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 1.8.1-3
132- rebuild for python 2.5
133
134* Tue Dec 05 2006 David Cantrell <dcantrell@redhat.com> - 1.8.1-2
135- Rebuild for GNU parted-1.8.1
136
137* Thu Nov 30 2006 David Cantrell <dcantrell@redhat.com> - 1.8.1-1
138- Determine Python version to use in %%build so the source RPM is more
139  easily moved between distribution releases.
140
141* Fri Nov 17 2006 David Cantrell <dcantrell@redhat.com> - 1.8.0-1
142- Bump version to 1.8.0 and require parted >= 1.8.0
143- Remove python-abi Requires line since rpm handles that automatically
144
145* Wed Aug 30 2006 David Cantrell <dcantrell@redhat.com> - 1.7.3-1
146- Include parted/constraint.h in required header files
147
148* Wed Aug 30 2006 David Cantrell <dcantrell@redhat.com> - 1.7.2-2
149- Require parted-1.7.1 or higher
150
151* Tue Jul 25 2006 David Cantrell <dcantrell@redhat.com> - 1.7.2-1
152- Add HPSERVICE, PALO, PREP, and MSFT_RESERVED to partition types list
153
154* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.7.1-1.1
155- rebuild
156
157* Sun May 28 2006 David Cantrell <dcantrell@redhat.com> - 1.7.1-1
158- Bump version to 1.7.1 and require parted >= 1.7.1
159
160* Fri May 19 2006 David Cantrell <dcantrell@redhat.com> - 1.7.0-1
161- Bump version to 1.7.0 and require parted >= 1.7.0
162
163* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
164- rebuilt
165
166* Fri Nov 11 2005 Peter Jones <pjones@redhat.com> - 1.6.10-1
167- rebuild for new parted.
168- add debugging options for make so debuginfo isn't useless
169
170* Wed Nov  9 2005 Jeremy Katz <katzj@redhat.com> - 1.6.9-5
171- rebuild for new parted
172
173* Wed Aug 31 2005 Chris Lumens <clumens@redhat.com> 1.6.9-4
174- Rebuilt for new parted library.
175
176* Wed Mar 16 2005 Chris Lumens <clumens@redhat.com> 1.6.9-3
177- Updated for gcc4 and python2.4.  Fixed build warnings.
178
179* Tue Dec 14 2004 Jeremy Katz <katzj@redhat.com> - 1.6.9-2
180- add support for sx8 devices
181
182* Mon Nov  8 2004 Jeremy Katz <katzj@redhat.com> - 1.6.8-3
183- rebuild for python 2.4
184
185* Mon Oct 11 2004 Warren Togami <wtogami@redhat.com> - 1.6.8-2
186- #135100 req python-abi (Robert Scheck)
187
188* Tue Aug 17 2004 Jeremy Katz <katzj@redhat.com> - 1.6.8-1
189- update for new parted ABI
190  - device -> heads, sectors, cylinders now refer to the bios geometry
191- require parted >= 1.6.12
192
193* Thu Jul 22 2004 Jeremy Katz <katzj@redhat.com> - 1.6.7-3
194- build on ppc64 again
195
196* Thu May 13 2004 Jeremy Katz <katzj@redhat.com> - 1.6.7-1
197- fix build for newer versions of gcc (fix from Jeff Law)
198
199* Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> 1.6.6-2
200- fix PARTITION_PROTECTED definition (#118451)
201
202* Fri Mar 12 2004 Jeremy Katz <katzj@redhat.com>
203- Initial build split out into separate source from the parted package.
204- Don't build on ppc64 right now due to parted build problems (#118183)
Note: See TracBrowser for help on using the repository browser.