source: projects/specs/trunk/p/pyparted/pyparted-vl.spec @ 12218

Revision 12218, 5.7 KB checked in by tomop, 5 years ago (diff)

pyparted-3.11.2-1

Line 
1Summary:        Python module for GNU parted
2Summary(ja):    parted の python モジュール
3Name:           pyparted
4Version:        3.11.2
5Release:        1%{?_dist_release}
6License:        GPLv2+
7Group:          System Environment/Libraries
8
9Vendor:         Project Vine
10Distribution:   Vine Linux
11
12Source0: https://fedorahosted.org/releases/p/y/%{name}/%{name}-%{version}.tar.gz
13BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14
15# https://github.com/dcantrell/pyparted/issues/57
16Patch0: use-decimal-instead-of-float.patch
17
18BuildRequires: python-devel
19BuildRequires: python-setuptools
20BuildRequires: python-rpm-macros
21BuildRequires: python-six
22
23BuildRequires: python3-devel
24BuildRequires: python3-setuptools
25BuildRequires: python3-rpm-macros
26BuildRequires: python3-six
27
28BuildRequires: parted-devel >= 3.2
29
30Requires: parted >= 3.2
31
32%description
33Python modules for the parted library.  It is used for manipulation
34partition tables.
35
36%package -n python3-pyparted
37Summary: Python 3 module for GNU parted
38Summary(ja): parted の python モジュール
39Group:   System Environment/Libraries
40
41%description -n python3-pyparted
42Python 3 modules for the parted library.  It is used for manipulation
43partition tables.
44
45%prep
46%setup -q
47%patch0 -p1
48
49rm -rf %{py3dir}
50mkdir -p %{py3dir}
51cp -a . %{py3dir}
52
53%build
54PYTHON=python make %{?_smp_mflags}
55
56pushd %{py3dir}
57PYTHON=python3 make %{?_smp_mflags}
58popd
59
60%install
61rm -rf $RPM_BUILD_ROOT
62PYTHON=python %__make install DESTDIR=$RPM_BUILD_ROOT
63
64pushd %{py3dir}
65PYTHON=python3 %__make install DESTDIR=$RPM_BUILD_ROOT
66popd
67
68%check
69PYTHON=python make test
70
71pushd %{py3dir}
72PYTHON=python3 make test
73popd
74
75%clean
76rm -rf $RPM_BUILD_ROOT
77
78%files
79%defattr(-,root,root,-)
80%license COPYING
81%doc AUTHORS NEWS README TODO
82%{python_sitearch}/parted
83%{python_sitearch}/*.egg-info
84%{python_sitearch}/*.so
85
86%files -n python3-pyparted
87%license COPYING
88%doc AUTHORS NEWS README TODO
89%{python3_sitearch}/_ped.*.so
90%{python3_sitearch}/parted
91%{python3_sitearch}/%{name}-%{version}-*.egg-info
92
93%changelog
94* Mon Sep 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.11.2-1
95- new upstream release.
96- added python3 support.
97- imported Patch0 from upstream.
98
99* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8-4
100- rebuild with VineSeed environment
101
102* Sun Jul 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8-3
103- rebuild with parted-3.1
104
105* Sat Feb 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8-2
106- rebuild with python-2.7.2
107
108* Fri Jan 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8-1
109- new upstream release
110
111* Sat Dec 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.9-3
112- rebuild with parted-2.3
113
114* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.8.9-2
115- rebuilt with python-2.6.4
116
117* Tue Aug 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.9-1
118- new upstream release
119- build with parted-1.8.8
120
121* Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> 1.8.1-4vl5
122- rebuilt with python-2.5.2
123- added pyexeclib macro
124- applied new versioning policy and spec in utf-8
125
126* Wed Dec 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.1-3vl1
127- rebuilt for VineSeed with parted-1.8.1 and python-2.4
128
129* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 1.8.1-3
130- rebuild for python 2.5
131
132* Tue Dec 05 2006 David Cantrell <dcantrell@redhat.com> - 1.8.1-2
133- Rebuild for GNU parted-1.8.1
134
135* Thu Nov 30 2006 David Cantrell <dcantrell@redhat.com> - 1.8.1-1
136- Determine Python version to use in %%build so the source RPM is more
137  easily moved between distribution releases.
138
139* Fri Nov 17 2006 David Cantrell <dcantrell@redhat.com> - 1.8.0-1
140- Bump version to 1.8.0 and require parted >= 1.8.0
141- Remove python-abi Requires line since rpm handles that automatically
142
143* Wed Aug 30 2006 David Cantrell <dcantrell@redhat.com> - 1.7.3-1
144- Include parted/constraint.h in required header files
145
146* Wed Aug 30 2006 David Cantrell <dcantrell@redhat.com> - 1.7.2-2
147- Require parted-1.7.1 or higher
148
149* Tue Jul 25 2006 David Cantrell <dcantrell@redhat.com> - 1.7.2-1
150- Add HPSERVICE, PALO, PREP, and MSFT_RESERVED to partition types list
151
152* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.7.1-1.1
153- rebuild
154
155* Sun May 28 2006 David Cantrell <dcantrell@redhat.com> - 1.7.1-1
156- Bump version to 1.7.1 and require parted >= 1.7.1
157
158* Fri May 19 2006 David Cantrell <dcantrell@redhat.com> - 1.7.0-1
159- Bump version to 1.7.0 and require parted >= 1.7.0
160
161* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
162- rebuilt
163
164* Fri Nov 11 2005 Peter Jones <pjones@redhat.com> - 1.6.10-1
165- rebuild for new parted.
166- add debugging options for make so debuginfo isn't useless
167
168* Wed Nov  9 2005 Jeremy Katz <katzj@redhat.com> - 1.6.9-5
169- rebuild for new parted
170
171* Wed Aug 31 2005 Chris Lumens <clumens@redhat.com> 1.6.9-4
172- Rebuilt for new parted library.
173
174* Wed Mar 16 2005 Chris Lumens <clumens@redhat.com> 1.6.9-3
175- Updated for gcc4 and python2.4.  Fixed build warnings.
176
177* Tue Dec 14 2004 Jeremy Katz <katzj@redhat.com> - 1.6.9-2
178- add support for sx8 devices
179
180* Mon Nov  8 2004 Jeremy Katz <katzj@redhat.com> - 1.6.8-3
181- rebuild for python 2.4
182
183* Mon Oct 11 2004 Warren Togami <wtogami@redhat.com> - 1.6.8-2
184- #135100 req python-abi (Robert Scheck)
185
186* Tue Aug 17 2004 Jeremy Katz <katzj@redhat.com> - 1.6.8-1
187- update for new parted ABI
188  - device -> heads, sectors, cylinders now refer to the bios geometry
189- require parted >= 1.6.12
190
191* Thu Jul 22 2004 Jeremy Katz <katzj@redhat.com> - 1.6.7-3
192- build on ppc64 again
193
194* Thu May 13 2004 Jeremy Katz <katzj@redhat.com> - 1.6.7-1
195- fix build for newer versions of gcc (fix from Jeff Law)
196
197* Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> 1.6.6-2
198- fix PARTITION_PROTECTED definition (#118451)
199
200* Fri Mar 12 2004 Jeremy Katz <katzj@redhat.com>
201- Initial build split out into separate source from the parted package.
202- Don't build on ppc64 right now due to parted build problems (#118183)
Note: See TracBrowser for help on using the repository browser.