source: projects/specs/trunk/p/pylint/pylint-vl.spec @ 8154

Revision 8154, 6.4 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1Name:           pylint
2Version:        1.0.0
3Release:        1%{?_dist_release}
4Summary:        Analyzes Python code looking for bugs and signs of poor quality
5
6Group:          Development/Debuggers
7License:        GPLv2+
8URL:            http://www.logilab.org/projects/pylint
9Source0:        ftp://ftp.logilab.org/pub/pylint/pylint-%{version}.tar.gz
10BuildArch:      noarch
11BuildRoot:      %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
12
13BuildRequires:  python-devel python-setuptools python-unittest2
14BuildRequires:  python-logilab-astng >= 0.22.0
15Requires:       python-logilab-astng >= 0.22.0
16
17Vendor: Project Vine
18Distribution: Vine Linux
19
20%description
21Pylint is a python tool that checks if a module satisfy a coding standard.
22Pylint can be seen as another PyChecker since nearly all tests you can do
23with PyChecker can also be done with Pylint. But Pylint offers some more
24features, like checking line-code's length, checking if variable names are
25well-formed according to your coding standard, or checking if declared
26interfaces are truly implemented, and much more. The big advantage with
27Pylint is that it is highly configurable, customizable, and you can easily
28write a small plugin to add a personal feature.
29
30
31%package gui
32Summary:        Graphical Interface tool for Pylint
33Group:          Development/Debuggers
34Requires:       %{name} = %{version}-%{release}
35Requires:       tkinter
36
37%description gui
38This package provides a gui tool for pylint written in tkinter.
39
40
41%prep
42%setup -q
43
44%build
45%{__python} setup.py build
46
47
48%install
49rm -rf $RPM_BUILD_ROOT
50%{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
51rm -rf $RPM_BUILD_ROOT%{_python_sitelib}/pylint/test
52mkdir -pm 755 $RPM_BUILD_ROOT%{_mandir}/man1
53install -pm 644 man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1/
54
55%clean
56rm -rf $RPM_BUILD_ROOT
57
58
59%files
60%defattr(-,root,root,-)
61%doc README ChangeLog examples elisp COPYING
62%{python_sitelib}/pylint*
63%{_bindir}/*
64%{_mandir}/man?/*
65%exclude %{python_sitelib}/pylint/gui.py*
66%exclude %{_bindir}/pylint-gui
67
68%files gui
69%defattr(-,root,root,-)
70%doc COPYING
71%{python_sitelib}/pylint/gui.py*
72%{_bindir}/pylint-gui
73
74
75%changelog
76* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
77- new upstream release
78
79* Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.25.1-1
80- initial build for Vine Linux
81
82
83* Wed Mar 14 2012 Brian C. Lane <bcl@redhat.com> 0.25.1-1
84- Upstream 0.25.1
85
86* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.25.0-2
87- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
88
89* Fri Nov 18 2011 Brian C. Lane <bcl@redhat.com> - 0.25.0-1
90- Upstream 0.25.0
91
92* Fri Jul 29 2011 Brian C. Lane <bcl@redhat.com> - 0.24.0-1
93- Upstream 0.24.0
94
95* Mon Mar 28 2011 Brian C. Lane <bcl@redhat.com> - 0.23-0.1
96- Upstream 0.23.0
97- Add unit tests to spec
98
99* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.22.0-3
100- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
101
102* Mon Dec 06 2010 Brian C. Lane <bcl@redhat.com> - 0.22.0-2
103- Add version to requirement for python-logilab-astng so that updates will
104  work correctly.
105
106* Mon Nov 29 2010 Brian C. Lane <bcl@redhat.com> - 0.22.0-1
107- Upstream 0.22.0
108
109* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 0.21.1-2
110- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
111
112* Thu Jul 08 2010 Brian C. Lane <bcl@redhat.com> - 0.21.1-1
113- Upstream 0.21.1
114- Removed patch for 500272, fixed upstream - http://www.logilab.org/ticket/22962
115
116* Mon Apr 05 2010 Brian C. Lane <bcl@redhat.com> - 0.20.0-2
117- Added patch for bug 500272 (exception with --disable-msg-cat)
118
119* Fri Mar 26 2010 Brian C.Lane <bcl@redhat.com> - 0.20.0-1
120- Upstream 0.20.0
121- Added python-setuptools to BuildRequires
122
123* Sun Aug 30 2009 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.18.1-1
124- Upstream 0.18.1 (bugfixes and small enhancements)
125
126* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.18.0-2
127- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
128
129* Wed Jun 17 2009 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.18.0-1
130- Upstream 0.18.0 (bugfixes and minor feature updates)
131
132* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.16.0-2
133- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
134
135* Wed Jan 28 2009 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.16.0-1
136- Upstream 0.16.0
137
138* Tue Dec 30 2008 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.15.2-1
139- Upstream 0.15.2
140
141* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.14.0-2
142- Rebuild for Python 2.6
143
144* Thu Jan 17 2008 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.14.0-1
145- Upstream 0.14.0
146- Package the .egg-info files.
147
148* Mon Dec 24 2007 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.13.2-1
149- Upstream 0.13.2
150- Adjust license to a more precise version
151- Fix docs to be valid utf-8
152
153* Sun Apr 01 2007 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.13.1-1
154- Upstream 0.13.1
155
156* Sun Dec 17 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.12.2-1
157- Upstream 0.12.2
158- Add COPYING to -gui
159
160* Tue Sep 26 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.12.1-1
161- Upstream 0.12.1
162- Require the renamed python-logilab-astng
163
164* Mon May 01 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.11.0-0
165- Version 0.11.0
166
167* Sun Mar 12 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.10.0-1
168- Version 0.10.0
169
170* Thu Jan 12 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.9.0-1
171- Version 0.9.0
172- Add COPYING to docs
173
174* Sun Nov 13 2005 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.8.1-1
175- Version 0.8.1
176- Add dependency on python-astng
177- Drop artificial version requirement on python-logilab-common
178
179* Mon Jun 13 2005 Konstantin Ryabitsev <icon@linux.duke.edu> - 0.7.0-1
180- Version 0.7.0
181- No longer in the logilab subdir
182- Disttagging
183
184* Mon May 09 2005 Konstantin Ryabitsev <icon@linux.duke.edu> - 0.6.4-4
185- Install the pylint.1 manfile.
186- Add examples and elisp dirs to docs.
187
188* Thu May 05 2005 Konstantin Ryabitsev <icon@linux.duke.edu> - 0.6.4-3
189- Only doc the .txt files.
190- Don't buildrequire python-logilab-common
191- Fix paths.
192
193* Tue Apr 26 2005 Konstantin Ryabitsev <icon@linux.duke.edu> - 0.6.4-2
194- Ghost .pyo files.
195- Remove the test dir, as it doesn't do anything.
196- Separate the gui package, which depends on tkinter.
197- Don't own site-packages/logilab, which is owned by
198  python-logilab-common.
199
200* Fri Apr 22 2005 Konstantin Ryabitsev <icon@linux.duke.edu> - 0.6.4-1
201- Initial packaging.
Note: See TracBrowser for help on using the repository browser.