source: projects/specs/trunk/p/pygtk2/pygtk2-vl.spec @ 8154

Revision 8154, 9.0 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3%define buildglade %(pkg-config libglade-2.0 && echo 1 || echo 0)
4%define pyver %(python -c 'import sys;print(sys.version[0:3])')
5
6Summary: Python bindings for the GTK+ widget set.
7Summary(ja): GTK+ ウィジットセットの Python 実装
8Name: pygtk2
9Version: 2.24.0
10Release: 3%{?_dist_release}
11
12Group: Development/Languages
13License: LGPLv2
14Source: ftp://ftp.gnome.org/pub/GNOME/sources/pygtk/2.24/pygtk-%{version}.tar.bz2
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17
18Buildrequires: python-devel >= 2.5
19Buildrequires: libglade2-devel >= 2.5.0
20BuildRequires: gtk2-devel >= 2.16.0
21BuildRequires: pygobject-devel >= 2.16.0
22BuildRequires: pycairo-devel >= 1.8.2
23BuildRequires: python-numeric
24BuildRequires: docbook-style-xsl
25BuildRequires: libxslt
26Buildrequires: automake >= 1.6.3-5
27
28Requires: pygobject
29Requires: pycairo
30Requires: python-numeric
31
32Obsoletes: pygtk
33
34Vendor: Project Vine
35Distribution: Vine Linux
36
37%description
38PyGTK is an extension module for python that gives you access to the GTK+
39widget set.  Just about anything you can write in C with GTK+ you can write
40in python with PyGTK (within reason), but with all the benefits of python.
41
42%description -l ja
43PyGTK は GTK+ ウィジットセットへアクセス可能にする python の拡張モジュール
44です。 C で GTK+ を使用して書けることは、大概 python で PyGTK を利用して書
45けます。 python のおかげでもあります。
46
47%package libglade
48Summary: A wrapper for the libglade library for use with PyGTK
49Summary(ja): PyGTK を利用するための libglade ライブラリのラッパ
50Group: Development/Libraries
51Requires: pygtk2 = %{version}
52
53%description libglade
54This module contains a wrapper for the libglade library.  Libglade allows
55a program to construct its user interface from an XML description, which
56allows the programmer to keep the UI and program logic separate.
57
58%description -l ja libglade
59このモジュールは libglade ライブラリのためのラッパを含んでいます。libglade は
60プログラムのユーザインタフェースを XML 記述で構成することを可能にします。この
61ためプログラマは、プログラムの UI とロジックを分離させておくことができます。
62
63%package devel
64Summary: files needed to build wrappers for GTK+ addon libraries
65Summary(ja): GTK+ の追加ライブラリのラッパ作成に必要なファイル
66Group: Development/Libraries
67Requires: pygtk2 = %{version}
68Requires: pygobject-devel >= 2.12.0
69Requires: gtk2-devel
70
71%description devel
72This package contains files required to build wrappers for GTK+ addon
73libraries so that they interoperate with pygtk.
74
75%description -l ja devel
76このパッケージには GTK+ の追加ライブラリのラッパを作るために必要なファイルを含
77みます。これらは PyGTK との仲介をします。
78
79%prep
80%setup -q -n pygtk-%{version}
81
82%build
83[ -x /usr/bin/python%{pyver} ] && export PYTHON=/usr/bin/python%{pyver}
84#aclocal && automake && autoconf
85%configure --enable-thread --enable-numpy
86export tagname=CC
87make LIBTOOL=/usr/bin/libtool
88
89%install
90rm -rf $RPM_BUILD_ROOT
91export tagname=CC
92make LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT install
93find $RPM_BUILD_ROOT -name '*.la' -or -name '*.a' | xargs rm -f
94
95%clean
96rm -rf $RPM_BUILD_ROOT
97
98%files
99%defattr(-,root,root)
100%doc AUTHORS NEWS README MAPPING ChangeLog
101%doc examples
102
103%defattr(644, root, root, 755)
104%dir %{python_sitearch}/gtk-2.0
105%dir %{python_sitearch}/gtk-2.0/gtk
106%{python_sitearch}/gtk-2.0/gtk/*.py*
107%dir %{_libdir}/pygtk
108%dir %{_libdir}/pygtk/2.0
109%{_libdir}/pygtk/2.0/*
110
111%defattr(755, root, root, 755)
112%{_bindir}/pygtk-demo
113%{python_sitearch}/gtk-2.0/atk.so
114%{python_sitearch}/gtk-2.0/pango.so
115%{python_sitearch}/gtk-2.0/gtk/_gtk.so
116%{python_sitearch}/gtk-2.0/gtkunixprint.so
117%{python_sitearch}/gtk-2.0/pangocairo.so
118
119%if %{buildglade}
120%files libglade
121%defattr(755, root, root, 755)
122%{_libdir}/python?.?/site-packages/gtk-2.0/gtk/glade.so
123%endif
124
125%files devel
126%defattr(644, root, root, 755)
127%dir %{_includedir}/pygtk-2.0
128%dir %{_includedir}/pygtk-2.0/pygtk
129%{_includedir}/pygtk-2.0/pygtk/*.h
130%{_libdir}/pkgconfig/pygtk-2.0.pc
131%dir %{_datadir}/pygtk
132%dir %{_datadir}/pygtk/2.0
133%dir %{_datadir}/pygtk/2.0/defs
134%{_datadir}/pygtk/2.0/defs/*.defs
135%{_datadir}/pygtk/2.0/defs/pangocairo.override
136%{_datadir}/gtk-doc/html/pygtk
137%defattr(755, root, root, 755)
138%{_bindir}/pygtk-codegen-2.0
139
140%changelog
141* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-3
142- rebuild with VineSeed environment
143
144* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-2
145- rebuild with python-2.7.2
146
147* Tue Jun 07 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
148- new upstream release
149
150* Mon Feb 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.0-2
151- add Requires: gtk2-devel (-devel package)
152
153* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.0-1
154- new upstream release
155
156* Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-1
157- new upstream release
158
159* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
160- new upstream release
161- rebuild with python-2.6
162
163* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-1
164- new upstream release
165
166* Fri Jul 18 2008 Shu KONNO <owa@bg.wakwak.com> 2.12.1-2vl5
167- rebuilt with python-2.5.2
168
169* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-1vl5
170- rebuilt with python-2.4.5
171- used %%{?_dist_release} macro
172
173* Fri Jan 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-0vl1
174- new upstream release
175
176* Sun Nov 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.0-0vl1
177- new upstream release
178
179* Sat Jul  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.5-0vl1
180- new upstream release
181
182* Mon Apr 30 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.4-0vl2
183- added Requires pygobject-devel to devel package
184
185* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.4-0vl1
186- new upstream release
187- add Requires/BuildRequires pygobject,pycairo
188
189* Thu Jun 22 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.6-0vl1
190- new upstream release 2.8.6
191
192* Fri Jan 13 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.4-0vl1
193- new upstream release 2.8.4
194- added japanese summary and description
195
196* Tue Oct 18 2005 Shu KONNO <owa@bg.wakwak.com> 2.8.2-0vl1
197- new upstream release 2.8.2
198
199* Sat Oct  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.1-0vl1
200- new upstream release 2.8.1
201- added %clean sectioin
202
203* Sat Sep 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.0-0vl1
204- new upstream release 2.8.0
205
206* Mon Apr 04 2005 Shu KONNO <owa@bg.wakwak.com> 2.6.1-0vl1
207- new upstream release 2.6.1
208
209* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl2
210- rebuild with python-2.4.1-0vl1
211
212* Sun Dec 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
213- new upstream release
214
215* Sat Jun 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.0-1vl1
216- updated to 2.2.0
217
218* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.0.0-1vl4
219- rebuild with python-2.3.3-0vl1
220
221* Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 2.0.0-1vl3.1
222- rebuild with python-2.3.3-0vl0.3 (for TestPkg)
223
224* Thu Sep 18 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0-1vl3
225- added missing %%defattr
226
227* Wed Sep 17 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.0.0-1vl2
228- added Provides and Obsoletes pygtk
229
230* Tue Sep 16 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0-1vl1
231- new upstream release (based on Redhat Rawhide 2.0.0-1)
232  * Thu Aug  7 2003 Elliot Lee <sopwith@redhat.com> 1.99.16-10
233  - Fix libtool
234  * Fri Jul 18 2003 Jeremy Katz <katzj@redhat.com> 1.99.16-8
235  - part of the fixnew patch wasn't applied upstream, apply it (#99400)
236
237* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.99.14-0vl1
238- new upstream release
239- build for Vine Linux
240
241* Thu Oct 31 2002 Matt Wilson <msw@redhat.com>
242- rebuild for multilib
243- use %%configure
244
245* Fri Aug 30 2002 Matt Wilson <msw@redhat.com>
246- fix pixbuf leaks (#72137)
247- five more pixbuf leaks plugged
248
249* Wed Aug 28 2002 Jonathan Blandford <jrb@redhat.com>
250- remover Packager tag
251
252* Tue Aug 27 2002 Jonathan Blandford <jrb@redhat.com>
253- add binding for gdk_atom_intern
254
255* Mon Jul 29 2002 Matt Wilson <msw@redhat.com>
256- 0.99.12
257
258* Wed Jul 17 2002 Matt Wilson <msw@redhat.com>
259- new version from CVS
260
261* Thu Jun 27 2002 Tim Waugh <twaugh@redhat.com>
262- Fix bug #65770.
263
264* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
265- automated rebuild
266
267* Mon Jun 17 2002 Matt Wilson <msw@redhat.com>
268- new version from CVS
269
270* Sun May 26 2002 Tim Powers <timp@redhat.com>
271- automated rebuild
272
273* Wed May 22 2002 Jeremy Katz <katzj@redhat.com>
274- 1.99.10
275
276* Wed Feb 27 2002 Matt Wilson <msw@redhat.com>
277- 1.99.8
278
279* Mon Jan 28 2002 Matt Wilson <msw@redhat.com>
280- added atkmodule.so to file list
281
282* Thu Oct 18 2001 Matt Wilson <msw@redhat.com>
283- fix devel filelist to match new header location
284
285* Mon Oct 15 2001 Matt Wilson <msw@redhat.com>
286- get the headers from their new version-specific location
287
288* Thu Oct 11 2001 Matt Wilson <msw@redhat.com>
289- fixed typo in devel filelist
290- added macro that tests to see if we have libglade2, make the
291  filelist a condition of that
292- changed name to 'pygtk2' to avoid name conflict with pygtk
293
Note: See TracBrowser for help on using the repository browser.