source: projects/specs/trunk/p/pygtk2/pygtk2-vl.spec @ 9803

Revision 9803, 9.0 KB checked in by Takemikaduchi, 8 years ago (diff)

chromium, pciutils, mesa: new upstream release
others: fix spec file

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3%define buildglade %(pkg-config libglade-2.0 && echo 1 || echo 0)
4%define pyver %(python -c 'import sys;print(sys.version[0:3])')
5
6Summary: Python bindings for the GTK+ widget set.
7Summary(ja): GTK+ ウィジットセットの Python 実装
8Name: pygtk2
9Version: 2.24.0
10Release: 4%{?_dist_release}
11
12Group: Development/Languages
13License: LGPLv2
14Source: ftp://ftp.gnome.org/pub/GNOME/sources/pygtk/2.24/pygtk-%{version}.tar.bz2
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17
18Buildrequires: python-devel >= 2.5
19Buildrequires: libglade2-devel >= 2.5.0
20BuildRequires: gtk2-devel >= 2.16.0
21BuildRequires: pygobject-devel >= 2.16.0
22BuildRequires: pycairo-devel >= 1.8.2
23BuildRequires: python-numeric
24BuildRequires: docbook-style-xsl
25BuildRequires: libxslt
26Buildrequires: automake >= 1.6.3-5
27
28Requires: pygobject
29Requires: pycairo
30Requires: python-numeric
31
32Obsoletes: pygtk
33
34Vendor: Project Vine
35Distribution: Vine Linux
36
37%description
38PyGTK is an extension module for python that gives you access to the GTK+
39widget set.  Just about anything you can write in C with GTK+ you can write
40in python with PyGTK (within reason), but with all the benefits of python.
41
42%description -l ja
43PyGTK は GTK+ ウィジットセットへアクセス可能にする python の拡張モジュール
44です。 C で GTK+ を使用して書けることは、大概 python で PyGTK を利用して書
45けます。 python のおかげでもあります。
46
47%package libglade
48Summary: A wrapper for the libglade library for use with PyGTK
49Summary(ja): PyGTK を利用するための libglade ライブラリのラッパ
50Group: Development/Libraries
51Requires: pygtk2 = %{version}
52
53%description libglade
54This module contains a wrapper for the libglade library.  Libglade allows
55a program to construct its user interface from an XML description, which
56allows the programmer to keep the UI and program logic separate.
57
58%description -l ja libglade
59このモジュールは libglade ライブラリのためのラッパを含んでいます。libglade は
60プログラムのユーザインタフェースを XML 記述で構成することを可能にします。この
61ためプログラマは、プログラムの UI とロジックを分離させておくことができます。
62
63%package devel
64Summary: files needed to build wrappers for GTK+ addon libraries
65Summary(ja): GTK+ の追加ライブラリのラッパ作成に必要なファイル
66Group: Development/Libraries
67Requires: pygtk2 = %{version}
68Requires: pygobject-devel >= 2.12.0
69Requires: gtk2-devel
70
71%description devel
72This package contains files required to build wrappers for GTK+ addon
73libraries so that they interoperate with pygtk.
74
75%description -l ja devel
76このパッケージには GTK+ の追加ライブラリのラッパを作るために必要なファイルを含
77みます。これらは PyGTK との仲介をします。
78
79%prep
80%setup -q -n pygtk-%{version}
81
82%build
83[ -x /usr/bin/python%{pyver} ] && export PYTHON=/usr/bin/python%{pyver}
84#aclocal && automake && autoconf
85%configure --enable-thread --enable-numpy
86export tagname=CC
87make LIBTOOL=/usr/bin/libtool
88
89%install
90rm -rf $RPM_BUILD_ROOT
91export tagname=CC
92make LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT install
93find $RPM_BUILD_ROOT -name '*.la' -or -name '*.a' | xargs rm -f
94
95%clean
96rm -rf $RPM_BUILD_ROOT
97
98%files
99%defattr(-,root,root)
100%doc AUTHORS NEWS README MAPPING ChangeLog
101%doc examples
102%dir %{python_sitearch}/gtk-2.0
103%dir %{python_sitearch}/gtk-2.0/gtk
104%{python_sitearch}/gtk-2.0/gtk/*.py*
105%dir %{_libdir}/pygtk
106%dir %{_libdir}/pygtk/2.0
107%{_libdir}/pygtk/2.0/*
108%{_bindir}/pygtk-demo
109%{python_sitearch}/gtk-2.0/atk.so
110%{python_sitearch}/gtk-2.0/pango.so
111%{python_sitearch}/gtk-2.0/gtk/_gtk.so
112%{python_sitearch}/gtk-2.0/gtkunixprint.so
113%{python_sitearch}/gtk-2.0/pangocairo.so
114
115%if %{buildglade}
116%files libglade
117%defattr(-,root,root,-)
118%{_libdir}/python?.?/site-packages/gtk-2.0/gtk/glade.so
119%endif
120
121%files devel
122%defattr(-,root,root,-)
123%dir %{_includedir}/pygtk-2.0
124%dir %{_includedir}/pygtk-2.0/pygtk
125%{_includedir}/pygtk-2.0/pygtk/*.h
126%{_libdir}/pkgconfig/pygtk-2.0.pc
127%dir %{_datadir}/pygtk
128%dir %{_datadir}/pygtk/2.0
129%dir %{_datadir}/pygtk/2.0/defs
130%{_datadir}/pygtk/2.0/defs/*.defs
131%{_datadir}/pygtk/2.0/defs/pangocairo.override
132%{_datadir}/gtk-doc/html/pygtk
133%{_bindir}/pygtk-codegen-2.0
134
135%changelog
136* Thu Nov 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-4
137- fix spec file
138
139* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-3
140- rebuild with VineSeed environment
141
142* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-2
143- rebuild with python-2.7.2
144
145* Tue Jun 07 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
146- new upstream release
147
148* Mon Feb 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.0-2
149- add Requires: gtk2-devel (-devel package)
150
151* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.0-1
152- new upstream release
153
154* Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-1
155- new upstream release
156
157* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
158- new upstream release
159- rebuild with python-2.6
160
161* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-1
162- new upstream release
163
164* Fri Jul 18 2008 Shu KONNO <owa@bg.wakwak.com> 2.12.1-2vl5
165- rebuilt with python-2.5.2
166
167* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-1vl5
168- rebuilt with python-2.4.5
169- used %%{?_dist_release} macro
170
171* Fri Jan 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-0vl1
172- new upstream release
173
174* Sun Nov 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.0-0vl1
175- new upstream release
176
177* Sat Jul  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.5-0vl1
178- new upstream release
179
180* Mon Apr 30 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.4-0vl2
181- added Requires pygobject-devel to devel package
182
183* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.4-0vl1
184- new upstream release
185- add Requires/BuildRequires pygobject,pycairo
186
187* Thu Jun 22 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.6-0vl1
188- new upstream release 2.8.6
189
190* Fri Jan 13 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.4-0vl1
191- new upstream release 2.8.4
192- added japanese summary and description
193
194* Tue Oct 18 2005 Shu KONNO <owa@bg.wakwak.com> 2.8.2-0vl1
195- new upstream release 2.8.2
196
197* Sat Oct  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.1-0vl1
198- new upstream release 2.8.1
199- added %clean sectioin
200
201* Sat Sep 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.0-0vl1
202- new upstream release 2.8.0
203
204* Mon Apr 04 2005 Shu KONNO <owa@bg.wakwak.com> 2.6.1-0vl1
205- new upstream release 2.6.1
206
207* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl2
208- rebuild with python-2.4.1-0vl1
209
210* Sun Dec 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
211- new upstream release
212
213* Sat Jun 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.0-1vl1
214- updated to 2.2.0
215
216* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.0.0-1vl4
217- rebuild with python-2.3.3-0vl1
218
219* Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 2.0.0-1vl3.1
220- rebuild with python-2.3.3-0vl0.3 (for TestPkg)
221
222* Thu Sep 18 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0-1vl3
223- added missing %%defattr
224
225* Wed Sep 17 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.0.0-1vl2
226- added Provides and Obsoletes pygtk
227
228* Tue Sep 16 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0-1vl1
229- new upstream release (based on Redhat Rawhide 2.0.0-1)
230  * Thu Aug  7 2003 Elliot Lee <sopwith@redhat.com> 1.99.16-10
231  - Fix libtool
232  * Fri Jul 18 2003 Jeremy Katz <katzj@redhat.com> 1.99.16-8
233  - part of the fixnew patch wasn't applied upstream, apply it (#99400)
234
235* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.99.14-0vl1
236- new upstream release
237- build for Vine Linux
238
239* Thu Oct 31 2002 Matt Wilson <msw@redhat.com>
240- rebuild for multilib
241- use %%configure
242
243* Fri Aug 30 2002 Matt Wilson <msw@redhat.com>
244- fix pixbuf leaks (#72137)
245- five more pixbuf leaks plugged
246
247* Wed Aug 28 2002 Jonathan Blandford <jrb@redhat.com>
248- remover Packager tag
249
250* Tue Aug 27 2002 Jonathan Blandford <jrb@redhat.com>
251- add binding for gdk_atom_intern
252
253* Mon Jul 29 2002 Matt Wilson <msw@redhat.com>
254- 0.99.12
255
256* Wed Jul 17 2002 Matt Wilson <msw@redhat.com>
257- new version from CVS
258
259* Thu Jun 27 2002 Tim Waugh <twaugh@redhat.com>
260- Fix bug #65770.
261
262* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
263- automated rebuild
264
265* Mon Jun 17 2002 Matt Wilson <msw@redhat.com>
266- new version from CVS
267
268* Sun May 26 2002 Tim Powers <timp@redhat.com>
269- automated rebuild
270
271* Wed May 22 2002 Jeremy Katz <katzj@redhat.com>
272- 1.99.10
273
274* Wed Feb 27 2002 Matt Wilson <msw@redhat.com>
275- 1.99.8
276
277* Mon Jan 28 2002 Matt Wilson <msw@redhat.com>
278- added atkmodule.so to file list
279
280* Thu Oct 18 2001 Matt Wilson <msw@redhat.com>
281- fix devel filelist to match new header location
282
283* Mon Oct 15 2001 Matt Wilson <msw@redhat.com>
284- get the headers from their new version-specific location
285
286* Thu Oct 11 2001 Matt Wilson <msw@redhat.com>
287- fixed typo in devel filelist
288- added macro that tests to see if we have libglade2, make the
289  filelist a condition of that
290- changed name to 'pygtk2' to avoid name conflict with pygtk
291
Note: See TracBrowser for help on using the repository browser.