source: projects/specs/trunk/p/pygtk2/pygtk2-vl.spec @ 521

Revision 521, 8.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3%define buildglade %(pkg-config libglade-2.0 && echo 1 || echo 0)
4%define pyver %(python -c 'import sys;print(sys.version[0:3])')
5
6Summary: Python bindings for the GTK+ widget set.
7Summary(ja): GTK+ ウィジットセットの Python 実装
8Name: pygtk2
9Version: 2.16.0
10Release: 1%{?_dist_release}
11License: LGPL (version 2.1)
12Group: Development/Languages
13Source: ftp://ftp.gnome.org/pub/GNOME/sources/pygtk/2.14/pygtk-%{version}.tar.bz2
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16
17Requires: pygobject
18Requires: pycairo
19Requires: python-numeric
20
21Buildrequires: python-devel >= 2.5
22Buildrequires: libglade2-devel >= 2.5.0
23BuildRequires: gtk2-devel >= 2.16.0
24BuildRequires: pygobject-devel >= 2.16.0
25BuildRequires: pycairo-devel >= 1.8.2
26BuildRequires: python-numeric
27BuildRequires: docbook-style-xsl
28BuildRequires: libxslt
29Buildrequires: automake >= 1.6.3-5
30
31Obsoletes: pygtk
32
33%description
34PyGTK is an extension module for python that gives you access to the GTK+
35widget set.  Just about anything you can write in C with GTK+ you can write
36in python with PyGTK (within reason), but with all the benefits of python.
37
38%description -l ja
39PyGTK は GTK+ ウィジットセットへアクセス可能にする python の拡張モジュール
40です。 C で GTK+ を使用して書けることは、大概 python で PyGTK を利用して書
41けます。 python のおかげでもあります。
42
43%package libglade
44Summary: A wrapper for the libglade library for use with PyGTK
45Summary(ja): PyGTK を利用するための libglade ライブラリのラッパ
46Group: Development/Libraries
47Requires: pygtk2 = %{version}
48
49%description libglade
50This module contains a wrapper for the libglade library.  Libglade allows
51a program to construct its user interface from an XML description, which
52allows the programmer to keep the UI and program logic separate.
53
54%description -l ja libglade
55このモジュールは libglade ライブラリのためのラッパを含んでいます。libglade は
56プログラムのユーザインタフェースを XML 記述で構成することを可能にします。この
57ためプログラマは、プログラムの UI とロジックを分離させておくことができます。
58
59%package devel
60Summary: files needed to build wrappers for GTK+ addon libraries
61Summary(ja): GTK+ の追加ライブラリのラッパ作成に必要なファイル
62Group: Development/Libraries
63Requires: pygtk2 = %{version}
64Requires: pygobject-devel >= 2.12.0
65
66%description devel
67This package contains files required to build wrappers for GTK+ addon
68libraries so that they interoperate with pygtk.
69
70%description -l ja devel
71このパッケージには GTK+ の追加ライブラリのラッパを作るために必要なファイルを含
72みます。これらは PyGTK との仲介をします。
73
74%prep
75%setup -q -n pygtk-%{version}
76
77%build
78[ -x /usr/bin/python%{pyver} ] && export PYTHON=/usr/bin/python%{pyver}
79#aclocal && automake && autoconf
80%configure --enable-thread --enable-numpy
81export tagname=CC
82make LIBTOOL=/usr/bin/libtool
83
84%install
85rm -rf $RPM_BUILD_ROOT
86export tagname=CC
87make LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT install
88find $RPM_BUILD_ROOT -name '*.la' -or -name '*.a' -exec rm {} \;
89
90%clean
91rm -rf $RPM_BUILD_ROOT
92
93%files
94%defattr(-,root,root)
95%doc AUTHORS NEWS README MAPPING ChangeLog
96%doc examples
97
98%defattr(644, root, root, 755)
99%dir %{python_sitearch}/gtk-2.0
100%dir %{python_sitearch}/gtk-2.0/gtk
101%{python_sitearch}/gtk-2.0/gtk/*.py*
102%dir %{_libdir}/pygtk
103%dir %{_libdir}/pygtk/2.0
104%{_libdir}/pygtk/2.0/*
105
106%defattr(755, root, root, 755)
107%{_bindir}/pygtk-demo
108%{python_sitearch}/gtk-2.0/atk.so
109%{python_sitearch}/gtk-2.0/pango.so
110%{python_sitearch}/gtk-2.0/gtk/_gtk.so
111%{python_sitearch}/gtk-2.0/gtkunixprint.so
112%{python_sitearch}/gtk-2.0/pangocairo.so
113
114%if %{buildglade}
115%files libglade
116%defattr(755, root, root, 755)
117%{_libdir}/python?.?/site-packages/gtk-2.0/gtk/glade.so
118%endif
119
120%files devel
121%defattr(644, root, root, 755)
122%dir %{_includedir}/pygtk-2.0
123%dir %{_includedir}/pygtk-2.0/pygtk
124%{_includedir}/pygtk-2.0/pygtk/*.h
125%{_libdir}/pkgconfig/pygtk-2.0.pc
126%dir %{_datadir}/pygtk
127%dir %{_datadir}/pygtk/2.0
128%dir %{_datadir}/pygtk/2.0/defs
129%{_datadir}/pygtk/2.0/defs/*.defs
130%{_datadir}/pygtk/2.0/defs/pangocairo.override
131%{_datadir}/gtk-doc/html/pygtk
132%defattr(755, root, root, 755)
133%{_bindir}/pygtk-codegen-2.0
134
135%changelog
136* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
137- new upstream release
138- rebuild with python-2.6
139
140* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-1
141- new upstream release
142
143* Fri Jul 18 2008 Shu KONNO <owa@bg.wakwak.com> 2.12.1-2vl5
144- rebuilt with python-2.5.2
145
146* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-1vl5
147- rebuilt with python-2.4.5
148- used %%{?_dist_release} macro
149
150* Fri Jan 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-0vl1
151- new upstream release
152
153* Sun Nov 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.0-0vl1
154- new upstream release
155
156* Sat Jul  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.5-0vl1
157- new upstream release
158
159* Mon Apr 30 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.4-0vl2
160- added Requires pygobject-devel to devel package
161
162* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.4-0vl1
163- new upstream release
164- add Requires/BuildRequires pygobject,pycairo
165
166* Thu Jun 22 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.6-0vl1
167- new upstream release 2.8.6
168
169* Fri Jan 13 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.4-0vl1
170- new upstream release 2.8.4
171- added japanese summary and description
172
173* Tue Oct 18 2005 Shu KONNO <owa@bg.wakwak.com> 2.8.2-0vl1
174- new upstream release 2.8.2
175
176* Sat Oct  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.1-0vl1
177- new upstream release 2.8.1
178- added %clean sectioin
179
180* Sat Sep 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.0-0vl1
181- new upstream release 2.8.0
182
183* Mon Apr 04 2005 Shu KONNO <owa@bg.wakwak.com> 2.6.1-0vl1
184- new upstream release 2.6.1
185
186* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl2
187- rebuild with python-2.4.1-0vl1
188
189* Sun Dec 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
190- new upstream release
191
192* Sat Jun 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.0-1vl1
193- updated to 2.2.0
194
195* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.0.0-1vl4
196- rebuild with python-2.3.3-0vl1
197
198* Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 2.0.0-1vl3.1
199- rebuild with python-2.3.3-0vl0.3 (for TestPkg)
200
201* Thu Sep 18 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0-1vl3
202- added missing %%defattr
203
204* Wed Sep 17 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.0.0-1vl2
205- added Provides and Obsoletes pygtk
206
207* Sun Sep 16 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0-1vl1
208- new upstream release (based on Redhat Rawhide 2.0.0-1)
209  * Thu Aug  7 2003 Elliot Lee <sopwith@redhat.com> 1.99.16-10
210  - Fix libtool
211  * Fri Jul 18 2003 Jeremy Katz <katzj@redhat.com> 1.99.16-8
212  - part of the fixnew patch wasn't applied upstream, apply it (#99400)
213
214* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.99.14-0vl1
215- new upstream release
216- build for Vine Linux
217
218* Thu Oct 31 2002 Matt Wilson <msw@redhat.com>
219- rebuild for multilib
220- use %%configure
221
222* Fri Aug 30 2002 Matt Wilson <msw@redhat.com>
223- fix pixbuf leaks (#72137)
224- five more pixbuf leaks plugged
225
226* Wed Aug 28 2002 Jonathan Blandford <jrb@redhat.com>
227- remover Packager tag
228
229* Tue Aug 27 2002 Jonathan Blandford <jrb@redhat.com>
230- add binding for gdk_atom_intern
231
232* Mon Jul 29 2002 Matt Wilson <msw@redhat.com>
233- 0.99.12
234
235* Wed Jul 17 2002 Matt Wilson <msw@redhat.com>
236- new version from CVS
237
238* Thu Jun 27 2002 Tim Waugh <twaugh@redhat.com>
239- Fix bug #65770.
240
241* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
242- automated rebuild
243
244* Mon Jun 17 2002 Matt Wilson <msw@redhat.com>
245- new version from CVS
246
247* Sun May 26 2002 Tim Powers <timp@redhat.com>
248- automated rebuild
249
250* Wed May 22 2002 Jeremy Katz <katzj@redhat.com>
251- 1.99.10
252
253* Wed Feb 27 2002 Matt Wilson <msw@redhat.com>
254- 1.99.8
255
256* Mon Jan 28 2002 Matt Wilson <msw@redhat.com>
257- added atkmodule.so to file list
258
259* Thu Oct 18 2001 Matt Wilson <msw@redhat.com>
260- fix devel filelist to match new header location
261
262* Mon Oct 15 2001 Matt Wilson <msw@redhat.com>
263- get the headers from their new version-specific location
264
265* Thu Oct 11 2001 Matt Wilson <msw@redhat.com>
266- fixed typo in devel filelist
267- added macro that tests to see if we have libglade2, make the
268  filelist a condition of that
269- changed name to 'pygtk2' to avoid name conflict with pygtk
270
Note: See TracBrowser for help on using the repository browser.