source: projects/specs/trunk/p/pygtk2/pygtk2-vl.spec @ 1881

Revision 1881, 8.5 KB checked in by inagaki, 14 years ago (diff)

update: pygobject, pycairo, pygtk2

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3%define buildglade %(pkg-config libglade-2.0 && echo 1 || echo 0)
4%define pyver %(python -c 'import sys;print(sys.version[0:3])')
5
6Summary: Python bindings for the GTK+ widget set.
7Summary(ja): GTK+ ウィジットセットの Python 実装
8Name: pygtk2
9Version: 2.21.0
10Release: 1%{?_dist_release}
11
12Group: Development/Languages
13License: LGPLv2
14Source: ftp://ftp.gnome.org/pub/GNOME/sources/pygtk/2.21/pygtk-%{version}.tar.bz2
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17
18Buildrequires: python-devel >= 2.5
19Buildrequires: libglade2-devel >= 2.5.0
20BuildRequires: gtk2-devel >= 2.16.0
21BuildRequires: pygobject-devel >= 2.16.0
22BuildRequires: pycairo-devel >= 1.8.2
23BuildRequires: python-numeric
24BuildRequires: docbook-style-xsl
25BuildRequires: libxslt
26Buildrequires: automake >= 1.6.3-5
27
28Requires: pygobject
29Requires: pycairo
30Requires: python-numeric
31
32Obsoletes: pygtk
33
34%description
35PyGTK is an extension module for python that gives you access to the GTK+
36widget set.  Just about anything you can write in C with GTK+ you can write
37in python with PyGTK (within reason), but with all the benefits of python.
38
39%description -l ja
40PyGTK は GTK+ ウィジットセットへアクセス可能にする python の拡張モジュール
41です。 C で GTK+ を使用して書けることは、大概 python で PyGTK を利用して書
42けます。 python のおかげでもあります。
43
44%package libglade
45Summary: A wrapper for the libglade library for use with PyGTK
46Summary(ja): PyGTK を利用するための libglade ライブラリのラッパ
47Group: Development/Libraries
48Requires: pygtk2 = %{version}
49
50%description libglade
51This module contains a wrapper for the libglade library.  Libglade allows
52a program to construct its user interface from an XML description, which
53allows the programmer to keep the UI and program logic separate.
54
55%description -l ja libglade
56このモジュールは libglade ライブラリのためのラッパを含んでいます。libglade は
57プログラムのユーザインタフェースを XML 記述で構成することを可能にします。この
58ためプログラマは、プログラムの UI とロジックを分離させておくことができます。
59
60%package devel
61Summary: files needed to build wrappers for GTK+ addon libraries
62Summary(ja): GTK+ の追加ライブラリのラッパ作成に必要なファイル
63Group: Development/Libraries
64Requires: pygtk2 = %{version}
65Requires: pygobject-devel >= 2.12.0
66
67%description devel
68This package contains files required to build wrappers for GTK+ addon
69libraries so that they interoperate with pygtk.
70
71%description -l ja devel
72このパッケージには GTK+ の追加ライブラリのラッパを作るために必要なファイルを含
73みます。これらは PyGTK との仲介をします。
74
75%prep
76%setup -q -n pygtk-%{version}
77
78%build
79[ -x /usr/bin/python%{pyver} ] && export PYTHON=/usr/bin/python%{pyver}
80#aclocal && automake && autoconf
81%configure --enable-thread --enable-numpy
82export tagname=CC
83make LIBTOOL=/usr/bin/libtool
84
85%install
86rm -rf $RPM_BUILD_ROOT
87export tagname=CC
88make LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT install
89find $RPM_BUILD_ROOT -name '*.la' -or -name '*.a' | xargs rm -f
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%files
95%defattr(-,root,root)
96%doc AUTHORS NEWS README MAPPING ChangeLog
97%doc examples
98
99%defattr(644, root, root, 755)
100%dir %{python_sitearch}/gtk-2.0
101%dir %{python_sitearch}/gtk-2.0/gtk
102%{python_sitearch}/gtk-2.0/gtk/*.py*
103%dir %{_libdir}/pygtk
104%dir %{_libdir}/pygtk/2.0
105%{_libdir}/pygtk/2.0/*
106
107%defattr(755, root, root, 755)
108%{_bindir}/pygtk-demo
109%{python_sitearch}/gtk-2.0/atk.so
110%{python_sitearch}/gtk-2.0/pango.so
111%{python_sitearch}/gtk-2.0/gtk/_gtk.so
112%{python_sitearch}/gtk-2.0/gtkunixprint.so
113%{python_sitearch}/gtk-2.0/pangocairo.so
114
115%if %{buildglade}
116%files libglade
117%defattr(755, root, root, 755)
118%{_libdir}/python?.?/site-packages/gtk-2.0/gtk/glade.so
119%endif
120
121%files devel
122%defattr(644, root, root, 755)
123%dir %{_includedir}/pygtk-2.0
124%dir %{_includedir}/pygtk-2.0/pygtk
125%{_includedir}/pygtk-2.0/pygtk/*.h
126%{_libdir}/pkgconfig/pygtk-2.0.pc
127%dir %{_datadir}/pygtk
128%dir %{_datadir}/pygtk/2.0
129%dir %{_datadir}/pygtk/2.0/defs
130%{_datadir}/pygtk/2.0/defs/*.defs
131%{_datadir}/pygtk/2.0/defs/pangocairo.override
132%{_datadir}/gtk-doc/html/pygtk
133%defattr(755, root, root, 755)
134%{_bindir}/pygtk-codegen-2.0
135
136%changelog
137* Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-1
138- new upstream release
139
140* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
141- new upstream release
142- rebuild with python-2.6
143
144* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-1
145- new upstream release
146
147* Fri Jul 18 2008 Shu KONNO <owa@bg.wakwak.com> 2.12.1-2vl5
148- rebuilt with python-2.5.2
149
150* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-1vl5
151- rebuilt with python-2.4.5
152- used %%{?_dist_release} macro
153
154* Fri Jan 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-0vl1
155- new upstream release
156
157* Sun Nov 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.0-0vl1
158- new upstream release
159
160* Sat Jul  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.5-0vl1
161- new upstream release
162
163* Mon Apr 30 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.4-0vl2
164- added Requires pygobject-devel to devel package
165
166* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.4-0vl1
167- new upstream release
168- add Requires/BuildRequires pygobject,pycairo
169
170* Thu Jun 22 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.6-0vl1
171- new upstream release 2.8.6
172
173* Fri Jan 13 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.4-0vl1
174- new upstream release 2.8.4
175- added japanese summary and description
176
177* Tue Oct 18 2005 Shu KONNO <owa@bg.wakwak.com> 2.8.2-0vl1
178- new upstream release 2.8.2
179
180* Sat Oct  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.1-0vl1
181- new upstream release 2.8.1
182- added %clean sectioin
183
184* Sat Sep 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.0-0vl1
185- new upstream release 2.8.0
186
187* Mon Apr 04 2005 Shu KONNO <owa@bg.wakwak.com> 2.6.1-0vl1
188- new upstream release 2.6.1
189
190* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl2
191- rebuild with python-2.4.1-0vl1
192
193* Sun Dec 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
194- new upstream release
195
196* Sat Jun 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.0-1vl1
197- updated to 2.2.0
198
199* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.0.0-1vl4
200- rebuild with python-2.3.3-0vl1
201
202* Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 2.0.0-1vl3.1
203- rebuild with python-2.3.3-0vl0.3 (for TestPkg)
204
205* Thu Sep 18 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0-1vl3
206- added missing %%defattr
207
208* Wed Sep 17 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.0.0-1vl2
209- added Provides and Obsoletes pygtk
210
211* Sun Sep 16 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0-1vl1
212- new upstream release (based on Redhat Rawhide 2.0.0-1)
213  * Thu Aug  7 2003 Elliot Lee <sopwith@redhat.com> 1.99.16-10
214  - Fix libtool
215  * Fri Jul 18 2003 Jeremy Katz <katzj@redhat.com> 1.99.16-8
216  - part of the fixnew patch wasn't applied upstream, apply it (#99400)
217
218* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.99.14-0vl1
219- new upstream release
220- build for Vine Linux
221
222* Thu Oct 31 2002 Matt Wilson <msw@redhat.com>
223- rebuild for multilib
224- use %%configure
225
226* Fri Aug 30 2002 Matt Wilson <msw@redhat.com>
227- fix pixbuf leaks (#72137)
228- five more pixbuf leaks plugged
229
230* Wed Aug 28 2002 Jonathan Blandford <jrb@redhat.com>
231- remover Packager tag
232
233* Tue Aug 27 2002 Jonathan Blandford <jrb@redhat.com>
234- add binding for gdk_atom_intern
235
236* Mon Jul 29 2002 Matt Wilson <msw@redhat.com>
237- 0.99.12
238
239* Wed Jul 17 2002 Matt Wilson <msw@redhat.com>
240- new version from CVS
241
242* Thu Jun 27 2002 Tim Waugh <twaugh@redhat.com>
243- Fix bug #65770.
244
245* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
246- automated rebuild
247
248* Mon Jun 17 2002 Matt Wilson <msw@redhat.com>
249- new version from CVS
250
251* Sun May 26 2002 Tim Powers <timp@redhat.com>
252- automated rebuild
253
254* Wed May 22 2002 Jeremy Katz <katzj@redhat.com>
255- 1.99.10
256
257* Wed Feb 27 2002 Matt Wilson <msw@redhat.com>
258- 1.99.8
259
260* Mon Jan 28 2002 Matt Wilson <msw@redhat.com>
261- added atkmodule.so to file list
262
263* Thu Oct 18 2001 Matt Wilson <msw@redhat.com>
264- fix devel filelist to match new header location
265
266* Mon Oct 15 2001 Matt Wilson <msw@redhat.com>
267- get the headers from their new version-specific location
268
269* Thu Oct 11 2001 Matt Wilson <msw@redhat.com>
270- fixed typo in devel filelist
271- added macro that tests to see if we have libglade2, make the
272  filelist a condition of that
273- changed name to 'pygtk2' to avoid name conflict with pygtk
274
Note: See TracBrowser for help on using the repository browser.