source: projects/specs/trunk/p/pygobject3/pygobject3-vl.spec @ 5701

Revision 5701, 2.9 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3Name: pygobject3
4Summary: Python bindings for GObject Introspection
5Summary(ja): GObject Introspection の Python バインディング
6Version: 3.0.4
7Release: 2%{?_dist_release}
8
9Group: Development/Languages
10License: LGPL
11URL: http://www.pygtk.org/
12
13Source: http://ftp.gnome.org/pub/GNOME/sources/pygobject/3.0/pygobject-%{version}.tar.xz
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: glib2-devel >= 2.26.0
17BuildRequires: python-devel >= 2.6
18BuildRequires: libffi-devel
19BuildRequires: libtool, automake
20BuildRequires: gobject-introspection-devel >= 0.9.8
21BuildRequires: pycairo-devel >= 1.8.10
22
23Vendor: Project Vine
24Distribution: Vine Linux
25Packager: Takemikaduchi
26
27%description
28pygobject provides a convenient wrapper for the GObject library
29for use in Python programs.
30
31%package devel
32Summary: Development files for building add-on libraries
33Group: Development/Libraries
34Requires: %{name} = %{version}-%{release}
35#Requires: pygobject-doc = %{version}-%{release}
36Requires: glib2-devel
37Requires: libffi-devel
38Requires: pkgconfig
39
40%description devel
41This package contains files required to build wrappers for
42pygobject-based libraries such as pygtk2.
43
44%package doc
45Summary: Documentation files for pygobject
46Group: Documentation
47BuildArch: noarch
48
49%description doc
50This package contains documentation files for pygobject.
51
52%prep
53%setup -q -n pygobject-%{version}
54
55%build
56# --disable-docs doesn't work; it builds the docs anyway.
57%configure \
58    --enable-silent-rules \
59    --disable-static \
60    --enable-thread
61export tagname=CC
62make LIBTOOL=/usr/bin/libtool
63
64%install
65rm -rf $RPM_BUILD_ROOT
66export tagname=CC
67make LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT install
68find $RPM_BUILD_ROOT -name '*.la' -or -name '*.a' | xargs rm -f
69
70rm -f examples/Makefile*
71
72# conflict with pygobject
73rm -rf $RPM_BUILD_ROOT%{python_sitearch}/gtk-2.0
74rm -rf $RPM_BUILD_ROOT%{_datadir}/pygobject
75
76%clean
77rm -fr $RPM_BUILD_ROOT
78
79%files
80%defattr(644, root, root, 755)
81%doc AUTHORS NEWS README ChangeLog
82%doc examples
83%{_libdir}/libpyglib-gi-2.0-python.so.*
84%{python_sitearch}/gi
85
86%files devel
87%defattr(644, root, root, 755)
88%{_includedir}/pygobject-3.0/pygobject.h
89%{_libdir}/libpyglib-gi-2.0-python.so
90%{_libdir}/pkgconfig/pygobject-3.0.pc
91
92%files doc
93%defattr(644, root, root, 755)
94
95%changelog
96* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.4-2
97- rebuild with python-2.7.2
98
99* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.4-1
100- new upstream release
101
102* Thu Nov 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
103- new upstream release
104
105* Thu Oct 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-1
106- new upstream release
107
108* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.0-1
109- new upstream release
110
111* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.90.3-1
112- initial build for Vine Linux
113
Note: See TracBrowser for help on using the repository browser.