source: projects/specs/trunk/p/pygobject3/pygobject3-vl.spec @ 12469

Revision 12469, 5.3 KB checked in by tomop, 4 years ago (diff)

python-3.8.5 and related packages.

Line 
1%bcond_without python2
2%bcond_without python3
3
4Name: pygobject3
5Summary: Python bindings for GObject Introspection
6Summary(ja): GObject Introspection の Python バインディング
7Version: 3.36.1
8Release: 1%{?_dist_release}
9Group: programming
10Vendor: Project Vine
11Distribution: Vine Linux
12
13License: LGPL
14URL: https://pypi.org/project/PyGObject/
15%global shortver %(echo "%{version}" | sed -e 's/\.[0-9]*$//')
16Source: https://ftp.gnome.org/pub/GNOME/sources/pygobject/%{shortver}/pygobject-%{version}.tar.xz
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: glib2-devel >= 2.26.0
20BuildRequires: python-devel >= 2.6
21BuildRequires: libffi-devel
22BuildRequires: libtool, automake
23BuildRequires: gobject-introspection-devel >= 0.9.8
24BuildRequires: python-rpm-macros
25%if %{with python2}
26BuildRequires: python-devel >= 2.6
27BuildRequires: python-setuptools
28BuildRequires: python2-rpm-macros
29BuildRequires: python2-pycairo-devel >= 1.8.10
30%endif
31
32Obsoletes:      %{name}-doc < 3.10.0
33
34%description
35pygobject provides a convenient wrapper for the GObject library
36for use in Python programs.
37
38
39%package devel
40Summary: Development files for building add-on libraries
41Group: programming
42Provides: python3-pygobject-devel = %{version}-%{release}
43Requires: %{name} = %{version}-%{release}
44Requires: glib2-devel
45Requires: libffi-devel
46Requires: pkgconfig
47
48%description devel
49This package contains files required to build wrappers for
50pygobject-based libraries such as pygtk2.
51
52
53%if %{with python3}
54%package -n python3-pygobject
55Summary: Python3 bindings for GObject Introspection
56Summary(ja): GObject Introspection の Python3 バインディング
57Group: programming
58BuildRequires: python3-devel
59BuildRequires: python3-setuptools
60BuildRequires: python3-rpm-macros
61BuildRequires: python3-pycairo-devel
62Obsoletes: python3-pygobject < 3.16.1
63
64%description -n python3-pygobject
65python3-pygobject provides a convenient wrapper for the GObject library
66for use in Python3 programs.
67%endif
68
69
70%prep
71%setup -q -n pygobject-%{version}
72
73
74%build
75%if %{with python2}
76%py_build
77%endif
78%if %{with python3}
79%py3_build
80%endif
81
82
83%install
84rm -rf $RPM_BUILD_ROOT
85%if %{with python2}
86%py_install
87%endif
88%if %{with python3}
89%py3_install
90%endif
91
92
93%clean
94rm -fr $RPM_BUILD_ROOT
95
96%if %{with python2}
97%files
98%defattr(-,root,root,-)
99%license COPYING
100%doc NEWS README*
101%doc examples
102%{_libdir}/python2.7/site-packages/pygtkcompat
103%{python_sitearch}/*.egg-info
104%{python_sitearch}/gi
105%endif
106
107%files devel
108%defattr(-,root,root,-)
109%{_includedir}/pygobject-3.0/pygobject.h
110%{_libdir}/pkgconfig/pygobject-3.0.pc
111
112%if %{with python3}
113%files -n python3-pygobject
114%defattr(-,root,root,-)
115%license COPYING
116%doc NEWS README*
117%{python3_sitearch}/pygtkcompat
118%{python3_sitearch}/*.egg-info
119%{python3_sitearch}/gi
120%endif
121
122
123%changelog
124* Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.36.1-1
125- new upstream release.
126
127* Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.34.0-1
128- new upstream release.
129
130* Fri Jul 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.1-1
131- new upstream release
132
133* Thu Nov 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.2-2
134- fix spec file
135
136* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.2-1
137- new upstream release
138
139* Sun Jun 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
140- new upstream release
141
142* Sun Apr 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
143- new upstream release
144- create python3-pygobject subpackage
145
146* Mon Mar 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
147- new upstream release
148
149* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
150- new upstream release
151
152* Fri Jun 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
153- new upstream release
154
155* Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
156- new upstream release
157
158* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
159- new upstream release
160
161* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
162- new upstream release
163
164* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
165- new upstream release
166- remove doc subpackage
167
168* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
169- new upstream release
170
171* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
172- new upstream release
173
174* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
175- new upstream release
176
177* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
178- new upstream release
179
180* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
181- new upstream release
182
183* Thu Oct 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1.1-1
184- new upstream release
185
186* Thu Sep 27 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.0-1
187- new upstream release
188
189* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
190- new upstream release
191
192* Sat Mar 31 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
193- new upstream release
194
195* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.4-2
196- rebuild with python-2.7.2
197
198* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.4-1
199- new upstream release
200
201* Thu Nov 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
202- new upstream release
203
204* Thu Oct 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-1
205- new upstream release
206
207* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.0-1
208- new upstream release
209
210* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.90.3-1
211- initial build for Vine Linux
212
Note: See TracBrowser for help on using the repository browser.