source: projects/specs/trunk/p/pygobject/pygobject-vl.spec @ 2041

Revision 2041, 6.3 KB checked in by Takemikaduchi, 14 years ago (diff)

update to GNOME-2.32.0

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3Name: pygobject
4Summary: Python bindings for GObject
5Summary(ja): GObject の Python バインディング
6Version: 2.26.0
7Release: 1%{?_dist_release}
8
9Group: Development/Languages
10License: LGPL
11URL: http://www.pygtk.org/
12
13Source: http://ftp.gnome.org/pub/GNOME/sources/pygobject/2.26/pygobject-%{version}.tar.bz2
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: glib2-devel >= 2.26.0
17BuildRequires: python-devel >= 2.6
18BuildRequires: libffi-devel
19BuildRequires: libtool, automake
20BuildRequires: gobject-introspection-devel >= 0.9.8
21BuildRequires: pycairo-devel >= 1.8.10
22
23Vendor: Project Vine
24Distribution: Vine Linux
25Packager: daisuke
26
27%description
28pygobject provides a convenient wrapper for the GObject library
29for use in Python programs.
30
31%package devel
32Summary: Development files for building add-on libraries
33Group: Development/Libraries
34Requires: pygobject = %{version}-%{release}
35#Requires: pygobject-doc = %{version}-%{release}
36Requires: glib2-devel
37Requires: libffi-devel
38Requires: pkgconfig
39
40%description devel
41This package contains files required to build wrappers for
42pygobject-based libraries such as pygtk2.
43
44%package doc
45Summary: Documentation files for pygobject
46Group: Documentation
47
48%description doc
49This package contains documentation files for pygobject.
50
51%prep
52%setup -q
53
54%build
55# --disable-docs doesn't work; it builds the docs anyway.
56%configure \
57    --enable-silent-rules \
58    --disable-static \
59    --enable-thread \
60    --enable-introspection=yes \
61    --disable-docs
62export tagname=CC
63make LIBTOOL=/usr/bin/libtool
64
65%install
66rm -rf $RPM_BUILD_ROOT
67export tagname=CC
68make LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT install
69find $RPM_BUILD_ROOT -name '*.la' -or -name '*.a' | xargs rm -f
70
71rm -f examples/Makefile*
72
73%clean
74rm -fr $RPM_BUILD_ROOT
75
76%files
77%defattr(644, root, root, 755)
78%doc AUTHORS NEWS README ChangeLog
79%doc examples
80
81%{_libdir}/libpyglib-2.0-python.so.*
82%dir %{python_sitearch}/gtk-2.0
83%{python_sitearch}/gtk-2.0/dsextras.*
84%{python_sitearch}/pygtk.*
85
86%defattr(755, root, root, 755)
87%{python_sitearch}/gtk-2.0/gio
88%{python_sitearch}/gtk-2.0/glib
89%{python_sitearch}/gtk-2.0/gobject
90%{python_sitearch}/gtk-2.0/gi
91
92%files devel
93%defattr(755, root, root, 755)
94%{_bindir}/pygobject-codegen-2.0
95%defattr(644, root, root, 755)
96%dir %{_datadir}/pygobject
97%dir %{_datadir}/pygobject/2.0
98%dir %{_includedir}/pygtk-2.0
99%{_datadir}/pygobject/2.0/codegen
100%{_datadir}/pygobject/2.0/defs
101%{_datadir}/pygobject/xsl
102%{_includedir}/pygtk-2.0/pyglib.h
103%{_includedir}/pygtk-2.0/pygobject.h
104%{_libdir}/libpyglib-2.0-python.so
105%{_libdir}/pkgconfig/pygobject-2.0.pc
106
107%files doc
108%defattr(644, root, root, 755)
109%{_datadir}/gtk-doc/html/pygobject
110
111%changelog
112* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.0-1
113- new upstream release
114- add BuildRequires: gobject-introspection-devel, pycairo-devel
115- change configure option --enable-introspection=yes instead of --disable-introspection
116
117* Thu Sep 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.21.5-1
118- new upstream release
119- added --disable-intropection option (it needs gobject-introspection >= 0.9)
120- moved xsl files to devel package
121- built with rpm-4.8.1
122
123* Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.1-1
124- new upstream release
125
126* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.0-3
127- build for python-2.6
128
129* Wed Dec  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-2
130- added Requires: libffi-devel to devel package <BTS:830>
131
132* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-1
133- new upstream release
134
135* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.1-1
136- new upstream release
137
138* Sat Jan 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.0-1
139- new upstream release
140
141* Sat Oct 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.4-1
142- new upstream release
143
144* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 2.14.2-2
145- rebuilt with python-2.5.2
146
147* Tue May 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-1
148- new upstream release
149- spec in UTF-8
150
151* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-1vl5
152- rebuilt with python-2.4.5 and glib2-2.16.1
153- used %%{?_dist_release} macro
154
155* Sun Feb 24 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl1
156- new upstream release
157
158* Sat Nov 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.0-0vl1
159- new upstream release
160- dropped Patch1 (merged into upstream)
161
162* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.3-0vl1
163- initial build for Vine Linux
164
165* Thu Apr 19 2007 Matthew Barnes <mbarnes@redhat.com> - 2.12.3-3.fc7
166- Add patch for RH bug #237179 (memory leak).
167
168* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 2.12.3-2
169- rebuild against python 2.5
170
171* Sat Nov 18 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.3-1.fc7
172- Update to 2.12.3
173
174* Thu Oct 26 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.2-3.fc7
175- Add subpackage pygobject2-doc (bug #205231).
176
177* Tue Oct 24 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.2-2.fc7
178- Use python_sitearch instead of python_sitelib.
179
180* Sun Oct 15 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.2-1.fc7
181- Update to 2.12.2
182
183* Sun Sep 24 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.1-3.fc6
184- Require glib2-devel for the -devel package.
185
186* Fri Sep 22 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.1-2.fc6
187- Define a python_sitelib macro for files under site_packages.
188- Spec file cleanups.
189
190* Tue Sep  5 2006 Matthias Clasen <mclasen@redhat.com> - 2.12.1-1.fc6
191- Update to 2.12.1
192- Require pkgconfig for the -devel package
193
194* Sun Aug 27 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.4-1.fc6
195- Update to 2.11.4
196- Use pre-built docs
197
198* Mon Aug 21 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.3-1.fc6
199- Update to 2.11.3
200
201* Sun Aug 13 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.2-2.fc6
202- BR libxslt
203
204* Sun Aug 13 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.2-1.fc6
205- Update to 2.11.2
206
207* Wed Jul 19 2006 Jesse Keating <jkeating@redhat.com> - 2.11.0-2
208- rebuild
209
210* Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.0-1
211- Update to 2.11.0
212
213* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.10.1-3
214- rebuild
215- Add missing br libtool
216
217* Fri May 19 2006 John (J5) Palmieri <johnp@redhat.com> - 2.10.1-2
218- Cleanup
219
220* Fri May 12 2006 John (J5) Palmieri <johnp@redhat.com> - 2.10.1-1
221- Initial package
Note: See TracBrowser for help on using the repository browser.